aboutsummaryrefslogtreecommitdiff
path: root/www/eaccelerator
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-04-11 08:10:38 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-04-11 08:10:38 +0000
commitfa82ac8165f35592706f244fe3c13740ca2c328c (patch)
tree5e28c79d8ebb7ce54ad3c54f712132ae78e52073 /www/eaccelerator
parent2288ee2ec6af401765f502f3c1f335b7914315f4 (diff)
Notes
Diffstat (limited to 'www/eaccelerator')
-rw-r--r--www/eaccelerator/Makefile27
-rw-r--r--www/eaccelerator/distinfo6
-rw-r--r--www/eaccelerator/files/patch-encoder.php33
-rw-r--r--www/eaccelerator/pkg-descr19
-rw-r--r--www/eaccelerator/pkg-plist1
5 files changed, 15 insertions, 71 deletions
diff --git a/www/eaccelerator/Makefile b/www/eaccelerator/Makefile
index 1885362587ed..5fe680134839 100644
--- a/www/eaccelerator/Makefile
+++ b/www/eaccelerator/Makefile
@@ -6,21 +6,20 @@
#
PORTNAME= eaccelerator
-PORTVERSION= 0.9.5.3
+PORTVERSION= 0.9.6
CATEGORIES= www
-MASTER_SITES= http://bart.eaccelerator.net/source/${PORTVERSION}/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/eAccelerator%20${PORTVERSION}/ \
+ http://bart.eaccelerator.net/source/${PORTVERSION}/
MAINTAINER= ale@FreeBSD.org
-COMMENT= An opcode cache for PHP with encoder and loader
+COMMENT= A free open-source PHP accelerator & optimizer
-USE_PHP= session
+USE_PHP= yes
USE_PHPIZE= yes
USE_PHP_BUILD= yes
+IGNORE_WITH_PHP=4
CONFIGURE_ARGS= --enable-eaccelerator=shared \
- --with-eaccelerator-shared-memory \
- --with-eaccelerator-sessions \
- --with-eaccelerator-content-caching \
--with-eaccelerator-userid=80
USE_BZIP2= yes
@@ -31,24 +30,10 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
-.if ${PHP_VER} == 5
-CONFIGURE_ARGS+= --without-eaccelerator-encoder
-PLIST_SUB+= ENCODER="@comment "
-.else
-PLIST_SUB+= ENCODER=""
-
-post-build:
- @${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g; s|0777|0755|g" \
- ${WRKSRC}/encoder.php > ${WRKSRC}/encoder
-.endif
-
do-install:
@${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}
${INSTALL_DATA} ${WRKSRC}/modules/${PORTNAME}.so \
${PREFIX}/lib/php/${PHP_EXT_DIR}
-.if ${PHP_VER} == 4
- ${INSTALL_SCRIPT} ${WRKSRC}/encoder ${PREFIX}/bin
-.endif
post-install:
.if !defined(NOPORTDOCS)
diff --git a/www/eaccelerator/distinfo b/www/eaccelerator/distinfo
index a240b85e6026..93f9ed1e0397 100644
--- a/www/eaccelerator/distinfo
+++ b/www/eaccelerator/distinfo
@@ -1,3 +1,3 @@
-MD5 (eaccelerator-0.9.5.3.tar.bz2) = caf797223739516882f870342f74b935
-SHA256 (eaccelerator-0.9.5.3.tar.bz2) = aa4f0e7817e0193d698db71cc858f45461c2820266941ae2034eb1b82c379e45
-SIZE (eaccelerator-0.9.5.3.tar.bz2) = 555631
+MD5 (eaccelerator-0.9.6.tar.bz2) = 85fa6150265a81f0cea852bc973382b9
+SHA256 (eaccelerator-0.9.6.tar.bz2) = ab1f309078d04ede3297b96f6c2689104e349e11e61376866f59c983ddde9a56
+SIZE (eaccelerator-0.9.6.tar.bz2) = 105833
diff --git a/www/eaccelerator/files/patch-encoder.php b/www/eaccelerator/files/patch-encoder.php
deleted file mode 100644
index 1d98b90b98cf..000000000000
--- a/www/eaccelerator/files/patch-encoder.php
+++ /dev/null
@@ -1,33 +0,0 @@
---- encoder.php.orig Fri May 6 10:26:43 2005
-+++ encoder.php Thu Feb 2 09:39:47 2006
-@@ -1,10 +1,12 @@
-+#!%%LOCALBASE%%/bin/php -f
-+
- <?php
- $web_error = "";
-
- function eaccelerator_encoder_usage() {
-- echo "Usage:\tphp -q encoder.php [options] source_file_name\n";
-- echo "\tphp -q encoder.php [options] source_file_name...\n";
-- echo "\tphp -q encoder.php [options] source_directory_name...\n\n";
-+ echo "Usage:\tencoder [options] source_file_name\n";
-+ echo "\tencoder [options] source_file_name...\n";
-+ echo "\tencoder [options] source_directory_name...\n\n";
- echo "Options:\n";
- echo "\t-s suffix\n\t\tencode files only with following suffix (default is \"php\")\n";
- echo "\t-a\n\t\tencode all files (no by default)\n";
-@@ -17,10 +19,10 @@
- echo "\t\tfile name. If you encode directory or several files at once\n";
- echo "\t\tthen 'target' specifyes an output directory name.\n";
- echo "\nExamples:\n";
-- echo "\tphp -q encoder.php some_file.php\n";
-- echo "\tphp -q encoder.php some_file.php -o some_encoded_file.php\n";
-- echo "\tphp -q encoder.php *.php -o some_dir\n";
-- echo "\tphp -q encoder.php ~/public_html/x -rcf -sphp -sinc -o ~/public_html/y\n";
-+ echo "\tencoder some_file.php\n";
-+ echo "\tencoder some_file.php -o some_encoded_file.php\n";
-+ echo "\tencoder *.php -o some_dir\n";
-+ echo "\tencoder ~/public_html/x -rcf -sphp -sinc -o ~/public_html/y\n";
- echo "\n";
- exit();
- }
diff --git a/www/eaccelerator/pkg-descr b/www/eaccelerator/pkg-descr
index d4cbb7124d37..001c06782037 100644
--- a/www/eaccelerator/pkg-descr
+++ b/www/eaccelerator/pkg-descr
@@ -1,17 +1,10 @@
-eAccelerator is a opcode cache for PHP. It increases
-performance of PHP scripts by caching them in compiled state,
-so that the overhead of compiling is almost completely eliminated.
-Also it uses some optimizations for speed up of PHP scripts execution.
-eAccelerator typically reduces server load and increases
-the speed of your PHP code by 1-10 times.
+eAccelerator is a free open-source PHP accelerator & optimizer. It increases
+the performance of PHP scripts by caching them in their compiled state, so
+that the overhead of compiling is almost completely eliminated. It also
+optimizes scripts to speed up their execution. eAccelerator typically reduces
+server load and increases the speed of your PHP code by 1-10 times.
-eAccelerator contains PHP encoder and loader. You can encode any PHP
-scripts with encoder to distribute them without sources. Encoded files
-can be run on any site which runs PHP with eAccelerator. The sources
-of encoded script can't be restored because they are stored in a compiled
-form and the encoded version doesn't contain the source.
-
-WWW: http://eaccelerator.net/
+WWW: http://eaccelerator.net/
- Alex Dupre
ale@FreeBSD.org
diff --git a/www/eaccelerator/pkg-plist b/www/eaccelerator/pkg-plist
index f57cec059c96..b9ec391c4956 100644
--- a/www/eaccelerator/pkg-plist
+++ b/www/eaccelerator/pkg-plist
@@ -1,4 +1,3 @@
-%%ENCODER%%bin/encoder
lib/php/%%PHP_EXT_DIR%%/eaccelerator.so
@dirrmtry lib/php/%%PHP_EXT_DIR%%
%%EXAMPLESDIR%%/control.php