aboutsummaryrefslogtreecommitdiff
path: root/www/elinks
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2007-07-30 14:53:58 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2007-07-30 14:53:58 +0000
commit128c1afc4db23b598f1d1329cc5029dcd5cffb46 (patch)
tree1902597642850cc577f92b4ec900af87e80a592f /www/elinks
parent4e9142821ca4da016cbea422c5980286610b3f9b (diff)
downloadports-128c1afc4db23b598f1d1329cc5029dcd5cffb46.tar.gz
ports-128c1afc4db23b598f1d1329cc5029dcd5cffb46.zip
Notes
Diffstat (limited to 'www/elinks')
-rw-r--r--www/elinks/Makefile3
-rw-r--r--www/elinks/files/patch-src_scripting_lua_Makefile11
2 files changed, 13 insertions, 1 deletions
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index 7d4978c36d5e..e683ef767af4 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -7,7 +7,7 @@
PORTNAME= elinks
PORTVERSION= 0.11.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://elinks.or.cz/download/ \
http://keyserver.kjsl.com/~jharris/distfiles/
@@ -79,6 +79,7 @@ USE_LUA= 5.0
CONFIGURE_ARGS+= --with-lua
CPPFLAGS+= -I${LUA_INCDIR}
LDFLAGS+= -L${LUA_LIBDIR}
+CONFIGURE_ENV+= "CPPFLAGS=${CPPFLAGS}"
.else
CONFIGURE_ARGS+= --without-lua
.endif
diff --git a/www/elinks/files/patch-src_scripting_lua_Makefile b/www/elinks/files/patch-src_scripting_lua_Makefile
new file mode 100644
index 000000000000..5c71bc947eea
--- /dev/null
+++ b/www/elinks/files/patch-src_scripting_lua_Makefile
@@ -0,0 +1,11 @@
+--- src/scripting/lua/Makefile.orig 2007-07-30 16:17:41.000000000 +0200
++++ src/scripting/lua/Makefile 2007-07-30 16:17:53.000000000 +0200
+@@ -1,7 +1,7 @@
+ top_builddir=../../..
+ include $(top_builddir)/Makefile.config
+
+-INCLUDES += $(LUA_CFLAGS)
++INCLUDES += $(LUA_CFLAGS) $(CPPFLAGS)
+
+ OBJS = lua.o hooks.o core.o
+