aboutsummaryrefslogtreecommitdiff
path: root/www/epiphany-extensions
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-29 23:28:15 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-29 23:28:15 +0000
commit53f4440d95c6c59f4d201ecf4da80b1f44f3a585 (patch)
tree7a56db1cee21d3771052b69e4750ca41e7500c1e /www/epiphany-extensions
parent75b6ed900a3cd736ddb104fcd9876e6f317ca4af (diff)
downloadports-53f4440d95c6c59f4d201ecf4da80b1f44f3a585.tar.gz
ports-53f4440d95c6c59f4d201ecf4da80b1f44f3a585.zip
Notes
Diffstat (limited to 'www/epiphany-extensions')
-rw-r--r--www/epiphany-extensions/Makefile55
1 files changed, 5 insertions, 50 deletions
diff --git a/www/epiphany-extensions/Makefile b/www/epiphany-extensions/Makefile
index 21ecf41939b2..94bb2ab6a0eb 100644
--- a/www/epiphany-extensions/Makefile
+++ b/www/epiphany-extensions/Makefile
@@ -18,44 +18,19 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A set of add-ons for the Epiphany web browser
-BUILD_DEPENDS= epiphany:${PORTSDIR}/www/epiphany \
- ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-RUN_DEPENDS= epiphany:${PORTSDIR}/www/epiphany \
- ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-
-MOZILLA= mozilla
-HEADERS_SUFX=
-MOZ_BUILD= mozilla
-
-.if !defined(WITH_MOZILLA)
-MOZILLA= firefox
-HEADERS_SUFX=
-MOZ_BUILD= firefox
-.else
-.if ${WITH_MOZILLA}=="mozilla"
-MOZILLA= mozilla
-MOZ_BUILD= mozilla
-.else
-.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
-MOZILLA= mozilla-devel
-HEADERS_SUFX= -devel
-.else
-MOZILLA= firefox
-HEADERS_SUFX=
-MOZ_BUILD= firefox
-.endif
-.endif
-.endif
+BUILD_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
+RUN_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_GECKO= firefox mozilla seamonkey
USE_GNOME= gnomeprefix gnomehack intlhack gnometarget
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-extensions="all" \
- --with-mozilla=${MOZ_BUILD}
+ --with-mozilla=${GECKO}
PLIST_SUB= VERSION="1.8" EPHY_VERSION="1.8"
@@ -65,6 +40,7 @@ WITH_OPENSP= yes
.endif
.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
.if exists(${LOCALBASE}/lib/libosp.so)
WITH_OPENSP= yes
@@ -76,30 +52,9 @@ CONFIGURE_ARGS+= --enable-opensp=yes
CONFIGURE_ARGS+= --disable-opensp
.endif
-.if ${OSVERSION} < 500000
-.if ${MOZILLA}=="mozilla-devel"
-USE_GCC= 3.4
-.endif
-.endif
-
pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} " By default epiphany-extensions builds with www/firefox support, but you can"
- @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
- @${ECHO_MSG}
- @${ECHO_MSG} " mozilla "
- @${ECHO_MSG} " mozilla-devel "
- @${ECHO_MSG} ""
@${ECHO_MSG} "Epiphany-extensions also supports the following tunable option(s):"
@${ECHO_MSG} " WITH_OPENSP=yes Enable support for OpenSP SGML validation"
@${ECHO_MSG} ""
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g; \
- s|mozilla-xpcom|mozilla-xpcom${HEADERS_SUFX}|g; \
- s|$$MOZILLA-gtkmozembed|$$MOZILLA-gtkmozembed${HEADERS_SUFX}|g; \
- s|$$MOZILLA-xpcom|$$MOZILLA-xpcom${HEADERS_SUFX}|g' \
- ${WRKSRC}/configure
-
.include <bsd.port.post.mk>