aboutsummaryrefslogtreecommitdiff
path: root/www/epiphany-extensions
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /www/epiphany-extensions
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
downloadports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.tar.gz
ports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.zip
Notes
Diffstat (limited to 'www/epiphany-extensions')
-rw-r--r--www/epiphany-extensions/Makefile21
-rw-r--r--www/epiphany-extensions/distinfo6
-rw-r--r--www/epiphany-extensions/pkg-plist71
3 files changed, 54 insertions, 44 deletions
diff --git a/www/epiphany-extensions/Makefile b/www/epiphany-extensions/Makefile
index 6cd0ed6851d9..915de298e6f5 100644
--- a/www/epiphany-extensions/Makefile
+++ b/www/epiphany-extensions/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/epiphany-extensions/Makefile,v 1.88 2007/03/11 20:34:21 mezz Exp $
+# $MCom: ports/www/epiphany-extensions/Makefile,v 1.101 2007/10/15 22:00:17 mezz Exp $
#
PORTNAME= epiphany-extensions
-PORTVERSION= 2.18.3
-PORTREVISION= 2
+PORTVERSION= 2.20.1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -18,6 +17,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A set of add-ons for the Epiphany web browser
BUILD_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
RUN_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
USE_GETTEXT= yes
@@ -35,12 +35,11 @@ CONFIGURE_ARGS= --with-mozilla=${GECKO}
GCONF_SCHEMAS= smart-bookmarks.schemas
EPHY_EXTENSIONS=all,rss
-EPHY_VERSION= 2.18
+EPHY_VERSION= 2.20
-PLIST_SUB= VERSION="2.18" EPHY_VERSION=${EPHY_VERSION}
+PLIST_SUB= VERSION="2.20" EPHY_VERSION=${EPHY_VERSION}
-OPTIONS= OPENSP "Enable OpenSP SGML support" off \
- ADBLOCK "Enable the adblock extension" on
+OPTIONS= OPENSP "Enable OpenSP SGML support" off
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
@@ -51,14 +50,6 @@ CONFIGURE_ARGS+= --enable-opensp=yes
CONFIGURE_ARGS+= --disable-opensp
.endif
-.if !defined(WITHOUT_ADBLOCK)
-EPHY_EXTENSIONS:= ${EPHY_EXTENSIONS},adblock
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-PLIST_SUB+= ADBLOCK=""
-.else
-PLIST_SUB+= ADBLOCK="@comment "
-.endif
-
.if exists(${LOCALBASE}/share/pygtk/2.0/defs/epiphany.defs)
USE_PYTHON= yes
.include "${PORTSDIR}/Mk/bsd.python.mk"
diff --git a/www/epiphany-extensions/distinfo b/www/epiphany-extensions/distinfo
index 37a96347a87b..44f53585cab1 100644
--- a/www/epiphany-extensions/distinfo
+++ b/www/epiphany-extensions/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/epiphany-extensions-2.18.3.tar.bz2) = 4e55bedcfe7f2f359043eb14b17e8cc4
-SHA256 (gnome2/epiphany-extensions-2.18.3.tar.bz2) = 50063c8bd5d03f0625c287015f7b4d9fcfd320b7405161d1bab40d27d3368682
-SIZE (gnome2/epiphany-extensions-2.18.3.tar.bz2) = 893264
+MD5 (gnome2/epiphany-extensions-2.20.1.tar.bz2) = cd8a247d81960217df4d7c8edfe9fbf8
+SHA256 (gnome2/epiphany-extensions-2.20.1.tar.bz2) = 35a66aa9151f0cbd492435077f4bef30ecb8728e990e29da3e4a5f275a5875d0
+SIZE (gnome2/epiphany-extensions-2.20.1.tar.bz2) = 908577
diff --git a/www/epiphany-extensions/pkg-plist b/www/epiphany-extensions/pkg-plist
index 6b3f2f49c971..f107dc0306ba 100644
--- a/www/epiphany-extensions/pkg-plist
+++ b/www/epiphany-extensions/pkg-plist
@@ -1,5 +1,5 @@
lib/epiphany/%%VERSION%%/extensions/actions.ephy-extension
-%%ADBLOCK%%lib/epiphany/%%VERSION%%/extensions/adblock.ephy-extension
+lib/epiphany/%%VERSION%%/extensions/adblock.ephy-extension
lib/epiphany/%%VERSION%%/extensions/auto-reload.ephy-extension
lib/epiphany/%%VERSION%%/extensions/auto-scroller.ephy-extension
%%PYTHON%%lib/epiphany/%%VERSION%%/extensions/cc-license-viewer.ephy-extension
@@ -20,8 +20,8 @@ lib/epiphany/%%VERSION%%/extensions/gestures.ephy-extension
lib/epiphany/%%VERSION%%/extensions/java-console.ephy-extension
lib/epiphany/%%VERSION%%/extensions/libactionsextension.la
lib/epiphany/%%VERSION%%/extensions/libactionsextension.so
-%%ADBLOCK%%lib/epiphany/%%VERSION%%/extensions/libadblockextension.la
-%%ADBLOCK%%lib/epiphany/%%VERSION%%/extensions/libadblockextension.so
+lib/epiphany/%%VERSION%%/extensions/libadblockextension.la
+lib/epiphany/%%VERSION%%/extensions/libadblockextension.so
lib/epiphany/%%VERSION%%/extensions/libautoreloadextension.la
lib/epiphany/%%VERSION%%/extensions/libautoreloadextension.so
lib/epiphany/%%VERSION%%/extensions/libautoscrollerextension.la
@@ -61,23 +61,23 @@ lib/epiphany/%%VERSION%%/extensions/sidebar.ephy-extension
lib/epiphany/%%VERSION%%/extensions/smart-bookmarks.ephy-extension
lib/epiphany/%%VERSION%%/extensions/tab-groups.ephy-extension
lib/epiphany/%%VERSION%%/extensions/tab-states.ephy-extension
-%%ADBLOCK%%share/gnome/epiphany-extensions/adblock-patterns
-%%ADBLOCK%%share/gnome/epiphany-extensions/adblock-statusbar-icon.svg
-share/gnome/epiphany-extensions/ephy-gestures.xml
-share/gnome/epiphany-extensions/glade/action-properties.glade
-share/gnome/epiphany-extensions/glade/actions-editor.glade
-%%ADBLOCK%%share/gnome/epiphany-extensions/glade/adblock.glade
-share/gnome/epiphany-extensions/glade/error-viewer.glade
-share/gnome/epiphany-extensions/glade/extensions-manager-ui.glade
-share/gnome/epiphany-extensions/glade/page-info.glade
-share/gnome/epiphany-extensions/glade/rss-ui.glade
-share/gnome/epiphany-extensions/xml/epiphany-sidebar-ui.xml
-share/gnome/epiphany-extensions/xml/page-info-context-ui.xml
-share/gnome/epiphany/icons/hicolor/16x16/status/feed-presence.png
-share/gnome/epiphany/icons/hicolor/22x22/status/feed-presence.png
-share/gnome/epiphany/icons/hicolor/24x24/status/feed-presence.png
-share/gnome/epiphany/icons/hicolor/32x32/status/feed-presence.png
-share/gnome/epiphany/icons/hicolor/scalable/status/feed-presence.svg
+%%DATADIR%%/adblock-patterns
+%%DATADIR%%/adblock-statusbar-icon.svg
+%%DATADIR%%/ephy-gestures.xml
+%%DATADIR%%/glade/action-properties.glade
+%%DATADIR%%/glade/actions-editor.glade
+%%DATADIR%%/glade/adblock.glade
+%%DATADIR%%/glade/error-viewer.glade
+%%DATADIR%%/glade/extensions-manager-ui.glade
+%%DATADIR%%/glade/page-info.glade
+%%DATADIR%%/glade/rss-ui.glade
+%%DATADIR%%/xml/epiphany-sidebar-ui.xml
+%%DATADIR%%/xml/page-info-context-ui.xml
+share/epiphany/icons/hicolor/16x16/status/feed-presence.png
+share/epiphany/icons/hicolor/22x22/status/feed-presence.png
+share/epiphany/icons/hicolor/24x24/status/feed-presence.png
+share/epiphany/icons/hicolor/32x32/status/feed-presence.png
+share/epiphany/icons/hicolor/scalable/status/feed-presence.svg
share/gnome/help/epiphany-extensions/C/epiphany-extensions.xml
share/gnome/help/epiphany-extensions/C/figures/epi-ext-action-create.png
share/gnome/help/epiphany-extensions/C/figures/epi-ext-adblocker.png
@@ -119,14 +119,13 @@ share/gnome/help/epiphany-extensions/sv/figures/epi-ext-gestures-view-source-2.p
share/gnome/help/epiphany-extensions/sv/figures/epi-ext-gestures-view-source.png
share/gnome/help/epiphany-extensions/sv/figures/epi-ext-sidebar.png
share/gnome/help/epiphany-extensions/sv/figures/epi-ext-tabgroups.png
-share/gnome/omf/epiphany-extensions/epiphany-extensions-C.omf
-share/gnome/omf/epiphany-extensions/epiphany-extensions-sv.omf
share/locale/ar/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/bg/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/ca/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/cs/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/da/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/de/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
+share/locale/dz/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/el/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/en_CA/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/en_GB/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
@@ -143,6 +142,7 @@ share/locale/lt/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/nb/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/ne/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/nl/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
+share/locale/oc/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/pa/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/pl/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/pt/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
@@ -162,15 +162,30 @@ share/locale/wa/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/zh_CN/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/zh_HK/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
share/locale/zh_TW/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
-@dirrm share/gnome/omf/epiphany-extensions
+share/omf/epiphany-extensions/epiphany-extensions-C.omf
+share/omf/epiphany-extensions/epiphany-extensions-sv.omf
+@dirrm share/omf/epiphany-extensions
@dirrm share/gnome/help/epiphany-extensions/sv/figures
@dirrm share/gnome/help/epiphany-extensions/sv
@dirrm share/gnome/help/epiphany-extensions/C/figures
@dirrm share/gnome/help/epiphany-extensions/C
@dirrm share/gnome/help/epiphany-extensions
-@dirrm share/gnome/epiphany-extensions/xml
-@dirrm share/gnome/epiphany-extensions/glade
-@dirrm share/gnome/epiphany-extensions
+@dirrmtry share/epiphany/icons/hicolor/scalable/status
+@dirrmtry share/epiphany/icons/hicolor/scalable
+@dirrmtry share/epiphany/icons/hicolor/32x32/status
+@dirrmtry share/epiphany/icons/hicolor/32x32
+@dirrmtry share/epiphany/icons/hicolor/24x24/status
+@dirrmtry share/epiphany/icons/hicolor/24x24
+@dirrmtry share/epiphany/icons/hicolor/22x22/status
+@dirrmtry share/epiphany/icons/hicolor/22x22
+@dirrmtry share/epiphany/icons/hicolor/16x16/status
+@dirrmtry share/epiphany/icons/hicolor/16x16
+@dirrmtry share/epiphany/icons/hicolor
+@dirrmtry share/epiphany/icons
+@dirrmtry share/epiphany
+@dirrm %%DATADIR%%/xml
+@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%
@dirrmtry lib/epiphany/%%VERSION%%/extensions
@dirrmtry lib/epiphany/%%VERSION%%/plugins
@dirrmtry lib/epiphany/%%VERSION%%
@@ -179,3 +194,7 @@ share/locale/zh_TW/LC_MESSAGES/epiphany-extensions-%%EPHY_VERSION%%.mo
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz