aboutsummaryrefslogtreecommitdiff
path: root/www/epiphany
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-05-06 19:41:58 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-05-06 19:41:58 +0000
commitddf5fe9345bb7ab9dfdeb490ad530b4169a457de (patch)
tree9afee409d9bbc07e0b3e81873b1508ad205e9f35 /www/epiphany
parent3930091f767b16edae84cebed0711c76776905d4 (diff)
downloadports-ddf5fe9345bb7ab9dfdeb490ad530b4169a457de.tar.gz
ports-ddf5fe9345bb7ab9dfdeb490ad530b4169a457de.zip
Notes
Diffstat (limited to 'www/epiphany')
-rw-r--r--www/epiphany/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 479017ea7bff..ab04d89fd954 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -59,6 +59,7 @@ EXTRA_CFLAGS+= `pkg-config --cflags WebKitGtk` -I${LOCALBASE}/include/WebKit/web
EXTRA_LIBS+= `pkg-config --libs WebKitGtk`
CONFLICTS= epiphany-[1-9]*
PLIST_SUB+= GECKO="@comment "
+PLUGIN_SYMLINK= 18
.else
USE_GECKO+= firefox libxul
CONFIGURE_ARGS+= --with-gecko=${GECKO} \
@@ -67,6 +68,11 @@ CONFIGURE_ARGS+= --with-gecko=${GECKO} \
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
CONFLICTS= epiphany-webkit-[1-9]*
PLIST_SUB+= GECKO=""
+.if ${GECKO:Mlibxul}!=""
+PLUGIN_SYMLINK= 19
+.else
+PLUGIN_SYMLINK= 18
+.endif
.endif
NO_WERROR= yes
@@ -75,12 +81,6 @@ NO_WERROR= yes
CONFIGURE_ARGS+= --enable-compile-warnings=no
.endif
-.if ${GECKO:Mlibxul}!=""
-PLUGIN_SYMLINK= 19
-.else
-PLUGIN_SYMLINK= 18
-.endif
-
.if ${HAVE_GNOME:Mpygnome2}!=""
USE_PYTHON= yes
.include "${PORTSDIR}/Mk/bsd.python.mk"