aboutsummaryrefslogtreecommitdiff
path: root/www/epiphany
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /www/epiphany
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Notes
Diffstat (limited to 'www/epiphany')
-rw-r--r--www/epiphany/Makefile67
-rw-r--r--www/epiphany/distinfo6
-rw-r--r--www/epiphany/files/extra-patch-embed_ephy-embed-prefs.c12
-rw-r--r--www/epiphany/files/patch-embed_ephy-embed-utils.c10
-rw-r--r--www/epiphany/files/patch-embed_ephy-web-view.c14
-rw-r--r--www/epiphany/files/patch-src_ephy-window.c35
-rw-r--r--www/epiphany/pkg-plist58
7 files changed, 129 insertions, 73 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index d97d89085e46..87c44e7babfa 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/epiphany/Makefile,v 1.195 2009/03/30 03:15:21 marcus Exp $
+# $MCom: ports/www/epiphany/Makefile,v 1.214 2009/10/25 20:22:54 marcus Exp $
#
PORTNAME= epiphany
-PORTVERSION= 2.26.3
-PORTREVISION?= 4
+PORTVERSION= 2.28.1
+PORTREVISION?= 1
CATEGORIES= www gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,11 +16,15 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT?= An extremely lightweight and simple web browser for GNOME 2
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
+ ${LOCALBASE}/share/gir-1.0/WebKit-1.0.gir:${PORTSDIR}/www/gir-repository-webkit
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2 \
+ notify.1:${PORTSDIR}/devel/libnotify \
+ gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
- ${LOCALBASE}/share/icons/HighContrastLargePrint/index.theme:${PORTSDIR}/x11-themes/gnome-themes
+ ${LOCALBASE}/share/gir-1.0/WebKit-1.0.gir:${PORTSDIR}/www/gir-repository-webkit \
+ ${LOCALBASE}/share/icons/HighContrastLargePrint/index.theme:${PORTSDIR}/x11-themes/gnome-themes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
@@ -32,19 +36,20 @@ USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop desktopfileutils
WANT_GNOME= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GECKO+= libxul
INSTALLS_OMF= yes
+CONFIGURE_ARGS+=--enable-introspection
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} ${EXTRA_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} ${EXTRA_LIBS}"
-GCONF_SCHEMAS= epiphany-lockdown.schemas epiphany.schemas \
- epiphany-fonts.schemas epiphany-pango.schemas
+GCONF_SCHEMAS= epiphany-lockdown.schemas epiphany.schemas
PLIST_SUB+= EPHY_VERSION="${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}"
MAN1= epiphany.1
-OPTIONS= SPELL_CHECKER "Enable spell checking support" off
+OPTIONS= NSS "Import passwords from 2.26 and older on first run" on \
+ SEED "Enable seed support" off \
+ SPELLCHECK "Enable spell checking by default" on
.if defined(PACKAGE_BUILDING)
.undef WITHOUT_GNOME
@@ -53,40 +58,26 @@ WITH_GNOME= yes
.include <bsd.port.pre.mk>
-CONFIGURE_ARGS+= --with-gecko=${GECKO} \
- --with-engine=mozilla \
- --with-gecko-home=${LOCALBASE}/lib/${GECKO}
-CONFLICTS= epiphany-webkit-[1-9]*
-PLIST_SUB+= GECKO=""
-.if ${GECKO:Mlibxul}!=""
-PLUGIN_SYMLINK= 19
-CONFIGURE_ENV+=gecko_cv_xpcom_program_check="yes"
-PLIST_SUB+= GECKO19=""
-.else
-PLUGIN_SYMLINK= 18
-PLIST_SUB+= GECKO19="@comment "
-.endif
-
NO_WERROR= yes
# allow build with more warnings enabled
.if defined(NO_WERROR)
CONFIGURE_ARGS+= --enable-compile-warnings=no
.endif
-.if ${HAVE_GNOME:Mpygnome2}!=""
-USE_PYTHON= yes
-.include "${PORTSDIR}/Mk/bsd.python.mk"
-USE_GNOME+= pygnome2
-CONFIGURE_ARGS+=--enable-python
-PLIST_SUB+= PYTHON=""
+.if defined(WITH_NSS)
+LIB_DEPENDS+= nss3.1:${PORTSDIR}/security/nss
+CONFIGURE_ARGS+=--enable-nss
.else
-CONFIGURE_ARGS+=--disable-python
-PLIST_SUB+= PYTHON="@comment "
+CONFIGURE_ARGS+=--disable-nss
+.endif
+
+.if defined(WITH_SEED)
+LIB_DEPENDS+= seed.0:${PORTSDIR}/devel/seed
+CONFIGURE_ARGS+=--enable-seed
.endif
-.if defined(WITH_SPELL_CHECKER)
-LIB_DEPENDS+= enchant.1:${PORTSDIR}/textproc/enchant
-CONFIGURE_ARGS+=--enable-spell-checker
+.if defined(WITH_SPELLCHECK)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-embed_ephy-embed-prefs.c
.endif
post-patch:
@@ -95,14 +86,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|execinfo.h|#|g ; \
s|-ldl"$$|"|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/lib/mozilla/plugins"|/lib/browser_plugins/symlinks/gecko${PLUGIN_SYMLINK}"|' \
- ${WRKSRC}/embed/mozilla/mozilla-embed-single.cpp
- @${REINPLACE_CMD} -e 's|@with_engine@|mozilla|' \
- ${WRKSRC}/data/epiphany.pc.in
post-install:
- ${INSTALL_DATA} ${WRKSRC}/data/epiphany-fonts.schemas \
- ${PREFIX}/etc/gconf/schemas
@-update-desktop-database
.include <bsd.port.post.mk>
diff --git a/www/epiphany/distinfo b/www/epiphany/distinfo
index 40744340fbdd..0ccbf15306c0 100644
--- a/www/epiphany/distinfo
+++ b/www/epiphany/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/epiphany-2.26.3.tar.bz2) = 16f44012bc376077e1443e049d725847
-SHA256 (gnome2/epiphany-2.26.3.tar.bz2) = bc3e79cb0d62c30ef32c7cf9eef563b1de1af60f31729dae43c3795d214880ad
-SIZE (gnome2/epiphany-2.26.3.tar.bz2) = 5655997
+MD5 (gnome2/epiphany-2.28.1.tar.bz2) = 7a8b885a4894d2a9e979b8cb8898db1e
+SHA256 (gnome2/epiphany-2.28.1.tar.bz2) = 95ccdd36bc7fdf95c6085da3b76cee6467f3c9a8745541cfb09fdd8d33a1f04d
+SIZE (gnome2/epiphany-2.28.1.tar.bz2) = 5693411
diff --git a/www/epiphany/files/extra-patch-embed_ephy-embed-prefs.c b/www/epiphany/files/extra-patch-embed_ephy-embed-prefs.c
new file mode 100644
index 000000000000..f9fbb6a13b89
--- /dev/null
+++ b/www/epiphany/files/extra-patch-embed_ephy-embed-prefs.c
@@ -0,0 +1,12 @@
+--- embed/ephy-embed-prefs.c.orig 2009-10-25 16:18:24.000000000 -0400
++++ embed/ephy-embed-prefs.c 2009-10-25 16:19:05.000000000 -0400
+@@ -250,6 +250,9 @@ ephy_embed_prefs_init (void)
+ /* Hardcoded settings */
+ g_object_set (settings, "auto-shrink-images", FALSE, NULL);
+
++ /* Enable spell-check by default */
++ g_object_set (settings, "enable-spell-checking", TRUE, NULL);
++
+ /* Connections */
+ connections = g_malloc (sizeof (guint) * G_N_ELEMENTS (webkit_pref_entries));
+
diff --git a/www/epiphany/files/patch-embed_ephy-embed-utils.c b/www/epiphany/files/patch-embed_ephy-embed-utils.c
new file mode 100644
index 000000000000..09de6a98174c
--- /dev/null
+++ b/www/epiphany/files/patch-embed_ephy-embed-utils.c
@@ -0,0 +1,10 @@
+--- embed/ephy-embed-utils.c.orig 2009-10-13 15:28:59.000000000 +0200
++++ embed/ephy-embed-utils.c 2009-10-13 15:29:30.000000000 +0200
+@@ -91,6 +91,7 @@ ephy_embed_utils_address_has_web_scheme
+ g_str_has_prefix (address, "file:") ||
+ g_str_has_prefix (address, "data:") ||
+ g_str_has_prefix (address, "about:") ||
++ g_str_has_prefix (address, "javascript:") ||
+ g_str_has_prefix (address, "gopher:"));
+
+ return has_web_scheme;
diff --git a/www/epiphany/files/patch-embed_ephy-web-view.c b/www/epiphany/files/patch-embed_ephy-web-view.c
new file mode 100644
index 000000000000..beb96fd71c92
--- /dev/null
+++ b/www/epiphany/files/patch-embed_ephy-web-view.c
@@ -0,0 +1,14 @@
+--- embed/ephy-web-view.c.orig 2009-10-13 15:30:12.000000000 +0200
++++ embed/ephy-web-view.c 2009-10-13 15:30:52.000000000 +0200
+@@ -1129,7 +1129,10 @@ ephy_web_view_load_url (EphyWebView *vie
+ else
+ effective_url = ephy_embed_utils_normalize_address (url);
+
+- webkit_web_view_open (WEBKIT_WEB_VIEW (view), effective_url);
++ if (g_str_has_prefix (effective_url, "javascript:"))
++ webkit_web_view_execute_script (WEBKIT_WEB_VIEW (view), effective_url);
++ else
++ webkit_web_view_open (WEBKIT_WEB_VIEW (view), effective_url);
+
+ if (soup_uri)
+ soup_uri_free (soup_uri);
diff --git a/www/epiphany/files/patch-src_ephy-window.c b/www/epiphany/files/patch-src_ephy-window.c
new file mode 100644
index 000000000000..f8467d96bce8
--- /dev/null
+++ b/www/epiphany/files/patch-src_ephy-window.c
@@ -0,0 +1,35 @@
+From c61c318aabdc980477dccd78549fe9819c3b1fa0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Fr=C3=A9d=C3=A9ric=20P=C3=A9ters?= <fpeters@0d.be>
+Date: Fri, 9 Oct 2009 20:07:20 +0200
+Subject: [PATCH] Pass mailto: URI to gtk_show_uri()
+
+(Part of) Bug #584537
+---
+ src/ephy-window.c | 8 ++++++++
+ 1 files changed, 8 insertions(+), 0 deletions(-)
+
+diff --git a/src/ephy-window.c b/src/ephy-window.c
+index 635a779..630ecec 100644
+--- src/ephy-window.c
++++ src/ephy-window.c
+@@ -2548,10 +2548,18 @@ policy_decision_required_cb (WebKitWebView *web_view,
+ WebKitWebNavigationReason reason;
+ gint button;
+ gint state;
++ const char *uri;
+
+ reason = webkit_web_navigation_action_get_reason (action);
+ button = webkit_web_navigation_action_get_button (action);
+ state = webkit_web_navigation_action_get_modifier_state (action);
++ uri = webkit_network_request_get_uri (request);
++
++ if (strncmp (uri, "mailto:", 7) == 0) {
++ webkit_web_policy_decision_ignore (decision);
++ gtk_show_uri (NULL, uri, GDK_CURRENT_TIME, NULL);
++ return TRUE;
++ }
+
+ /* Open in new tab for middle click or ctrl+click */
+ if (reason == WEBKIT_WEB_NAVIGATION_REASON_LINK_CLICKED &&
+--
+1.6.4.3
diff --git a/www/epiphany/pkg-plist b/www/epiphany/pkg-plist
index 583f6d49d136..265cf986aa97 100644
--- a/www/epiphany/pkg-plist
+++ b/www/epiphany/pkg-plist
@@ -1,16 +1,13 @@
bin/epiphany
+include/epiphany/%%EPHY_VERSION%%/epiphany/epiphany.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-adblock-manager.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-adblock.h
-include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-base-embed.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-bookmarks-type-builtins.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-bookmarks.h
-include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-command-manager.h
-include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-cookie-manager.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-dbus.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-dialog.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-container.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-event.h
-include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-factory.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-persist.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-prefs.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-shell.h
@@ -20,7 +17,6 @@ include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-utils.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-extension.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-extensions-manager.h
-include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-history-item.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-history.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-lib-type-builtins.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-link.h
@@ -28,36 +24,39 @@ include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-loader.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-node-db.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-node.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-notebook.h
-include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-password-manager.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-permission-manager.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-session.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-shell.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-state.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-statusbar.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-type-builtins.h
-include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-version.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-web-view.h
include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-window.h
-%%GECKO%%lib/epiphany/%%EPHY_VERSION%%/plugins/libdesktopfileplugin.la
-%%GECKO%%lib/epiphany/%%EPHY_VERSION%%/plugins/libdesktopfileplugin.so
@comment libdata/pkgconfig/epiphany-%%EPHY_VERSION%%.pc
-libdata/pkgconfig/epiphany-2.26.pc
+libdata/pkgconfig/epiphany-%%EPHY_VERSION%%.pc
share/aclocal/epiphany.m4
share/applications/bme.desktop
share/applications/epiphany.desktop
share/dbus-1/services/org.gnome.Epiphany.service
+lib/girepository-1.0/Epiphany-2.28.typelib
+share/gir-1.0/Epiphany-2.28.gir
%%DOCSDIR%%/EphyCommandManager.html
%%DOCSDIR%%/EphyEmbed.html
+%%DOCSDIR%%/EphyLocationEntry.html
%%DOCSDIR%%/EphyNodeDb.html
+%%DOCSDIR%%/EphySearchEntry.html
+%%DOCSDIR%%/EphySpinner.html
%%DOCSDIR%%/EphyWindow.html
+%%DOCSDIR%%/EphyZoomControl.html
%%DOCSDIR%%/ch01.html
%%DOCSDIR%%/ch02.html
+%%DOCSDIR%%/ch03.html
%%DOCSDIR%%/epiphany-EphyEmbedFactory.html
%%DOCSDIR%%/epiphany-EphyEmbedPersist.html
%%DOCSDIR%%/epiphany-EphyEmbedSingle.html
%%DOCSDIR%%/epiphany-EphyExtensionsManager.html
%%DOCSDIR%%/epiphany-EphyGlade.html
%%DOCSDIR%%/epiphany-EphyPermissionManager.html
-%%DOCSDIR%%/epiphany-ephy-cookie-manager.html
%%DOCSDIR%%/epiphany-ephy-password-manager.html
%%DOCSDIR%%/epiphany-ephy-session.html
%%DOCSDIR%%/epiphany-ephy-shell.html
@@ -71,13 +70,7 @@ share/dbus-1/services/org.gnome.Epiphany.service
%%DOCSDIR%%/style.css
%%DOCSDIR%%/up.png
%%DATADIR%%/about.ini
-%%DATADIR%%/chrome/app-chrome.manifest
-%%DATADIR%%/chrome/branding/brand.dtd
-%%DATADIR%%/chrome/branding/brand.properties
-%%DATADIR%%/chrome/global/about.xhtml
-%%GECKO19%%%%DATADIR%%/chrome/global/netError.dtd
-%%GECKO19%%%%DATADIR%%/components/epiphany.xpt
-%%DATADIR%%/default-prefs.js
+%%DATADIR%%/default-bookmarks.rdf
%%DATADIR%%/ephy-xml2ini.xsl
%%DATADIR%%/epiphany-bookmark-editor-ui.xml
%%DATADIR%%/epiphany-bookmarks-html.xsl
@@ -87,11 +80,11 @@ share/dbus-1/services/org.gnome.Epiphany.service
%%DATADIR%%/epiphany-toolbar.xml
%%DATADIR%%/epiphany-ui.xml
%%DATADIR%%/epiphany.xhtml
-%%DATADIR%%/glade/certificate-dialogs.glade
-%%DATADIR%%/glade/epiphany.glade
-%%DATADIR%%/glade/form-signing-dialog.glade
-%%DATADIR%%/glade/prefs-dialog.glade
-%%DATADIR%%/glade/print.glade
+%%DATADIR%%/glade/certificate-dialogs.ui
+%%DATADIR%%/glade/epiphany.ui
+%%DATADIR%%/glade/form-signing-dialog.ui
+%%DATADIR%%/glade/prefs-dialog.ui
+%%DATADIR%%/glade/print.ui
%%DATADIR%%/icons/hicolor/16x16/actions/bookmark-view.png
%%DATADIR%%/icons/hicolor/16x16/actions/history-view.png
%%DATADIR%%/icons/hicolor/16x16/actions/location-entry.png
@@ -239,8 +232,10 @@ share/locale/be@latin/LC_MESSAGES/epiphany.mo
share/locale/bg/LC_MESSAGES/epiphany.mo
share/locale/bn/LC_MESSAGES/epiphany.mo
share/locale/bn_IN/LC_MESSAGES/epiphany.mo
+share/locale/br/LC_MESSAGES/epiphany.mo
share/locale/bs/LC_MESSAGES/epiphany.mo
share/locale/ca/LC_MESSAGES/epiphany.mo
+share/locale/ca@valencia/LC_MESSAGES/epiphany.mo
share/locale/cs/LC_MESSAGES/epiphany.mo
share/locale/cy/LC_MESSAGES/epiphany.mo
share/locale/da/LC_MESSAGES/epiphany.mo
@@ -262,7 +257,9 @@ share/locale/he/LC_MESSAGES/epiphany.mo
share/locale/hi/LC_MESSAGES/epiphany.mo
share/locale/hr/LC_MESSAGES/epiphany.mo
share/locale/hu/LC_MESSAGES/epiphany.mo
+share/locale/hy/LC_MESSAGES/epiphany.mo
share/locale/id/LC_MESSAGES/epiphany.mo
+share/locale/ig/LC_MESSAGES/epiphany.mo
share/locale/is/LC_MESSAGES/epiphany.mo
share/locale/it/LC_MESSAGES/epiphany.mo
share/locale/ja/LC_MESSAGES/epiphany.mo
@@ -282,6 +279,7 @@ share/locale/mn/LC_MESSAGES/epiphany.mo
share/locale/mr/LC_MESSAGES/epiphany.mo
share/locale/ms/LC_MESSAGES/epiphany.mo
share/locale/nb/LC_MESSAGES/epiphany.mo
+share/locale/ne/LC_MESSAGES/epiphany.mo
share/locale/nl/LC_MESSAGES/epiphany.mo
share/locale/nn/LC_MESSAGES/epiphany.mo
share/locale/oc/LC_MESSAGES/epiphany.mo
@@ -307,8 +305,11 @@ share/locale/th/LC_MESSAGES/epiphany.mo
share/locale/tk/LC_MESSAGES/epiphany.mo
share/locale/tr/LC_MESSAGES/epiphany.mo
share/locale/uk/LC_MESSAGES/epiphany.mo
+share/locale/uz/LC_MESSAGES/epiphany.mo
+share/locale/uz@cyrillic/LC_MESSAGES/epiphany.mo
share/locale/vi/LC_MESSAGES/epiphany.mo
share/locale/wa/LC_MESSAGES/epiphany.mo
+share/locale/yo/LC_MESSAGES/epiphany.mo
share/locale/zh_CN/LC_MESSAGES/epiphany.mo
share/locale/zh_HK/LC_MESSAGES/epiphany.mo
share/locale/zh_TW/LC_MESSAGES/epiphany.mo
@@ -330,7 +331,6 @@ share/omf/epiphany/epiphany-oc.omf
share/omf/epiphany/epiphany-ru.omf
share/omf/epiphany/epiphany-sv.omf
share/omf/epiphany/epiphany-uk.omf
-share/pygtk/2.0/defs/epiphany.defs
@dirrm share/omf/epiphany
@dirrmtry share/icons/LowContrastLargePrint/48x48/apps
@dirrmtry share/icons/LowContrastLargePrint/48x48
@@ -395,14 +395,12 @@ share/pygtk/2.0/defs/epiphany.defs
@dirrmtry %%DATADIR%%/icons/hicolor
@dirrmtry %%DATADIR%%/icons
@dirrm %%DATADIR%%/glade
-@dirrm %%DATADIR%%/components
-@dirrm %%DATADIR%%/chrome/global
-@dirrm %%DATADIR%%/chrome/branding
-@dirrm %%DATADIR%%/chrome
@dirrm %%DATADIR%%/art
@dirrmtry %%DATADIR%%
-@dirrm %%DOCSDIR%%
+@dirrmtry %%DOCSDIR%%
@dirrmtry share/applications
+@dirrmtry lib/girepository-1.0
+@dirrmtry share/gir-1.0
@dirrmtry lib/epiphany/%%EPHY_VERSION%%/plugins
@dirrmtry lib/epiphany/%%EPHY_VERSION%%
@dirrmtry lib/epiphany
@@ -437,6 +435,8 @@ share/pygtk/2.0/defs/epiphany.defs
@dirrmtry share/locale/ku
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES