aboutsummaryrefslogtreecommitdiff
path: root/www/epiphany
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /www/epiphany
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
downloadports-e18151212d3326dbf04797c6d5300fb1211ee875.tar.gz
ports-e18151212d3326dbf04797c6d5300fb1211ee875.zip
Notes
Diffstat (limited to 'www/epiphany')
-rw-r--r--www/epiphany/Makefile49
-rw-r--r--www/epiphany/distinfo4
-rw-r--r--www/epiphany/files/patch-help_Makefile.in11
-rw-r--r--www/epiphany/pkg-plist100
4 files changed, 98 insertions, 66 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index d5dbb55b5aad..eb55e185215b 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -3,39 +3,44 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/www/epiphany/Makefile,v 1.84 2005/10/02 23:28:19 marcus Exp $
#
PORTNAME= epiphany
-PORTVERSION= 1.6.5
+PORTVERSION= 1.8.2
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.6
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.8
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= An extremely lightweight and simple web browser for GNOME 2
-BUILD_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
+BUILD_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA} \
+ ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA} \
+ ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
MOZILLA= mozilla
HEADERS_SUFX=
MOZ_BUILD= mozilla
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla
-HEADERS_SUFX=
-.else
-.if ${WITH_MOZILLA}=="firefox"
MOZILLA= firefox
+HEADERS_SUFX=
MOZ_BUILD= firefox
.else
+.if ${WITH_MOZILLA}=="mozilla"
+MOZILLA= mozilla
+MOZ_BUILD= mozilla
+.else
.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
MOZILLA= mozilla-devel
HEADERS_SUFX= -devel
.else
-MOZILLA= mozilla
+MOZILLA= firefox
HEADERS_SUFX=
+MOZ_BUILD= firefox
.endif
.endif
.endif
@@ -43,12 +48,14 @@ HEADERS_SUFX=
USE_BZIP2= yes
USE_X_PREFIX= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop desktopfileutils
-USE_LIBTOOL_VER=15
+USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop desktopfileutils \
+ libgnomeprintui
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_REINPLACE= yes
INSTALLS_OMF= yes
-CONFIGURE_ARGS= --with-mozilla=${MOZ_BUILD}
+CONFIGURE_ARGS= --with-mozilla=${MOZ_BUILD} \
+ --disable-python
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -75,23 +82,25 @@ USE_GCC= 3.4
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default epiphany uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " By default epiphany uses www/firefox for html rendering, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
- @${ECHO_MSG} " firefox "
+ @${ECHO_MSG} " mozilla "
@${ECHO_MSG} " mozilla-devel "
@${ECHO_MSG} ""
post-patch:
- @${REINPLACE_CMD} -e 's|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g ; \
- s|mozilla-xpcom|mozilla-xpcom${HEADERS_SUFX}|g ; \
- s|$$MOZILLA-gtkmozembed|$$MOZILLA-gtkmozembed${HEADERS_SUFX}|g ; \
- s|$$MOZILLA-xpcom|$$MOZILLA-xpcom${HEADERS_SUFX}|g' \
+.if defined(WITH_MOZILLA) && ${WITH_MOZILLA}=="mozilla-devel"
+ @${REINPLACE_CMD} -e 's|xmozilla|xmozilla${HEADERS_SUFX}|g; \
+ s|mozilla)|mozilla${HEADERS_SUFX})|g; \
+ s|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g; \
+ s|mozilla-xpcom|mozilla-xpcom${HEADERS_SUFX}|g; \
+ s|$$MOZILLA-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g; \
+ s|$$MOZILLA-xpcom|mozilla-xpcom${HEADERS_SUFX}|g' \
${WRKSRC}/configure
+.endif
@${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'
- @${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|malloc\.h|stdlib.h|g'
post-configure:
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; \
diff --git a/www/epiphany/distinfo b/www/epiphany/distinfo
index b62f1cdf8427..6bfaecae7c1a 100644
--- a/www/epiphany/distinfo
+++ b/www/epiphany/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/epiphany-1.6.5.tar.bz2) = ac87745115e41f4d9488e80c8684c207
-SIZE (gnome2/epiphany-1.6.5.tar.bz2) = 3037945
+MD5 (gnome2/epiphany-1.8.2.tar.bz2) = 0a2e479816a1b2845c758e7a5d84a848
+SIZE (gnome2/epiphany-1.8.2.tar.bz2) = 3354620
diff --git a/www/epiphany/files/patch-help_Makefile.in b/www/epiphany/files/patch-help_Makefile.in
new file mode 100644
index 000000000000..1b9f2bb6f91c
--- /dev/null
+++ b/www/epiphany/files/patch-help_Makefile.in
@@ -0,0 +1,11 @@
+--- help/Makefile.in.orig Wed Jul 27 02:50:59 2005
++++ help/Makefile.in Wed Jul 27 02:51:22 2005
+@@ -972,7 +972,7 @@
+ else \
+ figfile="$(srcdir)/C/$$fig"; \
+ fi; \
+- figdir="$$lc/"`echo $$fig | sed -e 's/^\(.*\/\).*\|.*/\1/'`; \
++ figdir="$$lc/"`echo $$fig | sed -E -e 's/^(.*\/).*|.*/\1/'`; \
+ figdir="$(DESTDIR)$(HELP_DIR)/$(DOC_MODULE)/$$figdir"; \
+ if ! test -d "$$figdir"; then \
+ echo "$(mkinstalldirs) $$figdir"; \
diff --git a/www/epiphany/pkg-plist b/www/epiphany/pkg-plist
index f3a1693b0867..3adc515fd8df 100644
--- a/www/epiphany/pkg-plist
+++ b/www/epiphany/pkg-plist
@@ -1,38 +1,38 @@
bin/epiphany
bin/epiphany-bin
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-bookmarks-type-builtins.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-bookmarks.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-command-manager.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-cookie-manager.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-dialog.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-event.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-factory.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-persist.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-prefs.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-shell.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-single.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-type-builtins.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-extension.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-extensions-manager.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-history.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-lib-type-builtins.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-link.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-loader.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-node-db.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-node.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-notebook.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-password-manager.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-permission-manager.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-session.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-shell.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-state.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-statusbar.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-tab.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-type-builtins.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-window.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-bookmarks-type-builtins.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-bookmarks.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-command-manager.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-cookie-manager.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-dialog.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-event.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-factory.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-persist.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-prefs.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-shell.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-single.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed-type-builtins.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-embed.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-extension.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-extensions-manager.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-history.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-lib-type-builtins.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-link.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-loader.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-node-db.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-node.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-notebook.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-password-manager.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-permission-manager.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-session.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-shell.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-state.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-statusbar.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-tab.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-type-builtins.h
+include/epiphany/%%EPHY_VERSION%%/epiphany/ephy-window.h
libdata/bonobo/servers/GNOME_Epiphany_Automation.server
-libdata/pkgconfig/epiphany-%%EPHY_VERSION%%.pc
+libdata/pkgconfig/epiphany-1.8.pc
%%DOCSDIR%%/EphyCommandManager.html
%%DOCSDIR%%/EphyEmbed.html
%%DOCSDIR%%/EphyNodeDb.html
@@ -61,6 +61,7 @@ libdata/pkgconfig/epiphany-%%EPHY_VERSION%%.pc
share/gnome/application-registry/epiphany.applications
share/gnome/applications/bme.desktop
share/gnome/applications/epiphany.desktop
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
share/gnome/epiphany/art/epiphany-bookmarks.png
share/gnome/epiphany/art/epiphany-close-tab.png
share/gnome/epiphany/art/epiphany-download.png
@@ -89,39 +90,48 @@ share/gnome/help/epiphany/C/figures/ephy-bookmarkbar-smartbookmark-screenshot.pn
share/gnome/help/epiphany/C/figures/ephy-history-window-screenshot.png
share/gnome/help/epiphany/C/figures/ephy-screenshot.png
share/gnome/help/epiphany/C/legal.xml
+share/gnome/help/epiphany/el/epiphany.xml
+share/gnome/help/epiphany/el/figures/ephy-addressbar-smartbookmark-screenshot.png
+share/gnome/help/epiphany/el/figures/ephy-bookmarkbar-smartbookmark-screenshot.png
+share/gnome/help/epiphany/el/figures/ephy-history-window-screenshot.png
+share/gnome/help/epiphany/el/figures/ephy-screenshot.png
share/gnome/help/epiphany/es/epiphany.xml
share/gnome/help/epiphany/es/figures/ephy-addressbar-smartbookmark-screenshot.png
share/gnome/help/epiphany/es/figures/ephy-bookmarkbar-smartbookmark-screenshot.png
share/gnome/help/epiphany/es/figures/ephy-history-window-screenshot.png
share/gnome/help/epiphany/es/figures/ephy-screenshot.png
-share/gnome/help/epiphany/es/legal.xml
share/gnome/help/epiphany/eu/epiphany.xml
+share/gnome/help/epiphany/eu/figures/ephy-addressbar-smartbookmark-screenshot.png
+share/gnome/help/epiphany/eu/figures/ephy-bookmarkbar-smartbookmark-screenshot.png
share/gnome/help/epiphany/eu/figures/ephy-history-window-screenshot.png
share/gnome/help/epiphany/eu/figures/ephy-screenshot.png
-share/gnome/help/epiphany/eu/legal.xml
share/gnome/help/epiphany/fi/epiphany.xml
share/gnome/help/epiphany/fi/figures/ephy-addressbar-smartbookmark-screenshot.png
share/gnome/help/epiphany/fi/figures/ephy-bookmarkbar-smartbookmark-screenshot.png
share/gnome/help/epiphany/fi/figures/ephy-history-window-screenshot.png
share/gnome/help/epiphany/fi/figures/ephy-screenshot.png
-share/gnome/help/epiphany/fi/legal.xml
share/gnome/help/epiphany/ja/epiphany.xml
share/gnome/help/epiphany/ja/figures/ephy-addressbar-smartbookmark-screenshot.png
share/gnome/help/epiphany/ja/figures/ephy-bookmarkbar-smartbookmark-screenshot.png
share/gnome/help/epiphany/ja/figures/ephy-history-window-screenshot.png
share/gnome/help/epiphany/ja/figures/ephy-screenshot.png
-share/gnome/help/epiphany/ja/legal.xml
+share/gnome/help/epiphany/nl/epiphany.xml
+share/gnome/help/epiphany/nl/figures/ephy-addressbar-smartbookmark-screenshot.png
+share/gnome/help/epiphany/nl/figures/ephy-bookmarkbar-smartbookmark-screenshot.png
+share/gnome/help/epiphany/nl/figures/ephy-history-window-screenshot.png
+share/gnome/help/epiphany/nl/figures/ephy-screenshot.png
share/gnome/help/epiphany/uk/epiphany.xml
share/gnome/help/epiphany/uk/figures/ephy-addressbar-smartbookmark-screenshot.png
share/gnome/help/epiphany/uk/figures/ephy-bookmarkbar-smartbookmark-screenshot.png
share/gnome/help/epiphany/uk/figures/ephy-history-window-screenshot.png
share/gnome/help/epiphany/uk/figures/ephy-screenshot.png
-share/gnome/help/epiphany/uk/legal.xml
share/gnome/omf/epiphany/epiphany-C.omf
+share/gnome/omf/epiphany/epiphany-el.omf
share/gnome/omf/epiphany/epiphany-es.omf
share/gnome/omf/epiphany/epiphany-eu.omf
share/gnome/omf/epiphany/epiphany-fi.omf
share/gnome/omf/epiphany/epiphany-ja.omf
+share/gnome/omf/epiphany/epiphany-nl.omf
share/gnome/omf/epiphany/epiphany-uk.omf
share/gnome/pixmaps/epiphany-bookmarks.png
share/locale/am/LC_MESSAGES/epiphany.mo
@@ -157,6 +167,7 @@ share/locale/is/LC_MESSAGES/epiphany.mo
share/locale/it/LC_MESSAGES/epiphany.mo
share/locale/ja/LC_MESSAGES/epiphany.mo
share/locale/ko/LC_MESSAGES/epiphany.mo
+share/locale/ku/LC_MESSAGES/epiphany.mo
share/locale/li/LC_MESSAGES/epiphany.mo
share/locale/lt/LC_MESSAGES/epiphany.mo
share/locale/mi/LC_MESSAGES/epiphany.mo
@@ -183,6 +194,7 @@ share/locale/sr/LC_MESSAGES/epiphany.mo
share/locale/sr@Latn/LC_MESSAGES/epiphany.mo
share/locale/sv/LC_MESSAGES/epiphany.mo
share/locale/ta/LC_MESSAGES/epiphany.mo
+share/locale/te/LC_MESSAGES/epiphany.mo
share/locale/th/LC_MESSAGES/epiphany.mo
share/locale/tk/LC_MESSAGES/epiphany.mo
share/locale/tr/LC_MESSAGES/epiphany.mo
@@ -191,13 +203,11 @@ share/locale/vi/LC_MESSAGES/epiphany.mo
share/locale/wa/LC_MESSAGES/epiphany.mo
share/locale/zh_CN/LC_MESSAGES/epiphany.mo
share/locale/zh_TW/LC_MESSAGES/epiphany.mo
-@unexec rmdir %D/share/locale/rw/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/rw 2> /dev/null || true
-@unexec rmdir %D/share/locale/mi/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/mi 2> /dev/null || true
@dirrm share/gnome/omf/epiphany
@dirrm share/gnome/help/epiphany/uk/figures
@dirrm share/gnome/help/epiphany/uk
+@dirrm share/gnome/help/epiphany/nl/figures
+@dirrm share/gnome/help/epiphany/nl
@dirrm share/gnome/help/epiphany/ja/figures
@dirrm share/gnome/help/epiphany/ja
@dirrm share/gnome/help/epiphany/fi/figures
@@ -206,6 +216,8 @@ share/locale/zh_TW/LC_MESSAGES/epiphany.mo
@dirrm share/gnome/help/epiphany/eu
@dirrm share/gnome/help/epiphany/es/figures
@dirrm share/gnome/help/epiphany/es
+@dirrm share/gnome/help/epiphany/el/figures
+@dirrm share/gnome/help/epiphany/el
@dirrm share/gnome/help/epiphany/C/figures
@dirrm share/gnome/help/epiphany/C
@dirrm share/gnome/help/epiphany
@@ -213,7 +225,7 @@ share/locale/zh_TW/LC_MESSAGES/epiphany.mo
@dirrm share/gnome/epiphany/art
@dirrm share/gnome/epiphany
@dirrm %%DOCSDIR%%
-@dirrm include/epiphany-%%EPHY_VERSION%%/epiphany
-@dirrm include/epiphany-%%EPHY_VERSION%%
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrm include/epiphany/%%EPHY_VERSION%%/epiphany
+@dirrm include/epiphany/%%EPHY_VERSION%%
+@dirrm include/epiphany
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true