aboutsummaryrefslogtreecommitdiff
path: root/www/epiphany
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
commit58406bee8938178fc317574c4236434b0dd11a25 (patch)
treeb4fa34eca69e23769c548b4436cbf65d765e5fe2 /www/epiphany
parent98eb5c95a29c8dd1a76435744e5316092835f696 (diff)
downloadports-58406bee8938178fc317574c4236434b0dd11a25.tar.gz
ports-58406bee8938178fc317574c4236434b0dd11a25.zip
Notes
Diffstat (limited to 'www/epiphany')
-rw-r--r--www/epiphany/Makefile40
-rw-r--r--www/epiphany/distinfo4
-rw-r--r--www/epiphany/files/epiphany27
-rw-r--r--www/epiphany/files/patch-embed_mozilla_Makefile.in18
-rw-r--r--www/epiphany/files/patch-src_epiphany.in22
-rw-r--r--www/epiphany/pkg-plist53
6 files changed, 101 insertions, 63 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index cebc7e3d8fe4..76797e5c5255 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= epiphany
-PORTVERSION= 1.2.8
+PORTVERSION= 1.4.4
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.4
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -36,8 +36,7 @@ HEADERS_SUFX=
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
-WANT_GNOME= yes
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui desktopfileutils
USE_LIBTOOL_VER=15
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -46,26 +45,13 @@ CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla${HEADERS_SUF
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+GCONF_SCHEMAS= epiphany-lockdown.schemas epiphany.schemas
+
FLASHPLAYER= ${LOCALBASE}/lib/libflashplayer.so.1
PLIST_SUB+= EPHY_VERSION="${PORTVERSION:C/\.[0-9]+$//}"
-.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
-.undef WITHOUT_GNOME
-.undef WITHOUT_ALL
-WITH_GNOME= yes
-.endif
-
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mnautilus2}!=""
-USE_GNOME+= nautilus2
-CONFIGURE_ARGS+= --enable-nautilus-view
-PLIST_SUB+= NAUTILUS=""
-.else
-CONFIGURE_ARGS+= --enable-nautilus-view=no
-PLIST_SUB+= NAUTILUS="@comment "
-.endif
-
.if ${OSVERSION} > 500000
# Galeon does not build correctly in -CURRENT if -Werror is passed
# to the compiler.
@@ -85,21 +71,29 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @${REINPLACE_CMD} -e 's|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g; \
- s|mozilla-xpcom|mozilla-xpcom${HEADERS_SUFX}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g ; \
+ s|mozilla-xpcom|mozilla-xpcom${HEADERS_SUFX}|g ; \
+ s|$$MOZILLA-gtkmozembed|$$MOZILLA-gtkmozembed${HEADERS_SUFX}|g ; \
+ s|$$MOZILLA-xpcom|$$MOZILLA-xpcom${HEADERS_SUFX}|g' \
+ ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g'
@${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
post-configure:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
s|%%X11BASE%%|${X11BASE}|g ; \
s|%%MOZILLA%%|${MOZILLA}|g ; \
- s|%%FLASHPLAYER%%|${FLASHPLAYER}|g' ${WRKSRC}/src/epiphany
+ s|%%FLASHPLAYER%%|${FLASHPLAYER}|g' <${FILESDIR}/epiphany \
+ > ${WRKDIR}/epiphany
pre-install:
@-${X11BASE}/bin/gconftool-2 --shutdown
+post-install:
+ @${MV} -f ${PREFIX}/bin/epiphany ${PREFIX}/bin/epiphany-bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/epiphany ${PREFIX}/bin
+
.include <bsd.port.post.mk>
diff --git a/www/epiphany/distinfo b/www/epiphany/distinfo
index 8224bfd17032..2006f639245d 100644
--- a/www/epiphany/distinfo
+++ b/www/epiphany/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/epiphany-1.2.8.tar.bz2) = 19d80db940f722b890dd439038743f83
-SIZE (gnome2/epiphany-1.2.8.tar.bz2) = 2979211
+MD5 (gnome2/epiphany-1.4.4.tar.bz2) = 2d29074c577dd42706c923df21a9a5bf
+SIZE (gnome2/epiphany-1.4.4.tar.bz2) = 3355896
diff --git a/www/epiphany/files/epiphany b/www/epiphany/files/epiphany
new file mode 100644
index 000000000000..504fd02402ce
--- /dev/null
+++ b/www/epiphany/files/epiphany
@@ -0,0 +1,27 @@
+#!/bin/sh
+
+dist_bin=`dirname $0`
+
+MOZILLA_HOME=%%X11BASE%%/lib/%%MOZILLA%%
+
+if [ -z "$MOZ_PLUGIN_PATH" ]; then
+ MOZ_PLUGIN_PATH=%%PREFIX%%/lib/browser_plugins
+ export MOZ_PLUGIN_PATH
+fi
+
+if [ -n "$LD_LIBRARY_PATH" ]; then
+ LD_LIBRARY_PATH=$MOZILLA_HOME:$LD_LIBRARY_PATH
+else
+ LD_LIBRARY_PATH=$MOZILLA_HOME
+fi
+export LD_LIBRARY_PATH
+
+MOZILLA_FIVE_HOME=$MOZILLA_HOME
+export MOZILLA_FIVE_HOME
+
+if [ -f %%LOCALBASE%%/lib/libflashplayer.so.1 ]; then
+ LD_PRELOAD=%%LOCALBASE%%/lib/libflashplayer.so.1
+ export LD_PRELOAD
+fi
+
+exec "%%PREFIX%%/bin/epiphany-bin" "$@"
diff --git a/www/epiphany/files/patch-embed_mozilla_Makefile.in b/www/epiphany/files/patch-embed_mozilla_Makefile.in
new file mode 100644
index 000000000000..d9be4935d30d
--- /dev/null
+++ b/www/epiphany/files/patch-embed_mozilla_Makefile.in
@@ -0,0 +1,18 @@
+--- embed/mozilla/Makefile.in.orig Tue Jul 6 18:36:11 2004
++++ embed/mozilla/Makefile.in Tue Jul 6 18:38:39 2004
+@@ -218,6 +218,7 @@
+ -I$(MOZILLA_INCLUDE_ROOT)/docshell \
+ -I$(MOZILLA_INCLUDE_ROOT)/dom \
+ -I$(MOZILLA_INCLUDE_ROOT)/exthandler \
++ -I$(MOZILLA_INCLUDE_ROOT)/find \
+ -I$(MOZILLA_INCLUDE_ROOT)/gfx \
+ -I$(MOZILLA_INCLUDE_ROOT)/helperAppDlg \
+ -I$(MOZILLA_INCLUDE_ROOT)/history \
+@@ -228,6 +229,7 @@
+ -I$(MOZILLA_INCLUDE_ROOT)/nkcache \
+ -I$(MOZILLA_INCLUDE_ROOT)/pipboot \
+ -I$(MOZILLA_INCLUDE_ROOT)/pipnss \
++ -I$(MOZILLA_INCLUDE_ROOT)/pref \
+ -I$(MOZILLA_INCLUDE_ROOT)/shistory \
+ -I$(MOZILLA_INCLUDE_ROOT)/uriloader \
+ -I$(MOZILLA_INCLUDE_ROOT)/uconv \
diff --git a/www/epiphany/files/patch-src_epiphany.in b/www/epiphany/files/patch-src_epiphany.in
deleted file mode 100644
index 23583b77fe82..000000000000
--- a/www/epiphany/files/patch-src_epiphany.in
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/epiphany.in.orig Sat Dec 20 14:35:58 2003
-+++ src/epiphany.in Sun Dec 28 16:44:41 2003
-@@ -5,7 +5,7 @@
- MOZILLA_HOME=@MOZILLA_HOME@
-
- if [ -z "$MOZ_PLUGIN_PATH" ]; then
-- MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins:/usr/libexec/plugins/mozilla
-+ MOZ_PLUGIN_PATH=%%X11BASE%%/lib/browser_plugins
- export MOZ_PLUGIN_PATH
- fi
-
-@@ -28,4 +28,9 @@
- MOZILLA_FIVE_HOME=$MOZILLA_HOME
- export MOZILLA_FIVE_HOME
-
--exec "$dist_bin/epiphany-bin" "$@"
-+if [ -f %%FLASHPLAYER%% ]; then
-+ LD_PRELOAD=%%FLASHPLAYER%%
-+ export LD_PRELOAD
-+fi
-+
-+exec "%%PREFIX%%/bin/epiphany-bin" "$@"
diff --git a/www/epiphany/pkg-plist b/www/epiphany/pkg-plist
index a33679b30382..62dc792f7ea7 100644
--- a/www/epiphany/pkg-plist
+++ b/www/epiphany/pkg-plist
@@ -1,16 +1,11 @@
bin/epiphany
bin/epiphany-bin
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/epiphany-lockdown.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/epiphany-lockdown.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/epiphany-lockdown.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/epiphany.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/epiphany.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/epiphany.schemas > /dev/null || /usr/bin/true
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-bookmarks.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-command-manager.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-cookie-manager.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-dialog.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-event.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-factory.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-persist.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-prefs.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-shell.h
@@ -30,14 +25,21 @@ include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-statusbar.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-tab.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-window.h
libdata/bonobo/servers/GNOME_Epiphany_Automation.server
-%%NAUTILUS%%libdata/bonobo/servers/GNOME_Epiphany_NautilusView.server
-libdata/pkgconfig/epiphany-1.2.pc
+libdata/pkgconfig/epiphany-1.4.pc
+%%DOCSDIR%%/EphyCommandManager.html
+%%DOCSDIR%%/EphyEmbed.html
+%%DOCSDIR%%/EphyNodeDb.html
+%%DOCSDIR%%/EphyTab.html
+%%DOCSDIR%%/EphyWindow.html
%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/ch02.html
+%%DOCSDIR%%/epiphany-EphyEmbedFactory.html
+%%DOCSDIR%%/epiphany-EphyEmbedPersist.html
+%%DOCSDIR%%/epiphany-EphyEmbedSingle.html
+%%DOCSDIR%%/epiphany-EphyGlade.html
+%%DOCSDIR%%/epiphany-EphyPermissionManager.html
%%DOCSDIR%%/epiphany-ephy-cookie-manager.html
-%%DOCSDIR%%/epiphany-ephy-embed-factory.html
-%%DOCSDIR%%/epiphany-ephy-embed-single.html
%%DOCSDIR%%/epiphany-ephy-password-manager.html
-%%DOCSDIR%%/epiphany-ephy-permission-manager.html
%%DOCSDIR%%/epiphany-ephy-session.html
%%DOCSDIR%%/epiphany-ephy-shell.html
%%DOCSDIR%%/epiphany.devhelp
@@ -46,21 +48,25 @@ libdata/pkgconfig/epiphany-1.2.pc
%%DOCSDIR%%/index.sgml
%%DOCSDIR%%/left.png
%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
%%DOCSDIR%%/up.png
share/gnome/application-registry/epiphany.applications
share/gnome/applications/bme.desktop
share/gnome/applications/epiphany.desktop
+@exec update-desktop-database > /dev/null || /usr/bin/true
share/gnome/epiphany/art/epiphany-bookmarks.png
+share/gnome/epiphany/art/epiphany-close-tab.png
share/gnome/epiphany/art/epiphany-download.png
share/gnome/epiphany/art/epiphany-entry.png
share/gnome/epiphany/art/epiphany-history.png
+share/gnome/epiphany/art/epiphany-popup-hidden.png
share/gnome/epiphany/art/epiphany-secure.png
-share/gnome/epiphany/art/epiphany-tab-loading.gif
share/gnome/epiphany/art/epiphany-unsecure.png
share/gnome/epiphany/art/hand-open.png
share/gnome/epiphany/conspiracy.xhtml
share/gnome/epiphany/default-prefs.js
share/gnome/epiphany/epiphany-bookmark-editor-ui.xml
+share/gnome/epiphany/epiphany-bookmarksbar.xml
share/gnome/epiphany/epiphany-fs-toolbar.xml
share/gnome/epiphany/epiphany-history-window-ui.xml
share/gnome/epiphany/epiphany-toolbar.xml
@@ -71,7 +77,6 @@ share/gnome/epiphany/glade/epiphany.glade
share/gnome/epiphany/glade/prefs-dialog.glade
share/gnome/epiphany/glade/print.glade
share/gnome/epiphany/mime-types-permissions.xml
-share/gnome/epiphany/nautilus-epiphany-view.xml
share/gnome/help/epiphany/C/epiphany.xml
share/gnome/help/epiphany/C/figures/ephy-addressbar-smartbookmark-screenshot.png
share/gnome/help/epiphany/C/figures/ephy-bookmarkbar-smartbookmark-screenshot.png
@@ -88,19 +93,28 @@ share/gnome/help/epiphany/eu/epiphany.xml
share/gnome/help/epiphany/eu/figures/ephy-history-window-screenshot.png
share/gnome/help/epiphany/eu/figures/ephy-screenshot.png
share/gnome/help/epiphany/eu/legal.xml
+share/gnome/help/epiphany/ja/epiphany.xml
+share/gnome/help/epiphany/ja/figures/ephy-addressbar-smartbookmark-screenshot.png
+share/gnome/help/epiphany/ja/figures/ephy-bookmarkbar-smartbookmark-screenshot.png
+share/gnome/help/epiphany/ja/figures/ephy-history-window-screenshot.png
+share/gnome/help/epiphany/ja/figures/ephy-screenshot.png
+share/gnome/help/epiphany/ja/legal.xml
share/gnome/omf/epiphany/epiphany-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/epiphany/epiphany-C.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/epiphany/epiphany-es.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/epiphany/epiphany-es.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/epiphany/epiphany-eu.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/epiphany/epiphany-eu.omf 2>/dev/null || /usr/bin/true
+share/gnome/omf/epiphany/epiphany-ja.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/epiphany/epiphany-ja.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/epiphany-bookmarks.png
share/locale/am/LC_MESSAGES/epiphany.mo
-share/locale/az/LC_MESSAGES/epiphany.mo
share/locale/ar/LC_MESSAGES/epiphany.mo
+share/locale/az/LC_MESSAGES/epiphany.mo
share/locale/be/LC_MESSAGES/epiphany.mo
share/locale/bg/LC_MESSAGES/epiphany.mo
share/locale/bn/LC_MESSAGES/epiphany.mo
+share/locale/bs/LC_MESSAGES/epiphany.mo
share/locale/ca/LC_MESSAGES/epiphany.mo
share/locale/cs/LC_MESSAGES/epiphany.mo
share/locale/cy/LC_MESSAGES/epiphany.mo
@@ -130,11 +144,14 @@ share/locale/li/LC_MESSAGES/epiphany.mo
share/locale/lt/LC_MESSAGES/epiphany.mo
share/locale/mi/LC_MESSAGES/epiphany.mo
share/locale/mk/LC_MESSAGES/epiphany.mo
+share/locale/ml/LC_MESSAGES/epiphany.mo
share/locale/mn/LC_MESSAGES/epiphany.mo
share/locale/ms/LC_MESSAGES/epiphany.mo
+share/locale/nb/LC_MESSAGES/epiphany.mo
+share/locale/ne/LC_MESSAGES/epiphany.mo
share/locale/nl/LC_MESSAGES/epiphany.mo
-share/locale/no/LC_MESSAGES/epiphany.mo
share/locale/nn/LC_MESSAGES/epiphany.mo
+share/locale/no/LC_MESSAGES/epiphany.mo
share/locale/pa/LC_MESSAGES/epiphany.mo
share/locale/pl/LC_MESSAGES/epiphany.mo
share/locale/pt/LC_MESSAGES/epiphany.mo
@@ -157,6 +174,8 @@ share/locale/wa/LC_MESSAGES/epiphany.mo
share/locale/zh_CN/LC_MESSAGES/epiphany.mo
share/locale/zh_TW/LC_MESSAGES/epiphany.mo
@dirrm share/gnome/omf/epiphany
+@dirrm share/gnome/help/epiphany/ja/figures
+@dirrm share/gnome/help/epiphany/ja
@dirrm share/gnome/help/epiphany/eu/figures
@dirrm share/gnome/help/epiphany/eu
@dirrm share/gnome/help/epiphany/es/figures
@@ -171,5 +190,7 @@ share/locale/zh_TW/LC_MESSAGES/epiphany.mo
@dirrm include/epiphany-%%EPHY_VERSION%%/epiphany
@dirrm include/epiphany-%%EPHY_VERSION%%
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/epiphany/epiphany-C.omf 2>/dev/null || /usr/bin/true
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/epiphany/epiphany-eu.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/epiphany/epiphany-es.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/epiphany/epiphany-eu.omf 2>/dev/null || /usr/bin/true
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/epiphany/epiphany-ja.omf 2>/dev/null || /usr/bin/true
+@unexec update-desktop-database > /dev/null || /usr/bin/true