aboutsummaryrefslogtreecommitdiff
path: root/www/epiphany
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /www/epiphany
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'www/epiphany')
-rw-r--r--www/epiphany/Makefile17
-rw-r--r--www/epiphany/distinfo4
-rw-r--r--www/epiphany/pkg-plist26
3 files changed, 30 insertions, 17 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 25d659b03d63..9f3afb06a15b 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= epiphany
-PORTVERSION= 1.4.8
+PORTVERSION= 1.6.0
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.4
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.6
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -36,11 +36,12 @@ HEADERS_SUFX=
USE_BZIP2= yes
USE_X_PREFIX= yes
-INSTALLS_OMF= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui desktopfileutils
+GNOME_DESKTOP_VERSION=2
+USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop desktopfileutils
USE_LIBTOOL_VER=15
USE_GMAKE= yes
USE_REINPLACE= yes
+INSTALLS_OMF= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla${HEADERS_SUFX}" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
@@ -55,14 +56,10 @@ MAN1= epiphany.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 500000
-# Galeon does not build correctly in -CURRENT if -Werror is passed
-# to the compiler.
NO_WERROR= yes
-.endif
# allow build with more warnings enabled
.if defined(NO_WERROR)
-CONFIGURE_ARGS+= --disable-werror
+CONFIGURE_ARGS+= --enable-compile-warnings=no
.endif
.if ${OSVERSION} < 500000
@@ -101,6 +98,6 @@ post-configure:
post-install:
@${MV} -f ${PREFIX}/bin/epiphany ${PREFIX}/bin/epiphany-bin
${INSTALL_SCRIPT} ${WRKDIR}/epiphany ${PREFIX}/bin
- @-update-desktop-database > /dev/null
+ @-update-desktop-database
.include <bsd.port.post.mk>
diff --git a/www/epiphany/distinfo b/www/epiphany/distinfo
index a2b527a3b181..e2a19172bd9c 100644
--- a/www/epiphany/distinfo
+++ b/www/epiphany/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/epiphany-1.4.8.tar.bz2) = bb9bdb92c5b4a7a97029e942304a9373
-SIZE (gnome2/epiphany-1.4.8.tar.bz2) = 3594408
+MD5 (gnome2/epiphany-1.6.0.tar.bz2) = 53eda1c713aec26a51fb806210c8afa7
+SIZE (gnome2/epiphany-1.6.0.tar.bz2) = 2983514
diff --git a/www/epiphany/pkg-plist b/www/epiphany/pkg-plist
index c71b7db133e0..9da0f027eb82 100644
--- a/www/epiphany/pkg-plist
+++ b/www/epiphany/pkg-plist
@@ -1,6 +1,7 @@
bin/epiphany
bin/epiphany-bin
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-bookmarks.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-bookmarks-type-builtins.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-command-manager.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-cookie-manager.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-dialog.h
@@ -10,10 +11,14 @@ include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-persist.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-prefs.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-shell.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-single.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-type-builtins.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed.h
-include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-encodings.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-extension.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-extensions-manager.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-history.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-lib-type-builtins.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-link.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-loader.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-node-db.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-node.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-notebook.h
@@ -21,11 +26,13 @@ include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-password-manager.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-permission-manager.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-session.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-shell.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-state.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-statusbar.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-tab.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-type-builtins.h
include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-window.h
libdata/bonobo/servers/GNOME_Epiphany_Automation.server
-libdata/pkgconfig/epiphany-%%EPHY_VERSION%%.pc
+libdata/pkgconfig/epiphany-1.6.pc
%%DOCSDIR%%/EphyCommandManager.html
%%DOCSDIR%%/EphyEmbed.html
%%DOCSDIR%%/EphyEmbedPersist.html
@@ -37,6 +44,7 @@ libdata/pkgconfig/epiphany-%%EPHY_VERSION%%.pc
%%DOCSDIR%%/ch01.html
%%DOCSDIR%%/ch02.html
%%DOCSDIR%%/epiphany-EphyEmbedFactory.html
+%%DOCSDIR%%/epiphany-EphyExtensionsManager.html
%%DOCSDIR%%/epiphany-EphyGlade.html
%%DOCSDIR%%/epiphany-ephy-cookie-manager.html
%%DOCSDIR%%/epiphany-ephy-password-manager.html
@@ -59,13 +67,12 @@ share/gnome/epiphany/art/epiphany-download.png
share/gnome/epiphany/art/epiphany-entry.png
share/gnome/epiphany/art/epiphany-history.png
share/gnome/epiphany/art/epiphany-popup-hidden.png
-share/gnome/epiphany/art/epiphany-secure.png
-share/gnome/epiphany/art/epiphany-unsecure.png
share/gnome/epiphany/art/hand-open.png
-share/gnome/epiphany/conspiracy.xhtml
share/gnome/epiphany/default-prefs.js
share/gnome/epiphany/epiphany-bookmark-editor-ui.xml
+share/gnome/epiphany/epiphany-bookmarks-html.xsl
share/gnome/epiphany/epiphany-bookmarksbar.xml
+share/gnome/epiphany/epiphany-extension.xsd
share/gnome/epiphany/epiphany-fs-toolbar.xml
share/gnome/epiphany/epiphany-history-window-ui.xml
share/gnome/epiphany/epiphany-toolbar.xml
@@ -104,11 +111,18 @@ share/gnome/help/epiphany/ja/figures/ephy-bookmarkbar-smartbookmark-screenshot.p
share/gnome/help/epiphany/ja/figures/ephy-history-window-screenshot.png
share/gnome/help/epiphany/ja/figures/ephy-screenshot.png
share/gnome/help/epiphany/ja/legal.xml
+share/gnome/help/epiphany/uk/epiphany.xml
+share/gnome/help/epiphany/uk/figures/ephy-addressbar-smartbookmark-screenshot.png
+share/gnome/help/epiphany/uk/figures/ephy-bookmarkbar-smartbookmark-screenshot.png
+share/gnome/help/epiphany/uk/figures/ephy-history-window-screenshot.png
+share/gnome/help/epiphany/uk/figures/ephy-screenshot.png
+share/gnome/help/epiphany/uk/legal.xml
share/gnome/omf/epiphany/epiphany-C.omf
share/gnome/omf/epiphany/epiphany-es.omf
share/gnome/omf/epiphany/epiphany-eu.omf
share/gnome/omf/epiphany/epiphany-fi.omf
share/gnome/omf/epiphany/epiphany-ja.omf
+share/gnome/omf/epiphany/epiphany-uk.omf
share/gnome/pixmaps/epiphany-bookmarks.png
share/locale/am/LC_MESSAGES/epiphany.mo
share/locale/ar/LC_MESSAGES/epiphany.mo
@@ -176,6 +190,8 @@ share/locale/wa/LC_MESSAGES/epiphany.mo
share/locale/zh_CN/LC_MESSAGES/epiphany.mo
share/locale/zh_TW/LC_MESSAGES/epiphany.mo
@dirrm share/gnome/omf/epiphany
+@dirrm share/gnome/help/epiphany/uk/figures
+@dirrm share/gnome/help/epiphany/uk
@dirrm share/gnome/help/epiphany/ja/figures
@dirrm share/gnome/help/epiphany/ja
@dirrm share/gnome/help/epiphany/fi/figures