aboutsummaryrefslogtreecommitdiff
path: root/www/epiphany
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
commitc4851e78e4f63338fe9a4883e5b7a0370dce27f7 (patch)
tree3910aa2e83f782cec94f15b4547dadb741cd29ce /www/epiphany
parentf82c84522b047dd99c6f9d85ce3e07217ccce7df (diff)
Notes
Diffstat (limited to 'www/epiphany')
-rw-r--r--www/epiphany/Makefile17
-rw-r--r--www/epiphany/distinfo4
-rw-r--r--www/epiphany/files/patch-configure10
-rw-r--r--www/epiphany/files/patch-embed_mozilla_mozilla-embed-single.cpp11
-rw-r--r--www/epiphany/files/patch-src_epiphany.in18
-rw-r--r--www/epiphany/pkg-descr8
-rw-r--r--www/epiphany/pkg-plist107
7 files changed, 102 insertions, 73 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index de0a05774cd8..a5e693257205 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= epiphany
-PORTVERSION= 1.0.8
+PORTVERSION= 1.2.2
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.0
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.2
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -27,10 +27,10 @@ HEADERS_SUFX=
MOZILLA= mozilla
HEADERS_SUFX=
.else
-.if ${WITH_MOZILLA}=="mozilla-devel-gtk2" || ${WITH_MOZILLA}=="mozilla-devel"
+.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
MOZILLA= mozilla-devel
HEADERS_SUFX= -devel
-MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="trunk"
+MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.7b"
.else
MOZILLA= mozilla
HEADERS_SUFX=
@@ -39,7 +39,7 @@ HEADERS_SUFX=
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
+USE_GNOME= gnomeprefix gnomehack intlhack lthack libgnomeui
WANT_GNOME= yes
USE_LIBTOOL_VER=13
USE_GMAKE= yes
@@ -53,6 +53,13 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_C
FLASHPLAYER= ${LOCALBASE}/lib/libflashplayer.so.1
XXX_FILES= EphyAutomation-common.c EphyAutomation-stubs.c \
EphyAutomation-skels.c EphyAutomation.h
+PLIST_SUB+= EPHY_VERSION="${PORTVERSION:C/\.[0-9]+$//}"
+
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
+.undef WITHOUT_GNOME
+.undef WITHOUT_ALL
+WITH_GNOME= yes
+.endif
.include <bsd.port.pre.mk>
diff --git a/www/epiphany/distinfo b/www/epiphany/distinfo
index 1e489a7b4bc1..157a17584241 100644
--- a/www/epiphany/distinfo
+++ b/www/epiphany/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/epiphany-1.0.8.tar.bz2) = 042fc75b9a272d3afce2677d04c0e927
-SIZE (gnome2/epiphany-1.0.8.tar.bz2) = 1830050
+MD5 (gnome2/epiphany-1.2.2.tar.bz2) = abf9a04159e1c0ef8c27d676ab383b8d
+SIZE (gnome2/epiphany-1.2.2.tar.bz2) = 2148870
diff --git a/www/epiphany/files/patch-configure b/www/epiphany/files/patch-configure
deleted file mode 100644
index 0f5ae010c697..000000000000
--- a/www/epiphany/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Tue Jul 15 14:31:11 2003
-+++ configure Tue Jul 15 14:31:11 2003
-@@ -18205,6 +18205,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/www/epiphany/files/patch-embed_mozilla_mozilla-embed-single.cpp b/www/epiphany/files/patch-embed_mozilla_mozilla-embed-single.cpp
new file mode 100644
index 000000000000..5f7bbebe333f
--- /dev/null
+++ b/www/epiphany/files/patch-embed_mozilla_mozilla-embed-single.cpp
@@ -0,0 +1,11 @@
+--- embed/mozilla/mozilla-embed-single.cpp.orig Thu Dec 11 14:58:19 2003
++++ embed/mozilla/mozilla-embed-single.cpp Thu Dec 11 14:58:27 2003
+@@ -385,7 +385,7 @@
+ return NS_ERROR_FAILURE;
+ }
+
+-#if MOZILLA_SNAPSHOT >= 12
++#if MOZILLA_SNAPSHOT > 12
+ result = localeService->GetLocaleComponentForUserAgent (aUILang);
+ #else
+ nsXPIDLString uiLang;
diff --git a/www/epiphany/files/patch-src_epiphany.in b/www/epiphany/files/patch-src_epiphany.in
index a5ded3caaecf..23583b77fe82 100644
--- a/www/epiphany/files/patch-src_epiphany.in
+++ b/www/epiphany/files/patch-src_epiphany.in
@@ -1,13 +1,19 @@
---- src/epiphany.in.orig Sat Dec 20 14:35:41 2003
-+++ src/epiphany.in Fri Jan 16 18:47:43 2004
-@@ -15,4 +15,12 @@
+--- src/epiphany.in.orig Sat Dec 20 14:35:58 2003
++++ src/epiphany.in Sun Dec 28 16:44:41 2003
+@@ -5,7 +5,7 @@
+ MOZILLA_HOME=@MOZILLA_HOME@
+
+ if [ -z "$MOZ_PLUGIN_PATH" ]; then
+- MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins:/usr/libexec/plugins/mozilla
++ MOZ_PLUGIN_PATH=%%X11BASE%%/lib/browser_plugins
+ export MOZ_PLUGIN_PATH
+ fi
+
+@@ -28,4 +28,9 @@
MOZILLA_FIVE_HOME=$MOZILLA_HOME
export MOZILLA_FIVE_HOME
-exec "$dist_bin/epiphany-bin" "$@"
-+MOZ_PLUGIN_PATH=%%X11BASE%%/lib/browser_plugins
-+export MOZ_PLUGIN_PATH
-+
+if [ -f %%FLASHPLAYER%% ]; then
+ LD_PRELOAD=%%FLASHPLAYER%%
+ export LD_PRELOAD
diff --git a/www/epiphany/pkg-descr b/www/epiphany/pkg-descr
index f24cd9a2e683..24a41f93deac 100644
--- a/www/epiphany/pkg-descr
+++ b/www/epiphany/pkg-descr
@@ -1,7 +1,5 @@
-Epiphany, as it's manifesto states, is a web browser designed for the layman,
-by being consistent, lightweight and fast throughout all its operations.
-
-Originally forked from Galeon's (www/galeon2) source code, Epiphany looks to
-be a very promising browser indeed.
+Epiphany is a web browser designed to be as lightweight and fast as
+possible, at the expense of many of the features found in other
+browsers.
WWW: http://epiphany.mozdev.org/
diff --git a/www/epiphany/pkg-plist b/www/epiphany/pkg-plist
index 042b95d598eb..d4237ee0eeb2 100644
--- a/www/epiphany/pkg-plist
+++ b/www/epiphany/pkg-plist
@@ -4,82 +4,94 @@ etc/gconf/gconf.xml.defaults/apps/epiphany/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/epiphany/dialogs/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/epiphany/directories/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/epiphany/general/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/epiphany/lockdown/%gconf.xml
etc/gconf/gconf.xml.defaults/apps/epiphany/web/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/epiphany/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/epiphany/dialogs/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/epiphany/directories/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/epiphany/general/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/epiphany/lockdown/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/epiphany/web/%gconf.xml
+etc/gconf/schemas/epiphany-lockdown.schemas
etc/gconf/schemas/epiphany.schemas
-include/epiphany-1.0/epiphany/ephy-bookmarks.h
-include/epiphany-1.0/epiphany/ephy-dialog.h
-include/epiphany-1.0/epiphany/ephy-embed-event.h
-include/epiphany-1.0/epiphany/ephy-embed-persist.h
-include/epiphany-1.0/epiphany/ephy-embed-prefs.h
-include/epiphany-1.0/epiphany/ephy-embed-shell.h
-include/epiphany-1.0/epiphany/ephy-embed-single.h
-include/epiphany-1.0/epiphany/ephy-embed-types.h
-include/epiphany-1.0/epiphany/ephy-embed.h
-include/epiphany-1.0/epiphany/ephy-history.h
-include/epiphany-1.0/epiphany/ephy-langs.h
-include/epiphany-1.0/epiphany/ephy-node-db.h
-include/epiphany-1.0/epiphany/ephy-node.h
-include/epiphany-1.0/epiphany/ephy-notebook.h
-include/epiphany-1.0/epiphany/ephy-shell.h
-include/epiphany-1.0/epiphany/ephy-tab.h
-include/epiphany-1.0/epiphany/ephy-types.h
-include/epiphany-1.0/epiphany/ephy-window.h
-include/epiphany-1.0/epiphany/session.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-bookmarks.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-command-manager.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-cookie-manager.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-dialog.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-event.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-persist.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-prefs.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-shell.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed-single.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-embed.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-encodings.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-extension.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-history.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-node-db.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-node.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-notebook.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-password-manager.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-permission-manager.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-session.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-shell.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-statusbar.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-tab.h
+include/epiphany-%%EPHY_VERSION%%/epiphany/ephy-window.h
libdata/bonobo/servers/GNOME_Epiphany_Automation.server
libdata/bonobo/servers/GNOME_Epiphany_NautilusView.server
-libdata/pkgconfig/epiphany-1.0.pc
+libdata/pkgconfig/epiphany-1.2.pc
+%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/epiphany-ephy-cookie-manager.html
+%%DOCSDIR%%/epiphany-ephy-embed-factory.html
+%%DOCSDIR%%/epiphany-ephy-embed-single.html
+%%DOCSDIR%%/epiphany-ephy-password-manager.html
+%%DOCSDIR%%/epiphany-ephy-permission-manager.html
+%%DOCSDIR%%/epiphany-ephy-session.html
+%%DOCSDIR%%/epiphany-ephy-shell.html
+%%DOCSDIR%%/epiphany.devhelp
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/up.png
share/gnome/application-registry/epiphany.applications
share/gnome/applications/bme.desktop
share/gnome/applications/epiphany.desktop
-share/gnome/epiphany/art/epiphany-bookmark-page.png
share/gnome/epiphany/art/epiphany-bookmarks.png
share/gnome/epiphany/art/epiphany-download.png
share/gnome/epiphany/art/epiphany-entry.png
-share/gnome/epiphany/art/epiphany-fullscreen.png
share/gnome/epiphany/art/epiphany-history.png
-share/gnome/epiphany/art/epiphany-new-tab.png
share/gnome/epiphany/art/epiphany-secure.png
-share/gnome/epiphany/art/epiphany-send-link.png
share/gnome/epiphany/art/epiphany-tab-loading.gif
share/gnome/epiphany/art/epiphany-unsecure.png
-share/gnome/epiphany/art/epiphany-viewsource.png
+share/gnome/epiphany/art/hand-open.png
share/gnome/epiphany/conspiracy.xhtml
+share/gnome/epiphany/default-prefs.js
share/gnome/epiphany/epiphany-bookmark-editor-ui.xml
+share/gnome/epiphany/epiphany-fs-toolbar.xml
share/gnome/epiphany/epiphany-history-window-ui.xml
share/gnome/epiphany/epiphany-toolbar.xml
share/gnome/epiphany/epiphany-ui.xml
share/gnome/epiphany/epiphany.xhtml
+share/gnome/epiphany/glade/certificate-dialogs.glade
share/gnome/epiphany/glade/epiphany.glade
share/gnome/epiphany/glade/prefs-dialog.glade
share/gnome/epiphany/glade/print.glade
+share/gnome/epiphany/mime-types-permissions.xml
share/gnome/epiphany/nautilus-epiphany-view.xml
share/gnome/help/epiphany/C/epiphany.xml
share/gnome/help/epiphany/C/figures/ephy-history-window-screenshot.png
share/gnome/help/epiphany/C/figures/ephy-screenshot.png
share/gnome/help/epiphany/C/legal.xml
-share/gnome/help/epiphany/nl/epiphany.xml
-share/gnome/help/epiphany/nl/figures/ephy-screenshot.png
-share/gnome/help/epiphany/nl/legal.xml
-share/gnome/help/epiphany/uk/epiphany.xml
-share/gnome/help/epiphany/uk/figures/ephy-history-window-screenshot.png
-share/gnome/help/epiphany/uk/figures/ephy-screenshot.png
-share/gnome/help/epiphany/uk/legal.xml
share/gnome/omf/epiphany/epiphany-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/epiphany/epiphany-C.omf 2>/dev/null || /usr/bin/true
-share/gnome/omf/epiphany/epiphany-nl.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/epiphany/epiphany-nl.omf 2>/dev/null || /usr/bin/true
-share/gnome/omf/epiphany/epiphany-uk.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/epiphany/epiphany-uk.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/epiphany-bookmarks.png
share/locale/am/LC_MESSAGES/epiphany.mo
share/locale/az/LC_MESSAGES/epiphany.mo
share/locale/ar/LC_MESSAGES/epiphany.mo
share/locale/be/LC_MESSAGES/epiphany.mo
+share/locale/bg/LC_MESSAGES/epiphany.mo
share/locale/bn/LC_MESSAGES/epiphany.mo
share/locale/ca/LC_MESSAGES/epiphany.mo
share/locale/cs/LC_MESSAGES/epiphany.mo
@@ -87,26 +99,33 @@ share/locale/cy/LC_MESSAGES/epiphany.mo
share/locale/da/LC_MESSAGES/epiphany.mo
share/locale/de/LC_MESSAGES/epiphany.mo
share/locale/el/LC_MESSAGES/epiphany.mo
+share/locale/en_CA/LC_MESSAGES/epiphany.mo
share/locale/en_GB/LC_MESSAGES/epiphany.mo
share/locale/es/LC_MESSAGES/epiphany.mo
share/locale/et/LC_MESSAGES/epiphany.mo
+share/locale/fa/LC_MESSAGES/epiphany.mo
share/locale/fi/LC_MESSAGES/epiphany.mo
share/locale/fr/LC_MESSAGES/epiphany.mo
share/locale/ga/LC_MESSAGES/epiphany.mo
+share/locale/gu/LC_MESSAGES/epiphany.mo
share/locale/hi/LC_MESSAGES/epiphany.mo
+share/locale/hr/LC_MESSAGES/epiphany.mo
share/locale/hu/LC_MESSAGES/epiphany.mo
+share/locale/id/LC_MESSAGES/epiphany.mo
share/locale/is/LC_MESSAGES/epiphany.mo
share/locale/it/LC_MESSAGES/epiphany.mo
share/locale/ja/LC_MESSAGES/epiphany.mo
-share/locale/kn/LC_MESSAGES/epiphany.mo
share/locale/ko/LC_MESSAGES/epiphany.mo
share/locale/li/LC_MESSAGES/epiphany.mo
share/locale/lt/LC_MESSAGES/epiphany.mo
+share/locale/mi/LC_MESSAGES/epiphany.mo
share/locale/mk/LC_MESSAGES/epiphany.mo
share/locale/mn/LC_MESSAGES/epiphany.mo
share/locale/ms/LC_MESSAGES/epiphany.mo
share/locale/nl/LC_MESSAGES/epiphany.mo
share/locale/no/LC_MESSAGES/epiphany.mo
+share/locale/nn/LC_MESSAGES/epiphany.mo
+share/locale/pa/LC_MESSAGES/epiphany.mo
share/locale/pl/LC_MESSAGES/epiphany.mo
share/locale/pt/LC_MESSAGES/epiphany.mo
share/locale/pt_BR/LC_MESSAGES/epiphany.mo
@@ -122,31 +141,29 @@ share/locale/ta/LC_MESSAGES/epiphany.mo
share/locale/tr/LC_MESSAGES/epiphany.mo
share/locale/uk/LC_MESSAGES/epiphany.mo
share/locale/vi/LC_MESSAGES/epiphany.mo
+share/locale/wa/LC_MESSAGES/epiphany.mo
share/locale/zh_CN/LC_MESSAGES/epiphany.mo
share/locale/zh_TW/LC_MESSAGES/epiphany.mo
@dirrm share/gnome/omf/epiphany
-@dirrm share/gnome/help/epiphany/uk/figures
-@dirrm share/gnome/help/epiphany/uk
-@dirrm share/gnome/help/epiphany/nl/figures
-@dirrm share/gnome/help/epiphany/nl
@dirrm share/gnome/help/epiphany/C/figures
@dirrm share/gnome/help/epiphany/C
@dirrm share/gnome/help/epiphany
@dirrm share/gnome/epiphany/glade
@dirrm share/gnome/epiphany/art
@dirrm share/gnome/epiphany
-@dirrm include/epiphany-1.0/epiphany
-@dirrm include/epiphany-1.0
+@dirrm %%DOCSDIR%%
+@dirrm include/epiphany-%%EPHY_VERSION%%/epiphany
+@dirrm include/epiphany-%%EPHY_VERSION%%
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/epiphany/web
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/epiphany/lockdown
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/epiphany/general
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/epiphany/directories
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/epiphany/dialogs
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/epiphany
@dirrm etc/gconf/gconf.xml.defaults/apps/epiphany/web
+@dirrm etc/gconf/gconf.xml.defaults/apps/epiphany/lockdown
@dirrm etc/gconf/gconf.xml.defaults/apps/epiphany/general
@dirrm etc/gconf/gconf.xml.defaults/apps/epiphany/directories
@dirrm etc/gconf/gconf.xml.defaults/apps/epiphany/dialogs
@dirrm etc/gconf/gconf.xml.defaults/apps/epiphany
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/epiphany/epiphany-C.omf 2>/dev/null || /usr/bin/true
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/epiphany/epiphany-nl.omf 2>/dev/null || /usr/bin/true
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/epiphany/epiphany-uk.omf 2>/dev/null || /usr/bin/true