aboutsummaryrefslogtreecommitdiff
path: root/www/erlang-webmachine
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2018-05-19 07:26:17 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2018-05-19 07:26:17 +0000
commitbc2c8d807a85ad202cdeaf59a7cb613c0e0485cd (patch)
treef7cda0ab2f43b37d6290c8cee72f61e404faf1de /www/erlang-webmachine
parent4b972df5c48e7b8422d13a78c5be4744ad7b52ec (diff)
downloadports-bc2c8d807a85ad202cdeaf59a7cb613c0e0485cd.tar.gz
ports-bc2c8d807a85ad202cdeaf59a7cb613c0e0485cd.zip
Notes
Diffstat (limited to 'www/erlang-webmachine')
-rw-r--r--www/erlang-webmachine/Makefile6
-rw-r--r--www/erlang-webmachine/distinfo5
-rw-r--r--www/erlang-webmachine/files/patch-Makefile11
-rw-r--r--www/erlang-webmachine/files/patch-rebar.config14
-rw-r--r--www/erlang-webmachine/pkg-plist29
5 files changed, 13 insertions, 52 deletions
diff --git a/www/erlang-webmachine/Makefile b/www/erlang-webmachine/Makefile
index dfb8dc5e5cbe..948282b23d4f 100644
--- a/www/erlang-webmachine/Makefile
+++ b/www/erlang-webmachine/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= webmachine
-PORTVERSION= 1.10.8
+PORTVERSION= 1.10.9
CATEGORIES= www devel
PKGNAMEPREFIX= erlang-
@@ -17,8 +17,4 @@ GH_ACCOUNT= webmachine
ERL_BUILD_DEPS= www/erlang-mochiweb-basho
ERL_RUN_DEPS:= ${ERL_BUILD_DEPS}
-post-install:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/demo && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
-
.include <bsd.port.mk>
diff --git a/www/erlang-webmachine/distinfo b/www/erlang-webmachine/distinfo
index d6986f7f10d3..11644e0ccfd5 100644
--- a/www/erlang-webmachine/distinfo
+++ b/www/erlang-webmachine/distinfo
@@ -1,2 +1,3 @@
-SHA256 (webmachine-webmachine-1.10.8_GH0.tar.gz) = d93c2dacc1786db5c56a2b6536f6254038452d9096483becbaceb6643ecc8dcc
-SIZE (webmachine-webmachine-1.10.8_GH0.tar.gz) = 1642596
+TIMESTAMP = 1526713504
+SHA256 (webmachine-webmachine-1.10.9_GH0.tar.gz) = febf7a29f79763f1ddcc8234ae53780dfb1b707fa5423c6e271d77f8145160f0
+SIZE (webmachine-webmachine-1.10.9_GH0.tar.gz) = 1521443
diff --git a/www/erlang-webmachine/files/patch-Makefile b/www/erlang-webmachine/files/patch-Makefile
deleted file mode 100644
index 4f866250bb75..000000000000
--- a/www/erlang-webmachine/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2015-02-11 18:40:46 UTC
-+++ Makefile
-@@ -11,7 +11,7 @@ all: deps compile
- compile: deps
- ./rebar compile
-
--deps: DEV_MODE
-+deps:
- @(./rebar get-deps)
-
- clean:
diff --git a/www/erlang-webmachine/files/patch-rebar.config b/www/erlang-webmachine/files/patch-rebar.config
index f4c1028a0c4d..fbbeaea1d915 100644
--- a/www/erlang-webmachine/files/patch-rebar.config
+++ b/www/erlang-webmachine/files/patch-rebar.config
@@ -1,17 +1,15 @@
---- rebar.config.orig 2015-02-11 18:40:46 UTC
+--- rebar.config.orig 2018-05-19 07:23:21 UTC
+++ rebar.config
-@@ -1,12 +1,12 @@
+@@ -1,11 +1,10 @@
%%-*- mode: erlang -*-
-{erl_opts, [warnings_as_errors]}.
-+{erl_opts, []}.
{cover_enabled, true}.
{edoc_opts, [{preprocess, true}]}.
{xref_checks, [undefined_function_calls]}.
- {deps,
-- [{mochiweb, "2.9.0", {git, "git://github.com/basho/mochiweb.git", {tag, "v2.9.0p1"}}}
-+ [
- ]}.
+-{deps, [{mochiweb, {git, "https://github.com/mochi/mochiweb", {tag, "v2.17.0"}}}]}.
++{deps, []}.
- {dev_only_deps,
+ {eunit_opts, [
+ no_tty,
diff --git a/www/erlang-webmachine/pkg-plist b/www/erlang-webmachine/pkg-plist
index e561a741dd72..3efecc16aedf 100644
--- a/www/erlang-webmachine/pkg-plist
+++ b/www/erlang-webmachine/pkg-plist
@@ -8,6 +8,7 @@ lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_dispatcher.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_error.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_error_handler.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_error_log_handler.beam
+lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_headers.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_log.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_logger_watcher.beam
lib/erlang/lib/webmachine-%%VERSION%%/ebin/webmachine_logger_watcher_sup.beam
@@ -26,17 +27,6 @@ lib/erlang/lib/webmachine-%%VERSION%%/include/webmachine_logger.hrl
lib/erlang/lib/webmachine-%%VERSION%%/include/wm_reqdata.hrl
lib/erlang/lib/webmachine-%%VERSION%%/include/wm_reqstate.hrl
lib/erlang/lib/webmachine-%%VERSION%%/include/wm_resource.hrl
-lib/erlang/lib/webmachine-%%VERSION%%/priv/templates/Makefile
-lib/erlang/lib/webmachine-%%VERSION%%/priv/templates/README
-lib/erlang/lib/webmachine-%%VERSION%%/priv/templates/rebar.config
-lib/erlang/lib/webmachine-%%VERSION%%/priv/templates/src/wmskel.app.src
-lib/erlang/lib/webmachine-%%VERSION%%/priv/templates/src/wmskel.erl
-lib/erlang/lib/webmachine-%%VERSION%%/priv/templates/src/wmskel_app.erl
-lib/erlang/lib/webmachine-%%VERSION%%/priv/templates/src/wmskel_config.erl
-lib/erlang/lib/webmachine-%%VERSION%%/priv/templates/src/wmskel_resource.erl
-lib/erlang/lib/webmachine-%%VERSION%%/priv/templates/src/wmskel_sup.erl
-lib/erlang/lib/webmachine-%%VERSION%%/priv/templates/start.sh
-lib/erlang/lib/webmachine-%%VERSION%%/priv/templates/wmskel.template
lib/erlang/lib/webmachine-%%VERSION%%/priv/trace/http-headers-status-v3.png
lib/erlang/lib/webmachine-%%VERSION%%/priv/trace/wmtrace.css
lib/erlang/lib/webmachine-%%VERSION%%/priv/trace/wmtrace.js
@@ -51,6 +41,7 @@ lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_dispatcher.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_error.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_error_handler.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_error_log_handler.erl
+lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_headers.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_log.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_logger_watcher.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_logger_watcher_sup.erl
@@ -64,18 +55,4 @@ lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_sup.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/webmachine_util.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/wmtrace_resource.erl
lib/erlang/lib/webmachine-%%VERSION%%/src/wrq.erl
-%%PORTDOCS%%%%DOCSDIR%%/README.org
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/priv/dispatch.conf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rebar.config
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo.app.src
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo_app.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo_fs_resource.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo_resource.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo_sup.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/webmachine_demo_upload_resource.erl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/start.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/form.dtl
-%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/priv/www/uploads
+%%PORTDOCS%%%%DOCSDIR%%/README.md