aboutsummaryrefslogtreecommitdiff
path: root/www/erwn
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-03 13:52:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-03 13:52:19 +0000
commit56faeda39d771a4c68061c4cb0c9e0df66a3852f (patch)
treeb65671e028b5cc2830f16f473eb5cb8dd98f2ebe /www/erwn
parent9a97af02c0423996f8f1fcbf22ce75c0f9337a5d (diff)
downloadports-56faeda39d771a4c68061c4cb0c9e0df66a3852f.tar.gz
ports-56faeda39d771a4c68061c4cb0c9e0df66a3852f.zip
Notes
Diffstat (limited to 'www/erwn')
-rw-r--r--www/erwn/Makefile15
-rw-r--r--www/erwn/distinfo2
-rw-r--r--www/erwn/files/patch-aa43
-rw-r--r--www/erwn/files/patch-configure10
-rw-r--r--www/erwn/pkg-plist4
5 files changed, 22 insertions, 52 deletions
diff --git a/www/erwn/Makefile b/www/erwn/Makefile
index 24703951b068..a859cac4e54d 100644
--- a/www/erwn/Makefile
+++ b/www/erwn/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= erwn
-PORTVERSION= 0.3.1
+PORTVERSION= 0.5
CATEGORIES= www editors
-MASTER_SITES= http://lisas.de/erwin/legacy/
+MASTER_SITES= http://lisas.de/erwin/
DISTNAME= erwin-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -16,13 +16,16 @@ COMMENT= Simple (at the moment) html editor based on GTK+
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gtk12
+USE_GNOME= gtk20 libxml2 libgtkhtml
+USE_LIBTOOL= yes
+
+MAN1= erwin.1
post-install:
.if !defined(NOPORTDOCS)
- @${ECHO} "===> Installing README in ${PREFIX}/share/doc/erwin"
- @${MKDIR} ${PREFIX}/share/doc/erwin && ${CHMOD} a+rx ${PREFIX}/share/doc/erwin
- @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/erwin
+ @${ECHO} "===> Installing README in ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/www/erwn/distinfo b/www/erwn/distinfo
index f82f342e0935..e8c76734141c 100644
--- a/www/erwn/distinfo
+++ b/www/erwn/distinfo
@@ -1 +1 @@
-MD5 (erwin-0.3.1.tar.gz) = 73ea4a702ecdac15551019cd7653b289
+MD5 (erwin-0.5.tar.gz) = 34cc4ea1ff7681ef73ba2b3239753740
diff --git a/www/erwn/files/patch-aa b/www/erwn/files/patch-aa
deleted file mode 100644
index 7d20775801f7..000000000000
--- a/www/erwn/files/patch-aa
+++ /dev/null
@@ -1,43 +0,0 @@
---- Makefile.orig Sun Jul 25 05:33:08 1999
-+++ Makefile Sat Jul 1 17:57:20 2000
-@@ -2,14 +2,14 @@
- bindir = $(prefix)/bin
-
- NAME = erwin-0.3.1
--CC = gcc
-+CC ?= gcc
- PROG = erwin
- OBJS = erwin.o erwinmenu.o erwinfunctions.o erwintoolbar.o \
- erwinnotebook.o erwindialogs.o erwintags.o gtkmessage.o
- INSTALL = install
--DEBUG = -g -DDEBUG
-+DEBUG = # -g -DDEBUG
-
--CFLAGS = -DNAME=\"$(NAME)\" $(DEBUG) -Wall -O2 -m486 -fno-strength-reduce -malign-functions=4 -malign-jumps=4 -malign-loops=4 -ffast-math -fexpensive-optimizations
-+CFLAGS += -DNAME=\"$(NAME)\" $(DEBUG) -fno-strength-reduce -ffast-math -fexpensive-optimizations
-
- all: license $(PROG)
-
-@@ -17,8 +17,7 @@
- strip $(PROG)
-
- install: strip
-- $(INSTALL) -d $(bindir)
-- $(INSTALL) -m 0755 $(PROG) $(bindir)
-+ ${BSD_INSTALL_PROGRAM} $(PROG) $(bindir)
-
- uninstall:
-
-@@ -28,10 +27,10 @@
- rm -f $(PROG) $(OBJS) *.?~ core license.h
-
- $(PROG): $(OBJS)
-- $(CC) $(LDFLAGS) $(shell gtk-config --libs) -o $@ $(OBJS)
-+ $(CC) $(LDFLAGS) `$(GTK_CONFIG) --libs` -o $@ $(OBJS)
-
- %.o: %.c
-- $(CC) $(CFLAGS) $(shell gtk-config --cflags) -o $@ -c $<
-+ $(CC) $(CFLAGS) `$(GTK_CONFIG) --cflags` -o $@ -c $<
-
- tar: clean
- cd ..; ln -s erwin $(NAME);tar cf - $(NAME)/* > $(NAME).tar;rm $(NAME);gzip -f $(NAME).tar
diff --git a/www/erwn/files/patch-configure b/www/erwn/files/patch-configure
new file mode 100644
index 000000000000..7872b8ad3a23
--- /dev/null
+++ b/www/erwn/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sat Jan 3 13:51:30 2004
++++ configure Sat Jan 3 13:51:48 2004
+@@ -5705,6 +5705,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/www/erwn/pkg-plist b/www/erwn/pkg-plist
index d1683263137c..21e2a819f0b7 100644
--- a/www/erwn/pkg-plist
+++ b/www/erwn/pkg-plist
@@ -1,3 +1,3 @@
bin/erwin
-share/doc/erwin/README
-@dirrm share/doc/erwin
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%