aboutsummaryrefslogtreecommitdiff
path: root/www/extsm
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2007-04-11 14:54:13 +0000
committerStanislav Sedov <stas@FreeBSD.org>2007-04-11 14:54:13 +0000
commite9295b2e92a984fb40d26cf6b3d7dfd40fc39390 (patch)
treebb454bce09fac413985e77593599f33a7e602a08 /www/extsm
parent52e95543cbd997b061cf3a7c0822d18614c90e62 (diff)
downloadports-e9295b2e92a984fb40d26cf6b3d7dfd40fc39390.tar.gz
ports-e9295b2e92a984fb40d26cf6b3d7dfd40fc39390.zip
Notes
Diffstat (limited to 'www/extsm')
-rw-r--r--www/extsm/Makefile82
-rw-r--r--www/extsm/distinfo3
-rw-r--r--www/extsm/pkg-descr24
-rw-r--r--www/extsm/pkg-message9
4 files changed, 118 insertions, 0 deletions
diff --git a/www/extsm/Makefile b/www/extsm/Makefile
new file mode 100644
index 000000000000..25bbfc670067
--- /dev/null
+++ b/www/extsm/Makefile
@@ -0,0 +1,82 @@
+# New ports collection makefile for: xsm
+# Date created: 2006-07-30
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xsm
+PORTVERSION= 1.0
+CATEGORIES= www java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=rxsm
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Extensible Site Manager
+
+RUN_DEPENDS= ${LOCALBASE}/bin/ant:${PORTSDIR}/devel/apache-ant
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+OPTIONS= TOMCAT4 "Use Jakarta Tomcat 4" off \
+ TOMCAT41 "Use Jakarta Tomcat 4.1" off \
+ TOMCAT5 "Use Jakarta Tomcat 5" on \
+ TOMCAT55 "Use Jakarta Tomcat 5.55" off \
+ RESIN2 "Use Resin 2" off \
+ RESIN3 "Use Resin 3" off
+
+.include <bsd.port.pre.mk>
+
+WEBAPP_DIRS= #empty
+.if defined(WITH_TOMCAT4)
+WEBAPP_DIRS+= jakarta-tomcat4.0
+RUN_DEPENDS+= ${PREFIX}/jakarta-tomcat4.0/bin/bootstrap.jar:${PORTSDIR}/www/jakarta-tomcat4
+.endif
+
+.if defined(WITH_TOMCAT41)
+WEBAPP_DIRS+= tomcat4.1
+RUN_DEPENDS+= ${PREFIX}/tomcat4.1/bin/bootstrap.jar:${PORTSDIR}/www/tomcat41
+.endif
+
+.if defined(WITH_TOMCAT5)
+WEBAPP_DIRS+= jakarta-tomcat5.0
+RUN_DEPENDS+= ${PREFIX}/jakarta-tomcat5.0/bin/bootstrap.jar:${PORTSDIR}/www/jakarta-tomcat5
+.endif
+
+.if defined(WITH_TOMCAT55)
+WEBAPP_DIRS+= tomcat5.5
+RUN_DEPENDS+= ${PREFIX}/tomcat5.5/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+.endif
+
+.if defined(WITH_RESIN2)
+WEBAPP_DIRS+= resin2
+RUN_DEPENDS+= ${PREFIX}/resin2/lib/resin.jar:${PORTSDIR}/www/resin2
+.endif
+
+.if defined(WITH_RESIN3)
+WEBAPP_DIRS+= resin3
+RUN_DEPENDS+= ${PREFIX}/resin3/lib/resin.jar:${PORTSDIR}/www/resin3
+.endif
+
+do-install:
+.if ${PREFIX}!=${LOCALBASE}
+ @${ECHO_CMD} "Warning: you changed prefix to ${PREFIX}"
+ @${ECHO_CMD} "Default installation will not work if you installed"
+ @${ECHO_CMD} "application server in different prefix"
+.endif
+.for DIR in ${WEBAPP_DIRS}
+ @${ECHO_CMD} "${DIR}/webapps/xsm.war" >> ${TMPPLIST}
+.if !exists(${PREFIX}/${DIR}/webapps)
+ ${MKDIR} ${PREFIX}/${DIR}/webapps
+ @${ECHO_CMD} "@dirrm ${DIR}/webapps" >> ${TMPPLIST}
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/xsm.war ${PREFIX}/${DIR}/webapps
+.endfor
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/extsm/distinfo b/www/extsm/distinfo
new file mode 100644
index 000000000000..33e3cb7c9512
--- /dev/null
+++ b/www/extsm/distinfo
@@ -0,0 +1,3 @@
+MD5 (xsm_1.0.tar.gz) = 4906e02686ad5e1ae7125aba139cd1ca
+SHA256 (xsm_1.0.tar.gz) = 708c53555ae1bb65108f57f09ec39fe00c8cefb4456922205a98823c414820a1
+SIZE (xsm_1.0.tar.gz) = 2779061
diff --git a/www/extsm/pkg-descr b/www/extsm/pkg-descr
new file mode 100644
index 000000000000..d0a59eb63aa0
--- /dev/null
+++ b/www/extsm/pkg-descr
@@ -0,0 +1,24 @@
+Rectang XSM (eXtensible Site Manager)
+
+XSM is a new Content management system for generating fast web sites.
+The system generates "static" html pages using Java / JSP renderers.
+Published content can be stored locally or distributed over an ssh connection.
+The backend uses only XML for easy management and backup.
+
+Using the TinyMCE open source project we can offer a WYSIWYG editor for
+editing HTML based document types ("HTML" and "News")
+
+Other Document types include:
+ * Html - (as above) simple WYSIWYG edited page for any content
+ * News - blog style inclue RSS and archive
+ * Gallery - generates thumbnails and previews along with pages for browsing
+ * Files - simple file listing for uploading misc files
+ * Book - for collating large, structured documents - generates individual
+ pages and a "printer friendly" version.
+ * FAQs - classic structure for a collection of question-answer knowledge
+ * PreviewdFile - file list, but providing a preview image and description for
+ every file
+ * Links - categorised links for the necessary "links" page
+
+Author: Andy (HandyAndE) Williams
+WWW: http://www.rectang.com/Software/XSM/
diff --git a/www/extsm/pkg-message b/www/extsm/pkg-message
new file mode 100644
index 000000000000..96b4ce118acd
--- /dev/null
+++ b/www/extsm/pkg-message
@@ -0,0 +1,9 @@
+
+===========================================================================
+Note, that XSM webapp should have rights to write to the directory "custom"
+within its context.
+
+For further installation instructions look at
+http://www.rectang.com/Software/XSM/
+===========================================================================
+