aboutsummaryrefslogtreecommitdiff
path: root/www/fancybox
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-06-02 04:05:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-06-02 04:05:56 +0000
commit05ca9d1eae4af0aae0ff95b4c3afe65f2ce4ba33 (patch)
treed20b44ee4e11f134d98e8e6755ce77486256d83a /www/fancybox
parentb8499703b5f923842828dc3a4d7fc3414034d808 (diff)
downloadports-05ca9d1eae4af0aae0ff95b4c3afe65f2ce4ba33.tar.gz
ports-05ca9d1eae4af0aae0ff95b4c3afe65f2ce4ba33.zip
Notes
Diffstat (limited to 'www/fancybox')
-rw-r--r--www/fancybox/Makefile25
-rw-r--r--www/fancybox/distinfo2
-rw-r--r--www/fancybox/pkg-descr15
-rw-r--r--www/fancybox/pkg-plist26
4 files changed, 68 insertions, 0 deletions
diff --git a/www/fancybox/Makefile b/www/fancybox/Makefile
new file mode 100644
index 000000000000..a0b459c059bb
--- /dev/null
+++ b/www/fancybox/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: fancybox
+# Date created: 2011-05-30
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fancybox
+PORTVERSION= 1.3.4
+CATEGORIES= www
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= jquery.${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A JavaScript library for image/html/multimedia content display
+
+NO_BUILD= yes
+USE_ZIP= yes
+
+do-install:
+ ${MKDIR} ${WWWDIR}/
+ cd ${WRKSRC}/${PORTNAME}/ && ${INSTALL_DATA} * ${WWWDIR}/
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}/
+
+.include <bsd.port.mk>
diff --git a/www/fancybox/distinfo b/www/fancybox/distinfo
new file mode 100644
index 000000000000..5691a22f8e28
--- /dev/null
+++ b/www/fancybox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jquery.fancybox-1.3.4.zip) = bb2757bfb3546ce482dd1bc8ea7789a85574c81082c9327a021a2c84470cec49
+SIZE (jquery.fancybox-1.3.4.zip) = 639850
diff --git a/www/fancybox/pkg-descr b/www/fancybox/pkg-descr
new file mode 100644
index 000000000000..b847dd86d905
--- /dev/null
+++ b/www/fancybox/pkg-descr
@@ -0,0 +1,15 @@
+FancyBox is a tool for displaying images, html content and multi-media in a
+Mac-style "lightbox" that floats overtop of web page. It was built using the
+jQuery library. Licensed under both MIT and GPL licenses.
+
+Features:
+- Can display images, HTML elements, SWF movies, iframes and also Ajax
+ requests.
+- Customizable through settings and CSS.
+- Groups related items and adds navigation.
+- If the mouse wheel plugin is included in the page then FancyBox will
+ respond to mouse wheel events as well.
+- Support fancy transitions by using easing plugin.
+- Adds a nice drop shadow under the zoomed item.
+
+WWW: http://fancybox.net/
diff --git a/www/fancybox/pkg-plist b/www/fancybox/pkg-plist
new file mode 100644
index 000000000000..8cecfdebf199
--- /dev/null
+++ b/www/fancybox/pkg-plist
@@ -0,0 +1,26 @@
+%%WWWDIR%%/blank.gif
+%%WWWDIR%%/fancy_close.png
+%%WWWDIR%%/fancy_loading.png
+%%WWWDIR%%/fancy_nav_left.png
+%%WWWDIR%%/fancy_nav_right.png
+%%WWWDIR%%/fancy_shadow_e.png
+%%WWWDIR%%/fancy_shadow_n.png
+%%WWWDIR%%/fancy_shadow_ne.png
+%%WWWDIR%%/fancy_shadow_nw.png
+%%WWWDIR%%/fancy_shadow_s.png
+%%WWWDIR%%/fancy_shadow_se.png
+%%WWWDIR%%/fancy_shadow_sw.png
+%%WWWDIR%%/fancy_shadow_w.png
+%%WWWDIR%%/fancy_title_left.png
+%%WWWDIR%%/fancy_title_main.png
+%%WWWDIR%%/fancy_title_over.png
+%%WWWDIR%%/fancy_title_right.png
+%%WWWDIR%%/fancybox-x.png
+%%WWWDIR%%/fancybox-y.png
+%%WWWDIR%%/fancybox.png
+%%WWWDIR%%/jquery.easing-1.3.pack.js
+%%WWWDIR%%/jquery.fancybox-1.3.4.css
+%%WWWDIR%%/jquery.fancybox-1.3.4.js
+%%WWWDIR%%/jquery.fancybox-1.3.4.pack.js
+%%WWWDIR%%/jquery.mousewheel-3.0.4.pack.js
+@dirrm %%WWWDIR%%