aboutsummaryrefslogtreecommitdiff
path: root/www/faup/files
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-11-25 22:07:21 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-11-25 22:07:21 +0000
commitdbaeeeeb71a1d88c4337bb9f1803ad654e570256 (patch)
treea511f77bf3a403d4013384b72356201d6a738079 /www/faup/files
parent17dcb8e9f485433cf5d16ae80926fae41810c55a (diff)
downloadports-dbaeeeeb71a1d88c4337bb9f1803ad654e570256.tar.gz
ports-dbaeeeeb71a1d88c4337bb9f1803ad654e570256.zip
Notes
Diffstat (limited to 'www/faup/files')
-rw-r--r--www/faup/files/patch-CMakeLists.txt11
-rw-r--r--www/faup/files/patch-src__lib__modules__CMakeLists.txt8
2 files changed, 19 insertions, 0 deletions
diff --git a/www/faup/files/patch-CMakeLists.txt b/www/faup/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..5d6678024084
--- /dev/null
+++ b/www/faup/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./CMakeLists.txt.orig 2013-09-25 08:53:24.000000000 +0000
++++ ./CMakeLists.txt 2013-11-16 12:02:09.000000000 +0000
+@@ -74,7 +74,7 @@
+
+ set(FAUP_INCLUDE_DIRS "${faup-project_SOURCE_DIR}/src/lib/include/" "${faup-project_BINARY_DIR}/src/lib/include")
+
+-set(FAUP_LIBRARY "${faup-project_BINARY_DIR}/src/lib/libfaupl.so")
++set(FAUP_LIBRARY faupl)
+ if(WIN32)
+ set(FAUP_LIBRARY "${faup-project_BINARY_DIR}/src/lib/${CMAKE_BUILD_TYPE}/faup_static.lib")
+ endif(WIN32)
diff --git a/www/faup/files/patch-src__lib__modules__CMakeLists.txt b/www/faup/files/patch-src__lib__modules__CMakeLists.txt
new file mode 100644
index 000000000000..a2b191b3fa44
--- /dev/null
+++ b/www/faup/files/patch-src__lib__modules__CMakeLists.txt
@@ -0,0 +1,8 @@
+--- ./src/lib/modules/CMakeLists.txt.orig 2013-09-25 08:53:24.000000000 +0000
++++ ./src/lib/modules/CMakeLists.txt 2013-11-16 12:02:09.000000000 +0000
+@@ -5,4 +5,4 @@
+
+ install(FILES ${MODULES_AVAILABLE} DESTINATION share/faup/modules_available)
+
+-install(CODE "file(MAKE_DIRECTORY ${CMAKE_INSTALL_PREFIX}/share/faup/modules_enabled)")
++install(DIRECTORY DESTINATION share/faup/modules_enabled)