aboutsummaryrefslogtreecommitdiff
path: root/www/fcgi/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-10 01:54:57 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-10 01:54:57 +0000
commit4416197424a4d80acbb0ca99da736449d295831d (patch)
treef8c06419125c8d4e69cadc24f14334710c032762 /www/fcgi/Makefile
parent428a33cce5feebb288bcad53a1eedd70d84c7f75 (diff)
Notes
Diffstat (limited to 'www/fcgi/Makefile')
-rw-r--r--www/fcgi/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/www/fcgi/Makefile b/www/fcgi/Makefile
index 92b8b2278479..5b8c6abfb73d 100644
--- a/www/fcgi/Makefile
+++ b/www/fcgi/Makefile
@@ -8,18 +8,28 @@
PORTNAME= fcgi-devkit
PORTVERSION= 2.1
CATEGORIES= www
-MASTER_SITES= http://fastcgi.idle.com/dist/
+MASTER_SITES= http://www.fastcgi.com/dist/
MAINTAINER= kbyanc@posi.net
MAN1= cgi-fcgi.1
-MAN3= FCGI_Accept.3 FCGI_Finish.3 FCGI_SetExitStatus.3 FCGI_StartFilterData.3
+MAN3= FCGI_Accept.3 FCGI_Finish.3 FCGI_SetExitStatus.3 \
+ FCGI_StartFilterData.3
USE_PERL5= yes
GNU_CONFIGURE= yes
+.if !defined(NOPORTDOCS)
post-install:
- @${RM} -f ${PREFIX}/fcgi-devkit/libfcgi/os_unix.c.orig \
- ${PREFIX}/fcgi-devkit/Makefile.in.orig
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+.for i in fastcgi-prog-guide fastcgi-whitepaper
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}/$i
+ cd ${WRKSRC}/doc/$i && \
+ ${INSTALL_DATA} * ${PREFIX}/share/doc/${PORTNAME}/$i
+ @if [ -f ${PREFIX}/share/doc/${PORTNAME}/$i/Makefile ]; then \
+ ${RM} ${PREFIX}/share/doc/${PORTNAME}/$i/Makefile; \
+ fi
+.endfor
+.endif
.include <bsd.port.mk>