aboutsummaryrefslogtreecommitdiff
path: root/www/fcgi
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-12-26 17:10:09 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2016-12-26 17:10:09 +0000
commit2d97b6fb47eeef27e067ad67c15860d6710d1486 (patch)
tree8d82141dcd954a8545a04de3ef831d2e4db2a1b6 /www/fcgi
parentb2a57b112ee490e9a26dfbedcd1081ed13f6c1a0 (diff)
downloadports-2d97b6fb47eeef27e067ad67c15860d6710d1486.tar.gz
ports-2d97b6fb47eeef27e067ad67c15860d6710d1486.zip
Clean up and modernize fcgi and fcgiwrap. Unbreak fcgiwrap, for
which distfiles are readily available, and host the fcgi distfile locally.
Notes
Notes: svn path=/head/; revision=429554
Diffstat (limited to 'www/fcgi')
-rw-r--r--www/fcgi/Makefile18
-rw-r--r--www/fcgi/files/patch-CVE-2012-6687-pool8
-rw-r--r--www/fcgi/files/patch-examples__Makefile.in6
-rw-r--r--www/fcgi/files/patch-include__fcgio.h4
4 files changed, 16 insertions, 20 deletions
diff --git a/www/fcgi/Makefile b/www/fcgi/Makefile
index f885eeecc01b..a92fa21401eb 100644
--- a/www/fcgi/Makefile
+++ b/www/fcgi/Makefile
@@ -5,7 +5,7 @@ PORTNAME= fcgi
PORTVERSION= 2.4.0
PORTREVISION= 5
CATEGORIES= www
-MASTER_SITES= http://www.fastcgi.com/dist/
+MASTER_SITES= LOCAL/adamw
PKGNAMESUFFIX= -devkit
MAINTAINER= adamw@FreeBSD.org
@@ -17,24 +17,22 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.TERMS
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
USES= cpe libtool
+CPE_VENDOR= fastcgi
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
-CPE_VENDOR= fastcgi
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libfcgi.so.0.0.0
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libfcgi++.so.0.0.0
- ${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${STAGEDIR}${MANPREFIX}/man/man1/
- ${INSTALL_MAN} ${WRKSRC}/doc/*.3 ${STAGEDIR}${MANPREFIX}/man/man3/
-.if ${PORT_OPTIONS:MDOCS}
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
- @${RM} ${STAGEDIR}${DOCSDIR}/*.[13]
-.endif
+ ${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/*.3 ${STAGEDIR}${MANPREFIX}/man/man3
+ (cd ${WRKSRC}/doc && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name *\.[13]")
.include <bsd.port.mk>
diff --git a/www/fcgi/files/patch-CVE-2012-6687-pool b/www/fcgi/files/patch-CVE-2012-6687-pool
index 4e0450661b49..381cb7f024ba 100644
--- a/www/fcgi/files/patch-CVE-2012-6687-pool
+++ b/www/fcgi/files/patch-CVE-2012-6687-pool
@@ -1,8 +1,6 @@
-diff --git a/libfcgi/os_unix.c b/libfcgi/os_unix.c
-index 73e6a7f..af35aee 100755
---- libfcgi/os_unix.c
+--- libfcgi/os_unix.c.orig 2002-03-05 19:14:49 UTC
+++ libfcgi/os_unix.c
-@@ -42,6 +42,7 @@ static const char rcsid[] = "$Id: os_unix.c,v 1.37 2002/03/05 19:14:49 robs Exp
+@@ -42,6 +42,7 @@ static const char rcsid[] = "$Id: os_uni
#include <sys/time.h>
#include <sys/un.h>
#include <signal.h>
@@ -61,7 +59,7 @@ index 73e6a7f..af35aee 100755
}
while (rv > 0 && read(fd, trash, sizeof(trash)) > 0);
}
-@@ -1116,13 +1127,11 @@ static int is_reasonable_accept_errno (const int error)
+@@ -1116,13 +1127,11 @@ static int is_reasonable_accept_errno (c
*/
static int is_af_unix_keeper(const int fd)
{
diff --git a/www/fcgi/files/patch-examples__Makefile.in b/www/fcgi/files/patch-examples__Makefile.in
index d297ead60fb5..cbf55472784b 100644
--- a/www/fcgi/files/patch-examples__Makefile.in
+++ b/www/fcgi/files/patch-examples__Makefile.in
@@ -1,6 +1,6 @@
---- ./examples/Makefile.in.orig 2003-01-19 18:21:17.000000000 +0100
-+++ ./examples/Makefile.in 2014-07-08 00:25:16.000000000 +0200
-@@ -125,7 +125,7 @@
+--- examples/Makefile.in.orig 2003-01-19 17:21:17 UTC
++++ examples/Makefile.in
+@@ -125,7 +125,7 @@ threaded_CFLAGS = @PTHREAD_CFLAGS@
threaded_LDFLAGS = @PTHREAD_CFLAGS@ @PTHREAD_LIBS@
echo_cpp_SOURCES = $(INCLUDE_FILES) $(INCLUDEDIR)/fcgio.h echo-cpp.cpp
diff --git a/www/fcgi/files/patch-include__fcgio.h b/www/fcgi/files/patch-include__fcgio.h
index 137b07bfc2e6..c4588a940e85 100644
--- a/www/fcgi/files/patch-include__fcgio.h
+++ b/www/fcgi/files/patch-include__fcgio.h
@@ -1,5 +1,5 @@
---- ./include/fcgio.h.orig 2011-01-21 12:26:36.000000000 +0000
-+++ ./include/fcgio.h 2011-01-21 12:27:29.000000000 +0000
+--- include/fcgio.h.orig 2002-02-25 13:16:11 UTC
++++ include/fcgio.h
@@ -31,6 +31,7 @@
#define FCGIO_H