aboutsummaryrefslogtreecommitdiff
path: root/www/fgallery
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-07-20 11:54:28 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-07-20 11:54:28 +0000
commita4e7305432c24a0bb12f700de38814c5b98c06d1 (patch)
treed2dde395b7f956239a57382d7474ad1629c6386d /www/fgallery
parent1ba616cf80841b3d8cc7ad334e256bbd23e9fc36 (diff)
Add fgallery 1.8.2, modern, static javascript photo gallery generator.
Notes
Notes: svn path=/head/; revision=446259
Diffstat (limited to 'www/fgallery')
-rw-r--r--www/fgallery/Makefile50
-rw-r--r--www/fgallery/distinfo3
-rw-r--r--www/fgallery/pkg-descr18
-rw-r--r--www/fgallery/pkg-plist27
4 files changed, 98 insertions, 0 deletions
diff --git a/www/fgallery/Makefile b/www/fgallery/Makefile
new file mode 100644
index 000000000000..8853c9d301ca
--- /dev/null
+++ b/www/fgallery/Makefile
@@ -0,0 +1,50 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fgallery
+PORTVERSION= 1.8.2
+CATEGORIES= www graphics
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Modern, static javascript photo gallery generator
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+
+RUN_DEPENDS= exiftool:graphics/p5-Image-ExifTool \
+ exiftran:graphics/exiftran \
+ p5-Cpanel-JSON-XS>=0:converters/p5-Cpanel-JSON-XS \
+ convert:graphics/ImageMagick
+LIB_DEPENDS= liblcms2.so:graphics/lcms2
+
+USE_GITHUB= yes
+NO_BUILD= yes
+NO_ARCH= yes
+
+GH_ACCOUNT= wavexx
+GH_TAGNAME= 45a8629
+
+OPTIONS_DEFINE= 7ZIP FACEDETECT JPEGOPTIM PNGCRUSH
+OPTIONS_DEFAULT=7ZIP FACEDETECT JPEGOPTIM PNGCRUSH
+
+7ZIP_DESC= Use 7-Zip for better zip compression
+FACEDETECT_DESC=Face detection for improved thumbnail centering
+JPEGOPTIM_DESC= Use jpegoptim for JPEG size optimization
+PNGCRUSH_DESC= Use pngcrush for PNG size optimization
+
+7ZIP_RUN_DEPENDS= 7z:archivers/p7zip
+7ZIP_RUN_DEPENDS_OFF= zip:archivers/zip
+FACEDETECT_RUN_DEPENDS= facedetect:graphics/facedetect
+JPEGOPTIM_RUN_DEPENDS= jpegoptim:graphics/jpegoptim
+PNGCRUSH_RUN_DEPENDS= pngcrush:graphics/pngcrush
+
+do-install:
+.for d in album view
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${DATADIR}
+ ${LN} -s ${DATADIR}/${PORTNAME} ${STAGEDIR}/${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/www/fgallery/distinfo b/www/fgallery/distinfo
new file mode 100644
index 000000000000..fc7a4dfb8ae5
--- /dev/null
+++ b/www/fgallery/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1500536838
+SHA256 (wavexx-fgallery-1.8.2-45a8629_GH0.tar.gz) = 657da1c0350489254bcf7fdb27af112722cce85fc1b2fdae4ab5cdf75fd802c9
+SIZE (wavexx-fgallery-1.8.2-45a8629_GH0.tar.gz) = 140796
diff --git a/www/fgallery/pkg-descr b/www/fgallery/pkg-descr
new file mode 100644
index 000000000000..1ee0f42bb3a7
--- /dev/null
+++ b/www/fgallery/pkg-descr
@@ -0,0 +1,18 @@
+fgallery is a static photo gallery generator with no frills that has a stylish,
+minimalist look. fgallery shows your photos, and nothing else.
+
+There is no server-side processing, only static generation. The resulting
+gallery can be uploaded anywhere without additional requirements and works with
+any modern browser.
+
+Key features:
+
+ * Automatically orients pictures without quality loss
+ * Adapts to the current screen size and proportions, switching from
+ horizontal/vertical layout and scaling thumbnails automatically
+ * Supports face detection for improved thumbnail centering
+ * Loads fast
+ * Includes original (raw) pictures in a zip file for downloading
+ * Panoramas can be seen full-size by default
+
+WWW: http://www.thregr.org/~wavexx/software/fgallery/
diff --git a/www/fgallery/pkg-plist b/www/fgallery/pkg-plist
new file mode 100644
index 000000000000..a42a31b7a274
--- /dev/null
+++ b/www/fgallery/pkg-plist
@@ -0,0 +1,27 @@
+bin/fgallery
+man/man1/fgallery.1.gz
+%%DATADIR%%/album/index.css
+%%DATADIR%%/album/index.html
+%%DATADIR%%/album/index.js
+%%DATADIR%%/fgallery
+%%DATADIR%%/view/back.png
+%%DATADIR%%/view/cap-always.png
+%%DATADIR%%/view/cap-never.png
+%%DATADIR%%/view/cap-normal.png
+%%DATADIR%%/view/cut-left.png
+%%DATADIR%%/view/cut-mov.png
+%%DATADIR%%/view/cut-right.png
+%%DATADIR%%/view/cut-top.png
+%%DATADIR%%/view/download.png
+%%DATADIR%%/view/eye.png
+%%DATADIR%%/view/index.css
+%%DATADIR%%/view/index.html
+%%DATADIR%%/view/index.js
+%%DATADIR%%/view/left.png
+%%DATADIR%%/view/mootools-core-1.4.js
+%%DATADIR%%/view/mootools-idle.js
+%%DATADIR%%/view/mootools-mooswipe.js
+%%DATADIR%%/view/mootools-more-1.4.js
+%%DATADIR%%/view/noise.png
+%%DATADIR%%/view/right.png
+%%DATADIR%%/view/throbber.gif