aboutsummaryrefslogtreecommitdiff
path: root/www/fhttpd
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-07-14 01:55:13 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-07-14 01:55:13 +0000
commit3ffee985dbb2eb56ea09159636c447be92d4af48 (patch)
tree0f2f560826fe143f106812be89ddcd2b14af08be /www/fhttpd
parent5dc81de480ba7216e42732cca80e4b95ecc1d005 (diff)
downloadports-3ffee985dbb2eb56ea09159636c447be92d4af48.tar.gz
ports-3ffee985dbb2eb56ea09159636c447be92d4af48.zip
Notes
Diffstat (limited to 'www/fhttpd')
-rw-r--r--www/fhttpd/Makefile2
-rw-r--r--www/fhttpd/files/fhttpd.sh20
2 files changed, 19 insertions, 3 deletions
diff --git a/www/fhttpd/Makefile b/www/fhttpd/Makefile
index 49579c606b45..29ab31076223 100644
--- a/www/fhttpd/Makefile
+++ b/www/fhttpd/Makefile
@@ -23,13 +23,11 @@ pre-patch:
pre-install:
${RM} -rf ${WRKSRC}/http-root/pub/dummy_directory
- ${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/fhttpd.sh
${PERL} -pi -e "s:%%LOGFILE%%:${PREFIX}/${LOGFILE}:g" ${WRKSRC}/fhttpd.sh
${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/http-root/root-fhttpd.conf
${PERL} -pi -e "s:%%LOGFILE%%:${PREFIX}/${LOGFILE}:g" ${WRKSRC}/http-root/root-fhttpd.conf
do-install:
- ${MKDIR} ${PREFIX}/etc/rc.d
${INSTALL_SCRIPT} ${WRKSRC}/fhttpd.sh ${PREFIX}/etc/rc.d
.for PROG in fhttpd fhttpd-file fhttpd-log
${INSTALL_PROGRAM} ${WRKSRC}/${PROG} ${PREFIX}/sbin
diff --git a/www/fhttpd/files/fhttpd.sh b/www/fhttpd/files/fhttpd.sh
index 51bbd8b71eeb..916f6e763f84 100644
--- a/www/fhttpd/files/fhttpd.sh
+++ b/www/fhttpd/files/fhttpd.sh
@@ -1,2 +1,20 @@
#!/bin/sh
-[ -x /usr/local/sbin/fhttpd ] && /usr/local/sbin/fhttpd -c /usr/local/etc/fhttpd.conf -l /usr/local/share/fhttpd/fhttpd.log >/dev/null 2>&1 && echo -n " fhttpd"
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ [ -x ${PREFIX}/sbin/fhttpd ] && ${PREFIX}/sbin/fhttpd -c ${PREFIX}/etc/fhttpd.conf -l ${PREFIX}/share/fhttpd/fhttpd.log > /dev/null 2>&1 && echo -n ' fhttpd'
+ ;;
+stop)
+ killall fhttpd && echo -n ' fhttpd'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0