aboutsummaryrefslogtreecommitdiff
path: root/www/fira-webfont
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-20 20:23:56 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-20 20:23:56 +0000
commitdf7f31d156379804bd7a0663215e9c6642d3a9aa (patch)
tree1dc8d0c42ecbaea9b74c4b5822550d5576c5b996 /www/fira-webfont
parentc8e1c36fe7d1905c22808c2e703f189404492df2 (diff)
downloadports-df7f31d156379804bd7a0663215e9c6642d3a9aa.tar.gz
ports-df7f31d156379804bd7a0663215e9c6642d3a9aa.zip
Notes
Diffstat (limited to 'www/fira-webfont')
-rw-r--r--www/fira-webfont/Makefile47
-rw-r--r--www/fira-webfont/distinfo2
-rw-r--r--www/fira-webfont/files/pkg-message.in9
-rw-r--r--www/fira-webfont/pkg-descr9
-rw-r--r--www/fira-webfont/pkg-plist53
5 files changed, 120 insertions, 0 deletions
diff --git a/www/fira-webfont/Makefile b/www/fira-webfont/Makefile
new file mode 100644
index 000000000000..47a103e17d28
--- /dev/null
+++ b/www/fira-webfont/Makefile
@@ -0,0 +1,47 @@
+# Created by: Horia Racoviceanu <horia@racoviceanu.com>
+# $FreeBSD$
+
+PORTNAME= fira
+PORTVERSION= 1.0
+CATEGORIES= www
+PKGNAMESUFFIX= -webfont
+
+MAINTAINER= horia@racoviceanu.com
+COMMENT= Sans-serif and monospaced Web Font for small screens
+
+LICENSE= OFL
+LICENSE_NAME= SIL OPEN FONT LICENSE Version 1.1
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+USE_GITHUB= yes
+GH_ACCOUNT= mozilla
+GH_PROJECT= Fira
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 705ffff
+
+NO_BUILD= yes
+
+PORTDOCS= README.md
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+
+OPTIONS_DEFINE= DOCS
+
+SUB_FILES= pkg-message
+PLIST_SUB= WWWDIR_REL=${WWWDIR_REL}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${STAGEDIR}${WWWDIR}
+ ${INSTALL_DATA} ${WRKSRC}/fira.css ${STAGEDIR}${WWWDIR}
+ @${MKDIR} ${STAGEDIR}${WWWDIR}/eot
+ ${INSTALL_DATA} ${WRKSRC}/eot/${GH_PROJECT}*.eot ${STAGEDIR}${WWWDIR}/eot/
+ @${MKDIR} ${STAGEDIR}${WWWDIR}/ttf
+ ${INSTALL_DATA} ${WRKSRC}/ttf/${GH_PROJECT}*.ttf ${STAGEDIR}${WWWDIR}/ttf/
+ @${MKDIR} ${STAGEDIR}${WWWDIR}/woff
+ ${INSTALL_DATA} ${WRKSRC}/woff/${GH_PROJECT}*.woff ${STAGEDIR}${WWWDIR}/woff/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/www/fira-webfont/distinfo b/www/fira-webfont/distinfo
new file mode 100644
index 000000000000..0a0c7df79646
--- /dev/null
+++ b/www/fira-webfont/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fira-1.0.tar.gz) = f87bd7d1380e5a93a3743edd3d038b44c7460ea14c204b152b750f5551fd2531
+SIZE (fira-1.0.tar.gz) = 3973356
diff --git a/www/fira-webfont/files/pkg-message.in b/www/fira-webfont/files/pkg-message.in
new file mode 100644
index 000000000000..d489edfaa50f
--- /dev/null
+++ b/www/fira-webfont/files/pkg-message.in
@@ -0,0 +1,9 @@
+===============================================================================
+
+Fira has been installed.
+
+Example HTML and CSS have been installed in %%WWWDIR%%
+
+For X11 Open Type and True Type font please use x11-fonts/fira port.
+
+===============================================================================
diff --git a/www/fira-webfont/pkg-descr b/www/fira-webfont/pkg-descr
new file mode 100644
index 000000000000..22503adaaace
--- /dev/null
+++ b/www/fira-webfont/pkg-descr
@@ -0,0 +1,9 @@
+The Fira font family was designed to cover the legibility needs for a
+large range of handsets varying in screen quality and rendering. It
+comes in a Sans Serif with 4 weights (light, regular, medium and bold)
+all accompanied by italic styles. The package also includes a Mono
+Spaced variant with 2 weights (regular and bold).
+
+Web Font: EOT, WOFF, TTF, and example HTML+CSS
+
+WWW: http://mozilla.github.io/Fira/
diff --git a/www/fira-webfont/pkg-plist b/www/fira-webfont/pkg-plist
new file mode 100644
index 000000000000..15ba52b115dd
--- /dev/null
+++ b/www/fira-webfont/pkg-plist
@@ -0,0 +1,53 @@
+%%WWWDIR_REL%%/eot/FiraMono-Bold.eot
+%%WWWDIR_REL%%/eot/FiraMono-Regular.eot
+%%WWWDIR_REL%%/eot/FiraSans-Bold.eot
+%%WWWDIR_REL%%/eot/FiraSans-BoldItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Light.eot
+%%WWWDIR_REL%%/eot/FiraSans-LightItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Medium.eot
+%%WWWDIR_REL%%/eot/FiraSans-MediumItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Regular.eot
+%%WWWDIR_REL%%/eot/FiraSans-RegularItalic.eot
+%%WWWDIR_REL%%/eot/FiraSansSC-Bold.eot
+%%WWWDIR_REL%%/eot/FiraSansSC-BoldItalic.eot
+%%WWWDIR_REL%%/eot/FiraSansSC-Light.eot
+%%WWWDIR_REL%%/eot/FiraSansSC-LightItalic.eot
+%%WWWDIR_REL%%/eot/FiraSansSC-Medium.eot
+%%WWWDIR_REL%%/eot/FiraSansSC-MediumItalic.eot
+%%WWWDIR_REL%%/eot/FiraSansSC-Regular.eot
+%%WWWDIR_REL%%/eot/FiraSansSC-RegularItalic.eot
+%%WWWDIR_REL%%/fira.css
+%%WWWDIR_REL%%/index.html
+%%WWWDIR_REL%%/ttf/FiraMono-Bold.ttf
+%%WWWDIR_REL%%/ttf/FiraMono-Regular.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Bold.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-BoldItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Light.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-LightItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Medium.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-MediumItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Regular.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-RegularItalic.ttf
+%%WWWDIR_REL%%/woff/FiraMono-Bold.woff
+%%WWWDIR_REL%%/woff/FiraMono-Regular.woff
+%%WWWDIR_REL%%/woff/FiraSans-Bold.woff
+%%WWWDIR_REL%%/woff/FiraSans-BoldItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Light.woff
+%%WWWDIR_REL%%/woff/FiraSans-LightItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Medium.woff
+%%WWWDIR_REL%%/woff/FiraSans-MediumItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Regular.woff
+%%WWWDIR_REL%%/woff/FiraSans-RegularItalic.woff
+%%WWWDIR_REL%%/woff/FiraSansOT-Light.woff
+%%WWWDIR_REL%%/woff/FiraSansSC-Bold.woff
+%%WWWDIR_REL%%/woff/FiraSansSC-BoldItalic.woff
+%%WWWDIR_REL%%/woff/FiraSansSC-Light.woff
+%%WWWDIR_REL%%/woff/FiraSansSC-LightItalic.woff
+%%WWWDIR_REL%%/woff/FiraSansSC-Medium.woff
+%%WWWDIR_REL%%/woff/FiraSansSC-MediumItalic.woff
+%%WWWDIR_REL%%/woff/FiraSansSC-Regular.woff
+%%WWWDIR_REL%%/woff/FiraSansSC-RegularItalic.woff
+@dirrm %%WWWDIR_REL%%/woff
+@dirrm %%WWWDIR_REL%%/ttf
+@dirrm %%WWWDIR_REL%%/eot
+@dirrm %%WWWDIR_REL%%