aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-devel/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-19 00:51:17 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-19 00:51:17 +0000
commit02e06ac28ccae59c574a63abc05aa014b605df57 (patch)
tree97a524ab4205c9243184ddbfe7844099725e570b /www/firefox-devel/Makefile
parent6a908ec2811f0f4b6494a25251eb7e8561f1eccb (diff)
downloadports-02e06ac28ccae59c574a63abc05aa014b605df57.tar.gz
ports-02e06ac28ccae59c574a63abc05aa014b605df57.zip
Notes
Diffstat (limited to 'www/firefox-devel/Makefile')
-rw-r--r--www/firefox-devel/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/www/firefox-devel/Makefile b/www/firefox-devel/Makefile
index ec944c9ba17b..6c77fb3bc839 100644
--- a/www/firefox-devel/Makefile
+++ b/www/firefox-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
@@ -57,10 +57,6 @@ OPTIONS= DEBUG "Build a debugging image" off \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
-CONFIGURE_ENV+= WITH_REORDER=yes
-.endif # ${ARCH} == "i386"
-
.if defined(WITH_DEBUG)
WITH_LOGGING= yes
CONFIGURE_ENV+= WITH_DEBUG=yes
@@ -68,6 +64,9 @@ CONFIGURE_ENV+= WITH_DEBUG=yes
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O2
+CONFIGURE_ENV+= WITH_OPTIMIZE=-O2
+.else
+CONFIGURE_ENV+= WITH_OPTIMIZE=-O
.endif # defined(WITH_OPTIMIZED_CFLAGS)
.if defined(WITH_LOGGING)
@@ -137,10 +136,11 @@ pre-configure:
fi
post-build:
- # XXX This works around an install problem that is triggered when
- # toolkit/profile/src is built after profile/src.
- @(cd ${WRKSRC}/dist/lib && ${LN} -sf ../../profile/src/libprofile_s.a \
- .)
+# XXX This works around an install problem that is triggered when
+# toolkit/profile/src is built after profile/src.
+# @(cd ${WRKSRC}/dist/lib && ${LN} -sf ../../profile/src/libprofile_s.a \
+# .)
+ @${TOUCH} -f ${WRKSRC}/profile/build/libprofile.so
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the