aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-devel
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2002-10-22 09:26:56 +0000
committerAlan Eldridge <alane@FreeBSD.org>2002-10-22 09:26:56 +0000
commitc59321e54f847fddceca6224539ae407624cc1ab (patch)
tree80f2779969bdf75d041be0312aa58ad8826448b7 /www/firefox-devel
parentdfbb4be26a618bed30c144966dde4531284d5cf0 (diff)
downloadports-c59321e54f847fddceca6224539ae407624cc1ab.tar.gz
ports-c59321e54f847fddceca6224539ae407624cc1ab.zip
Notes
Diffstat (limited to 'www/firefox-devel')
-rw-r--r--www/firefox-devel/Makefile22
-rw-r--r--www/firefox-devel/files/mozconfig.in27
-rw-r--r--www/firefox-devel/pkg-descr1
-rw-r--r--www/firefox-devel/pkg-plist2
4 files changed, 42 insertions, 10 deletions
diff --git a/www/firefox-devel/Makefile b/www/firefox-devel/Makefile
index 8de59bf092bc..a197d83f1ecb 100644
--- a/www/firefox-devel/Makefile
+++ b/www/firefox-devel/Makefile
@@ -9,22 +9,24 @@
PORTNAME= phoenix
PORTVERSION= 0.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= trevor
-MAINTAINER= alane@freebsd.org # will change to trevor@ soon
-
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- freetype-config:${PORTSDIR}/print/freetype2 \
- perl5.8.0:${PORTSDIR}/lang/perl5.8
+MAINTAINER= alane@freebsd.org # and trevor@freebsd.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
freetype.9:${PORTSDIR}/print/freetype2
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ freetype-config:${PORTSDIR}/print/freetype2 \
+ perl5.8.0:${PORTSDIR}/lang/perl5.8
+
+PREFIX= ${X11BASE}/lib/${PORTNAME}
+
USE_BZIP2= yes
USE_GMAKE= yes
#USE_AUTOCONF_VER= 213
@@ -34,11 +36,19 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != 5.8.0
+.error This port requires Perl 5.8.0.
+.endif
+
post-extract:
${SED} -e 's|@X11BASE@|${X11BASE}|' \
-e 's|@LOCALBASE@|${LOCALBASE}|' \
<${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
+post-install:
+ ${LN} -s ${PREFIX}/bin/phoenix ${X11BASE}/bin/phoenix
+ ${LN} -s ${PREFIX}/bin/mozilla-config ${X11BASE}/bin/phoenix-config
+
.include <bsd.port.post.mk>
#EOF
diff --git a/www/firefox-devel/files/mozconfig.in b/www/firefox-devel/files/mozconfig.in
index 9a02a88d6c7b..f923e6f239b5 100644
--- a/www/firefox-devel/files/mozconfig.in
+++ b/www/firefox-devel/files/mozconfig.in
@@ -1,5 +1,7 @@
# .mozconfig.in -*-shell-script-*-
# $FreeBSD$
+######################################################################
+# standard opts from README
export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1
ac_add_options --enable-crypto
@@ -8,16 +10,35 @@ ac_add_options --disable-debug
ac_add_options --disable-mailnews
ac_add_options --disable-composer
ac_add_options --enable-optimize=-O2
+######################################################################
# FBSD specific
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
mk_add_options GLIB_CONFIG=$GLIB_CONFIG
-# Use ports for these
+######################################################################
+# Use ports for these libraries
ac_add_options --with-system-jpeg=@LOCALBASE@
ac_add_options --with-system-zlib
ac_add_options --with-system-png=@LOCALBASE@
ac_add_options --with-system-mng=@LOCALBASE@
-# other options
-ac_add_options --disable-ldap
+######################################################################
+# enable features
ac_add_options --with-pthreads
+ac_add_options --enable-crypto
+ac_add_options --enable-xinerama
+ac_add_options --enable-reorder
+ac_add_options --enable-strip
+#ac_add_options --enable-crash-on-assert
+######################################################################
+# disable unneeded to speed up build/runtime
+ac_add_options --disable-tests
+ac_add_options --disable-ldap
+ac_add_options --disable-logging
+ac_add_options --disable-dtd-debug
+ac_add_options --disable-auto-deps
+ac_add_options --disable-pedantic
+######################################################################
+
diff --git a/www/firefox-devel/pkg-descr b/www/firefox-devel/pkg-descr
index c7e28926f3d8..af8041043b21 100644
--- a/www/firefox-devel/pkg-descr
+++ b/www/firefox-devel/pkg-descr
@@ -4,4 +4,3 @@ phoenix project page for more details.
WWW: http://www.mozilla.org/projects/phoenix/
-- AlanE <alane@freebsd.org>
-
diff --git a/www/firefox-devel/pkg-plist b/www/firefox-devel/pkg-plist
index 682a2e35c1cd..7ae21fd8d8de 100644
--- a/www/firefox-devel/pkg-plist
+++ b/www/firefox-devel/pkg-plist
@@ -3401,3 +3401,5 @@ share/idl/mozilla-1.2b/xpcjsid.idl
@dirrm include/mozilla-1.2b/appcomps
@dirrm include/mozilla-1.2b/accessibility
@dirrm include/mozilla-1.2b
+@unexec /bin/rm %%X11BASE%%/bin/phoenix || true
+@unexec /bin/rm %%X11BASE%%/bin/phoenix-config || true