aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-devel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-17 21:29:31 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-17 21:29:31 +0000
commite3a98cbb2d2c1737f7c49110dd7736b2ad516e0b (patch)
tree727ff47faed55c47cb667bdc46346f421d34e738 /www/firefox-devel
parentca8f1390f3b9faa879f9fefda0c2c8240a3eb992 (diff)
downloadports-e3a98cbb2d2c1737f7c49110dd7736b2ad516e0b.tar.gz
ports-e3a98cbb2d2c1737f7c49110dd7736b2ad516e0b.zip
Notes
Diffstat (limited to 'www/firefox-devel')
-rw-r--r--www/firefox-devel/Makefile15
-rw-r--r--www/firefox-devel/files/patch-browser_app_Makefile.in10
-rw-r--r--www/firefox-devel/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp12
-rw-r--r--www/firefox-devel/files/patch-toolkit_xre_nsAppRunner.cpp10
-rw-r--r--www/firefox-devel/pkg-install.in5
5 files changed, 13 insertions, 39 deletions
diff --git a/www/firefox-devel/Makefile b/www/firefox-devel/Makefile
index 1ae047590258..a62cffed60b1 100644
--- a/www/firefox-devel/Makefile
+++ b/www/firefox-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 1.0.1.p
-PORTREVISION= 2
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${REALVERSION}
@@ -18,10 +18,9 @@ COMMENT= Web browser based on the browser portion of Mozilla
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
- mng.1:${PORTSDIR}/graphics/libmng \
- freetype.9:${PORTSDIR}/print/freetype2
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- freetype-config:${PORTSDIR}/print/freetype2
+ mng.1:${PORTSDIR}/graphics/libmng
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+RUN_DEPENDS= Xvfb:${X_VFBSERVER_PORT}
ALL_TARGET= default
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
@@ -139,7 +138,8 @@ post-patch:
.for ii in modules/libpref/src/init extensions/sroaming/resources/content/prefs \
embedding/minimo
${MV} ${WRKSRC}/${ii}/all.js ${WRKSRC}/${ii}/all.js.bak
- ${SED} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
+ ${SED} -e '/accessibility.typeaheadfind.enablesound/s/true/false/ ; \
+ /dom.disable_window_open_feature.toolbar/s/false/true/' \
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
.for ii in ${PKGCONFIG_FILES}
@@ -171,7 +171,8 @@ pre-install:
@${RM} -rf ${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${REALVERSION}/chrome/en-${ii}${jj}
.endfor
.endfor
- @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${REALVERSION}|g' \
+ @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${REALVERSION}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
@${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${REALVERSION}|g' \
< ${MASTERDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
diff --git a/www/firefox-devel/files/patch-browser_app_Makefile.in b/www/firefox-devel/files/patch-browser_app_Makefile.in
deleted file mode 100644
index 0fee861b9f72..000000000000
--- a/www/firefox-devel/files/patch-browser_app_Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- browser/app/Makefile.in.orig Sat Jun 19 00:39:09 2004
-+++ browser/app/Makefile.in Sat Jun 19 00:39:55 2004
-@@ -75,6 +75,7 @@
- $(STATIC_COMPONENTS_LINKER_PATH) \
- $(EXTRA_DSO_LIBS) \
- $(DIST)/lib/$(LIB_PREFIX)xulapp_s.$(LIB_SUFFIX) \
-+ -lgthread-2.0 \
- $(MOZ_JS_LIBS) \
- $(XPCOM_LIBS) \
- $(NSPR_LIBS) \
diff --git a/www/firefox-devel/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp b/www/firefox-devel/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
deleted file mode 100644
index bc141062f7c6..000000000000
--- a/www/firefox-devel/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- gfx/src/gtk/nsFontMetricsXft.cpp.orig Wed Mar 17 02:08:01 2004
-+++ gfx/src/gtk/nsFontMetricsXft.cpp Wed Mar 17 02:08:15 2004
-@@ -65,7 +65,8 @@
-
- #include <gdk/gdkx.h>
- #include <freetype/tttables.h>
--#include <freetype/freetype.h>
-+#include <ft2build.h>
-+#include FT_FREETYPE_H
-
- #define FORCE_PR_LOG
- #include "prlog.h"
diff --git a/www/firefox-devel/files/patch-toolkit_xre_nsAppRunner.cpp b/www/firefox-devel/files/patch-toolkit_xre_nsAppRunner.cpp
deleted file mode 100644
index 68f43996813d..000000000000
--- a/www/firefox-devel/files/patch-toolkit_xre_nsAppRunner.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- toolkit/xre/nsAppRunner.cpp.orig Sat Jun 19 00:37:07 2004
-+++ toolkit/xre/nsAppRunner.cpp Sat Jun 19 00:37:39 2004
-@@ -1710,6 +1710,7 @@
- // in nsAppShell::Create, but we need to get in before gtk
- // has been initialized to make sure everything is running
- // consistently.
-+ g_thread_init(NULL);
- if (CheckArg("install"))
- gdk_rgb_set_install(TRUE);
-
diff --git a/www/firefox-devel/pkg-install.in b/www/firefox-devel/pkg-install.in
index 048ff1d62da3..8004a6516143 100644
--- a/www/firefox-devel/pkg-install.in
+++ b/www/firefox-devel/pkg-install.in
@@ -15,6 +15,7 @@ PATH=/bin:/usr/bin
MOZDIR=%%MOZDIR%%
REGXPCOM=${MOZDIR}/regxpcom
REGCHROME=${MOZDIR}/regchrome
+FIREFOX=${MOZDIR}/firefox-bin
echo "===> Building Chrome's registry..."
rm -rf ${MOZDIR}/chrome/overlayinfo
@@ -27,4 +28,8 @@ cd ${MOZDIR} || exit 1
./run-mozilla.sh ${REGXPCOM} || true
./run-mozilla.sh ${REGCHROME} || true
+# Instantiate the extension space as root.
+su - root -c "%%X11BASE%%/bin/xinit %%MOZDIR%%/run-mozilla.sh ${FIREFOX} -install-global-extension -- %%X11BASE%%/bin/Xvfb :1001" > /dev/null 2>&1
+su - root -c "%%X11BASE%%/bin/xinit %%MOZDIR%%/run-mozilla.sh ${FIREFOX} -install-global-theme -- %%X11BASE%%/bin/Xvfb :1001" > /dev/null 2>&1
+
exit 0