aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-16 00:10:12 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-16 00:10:12 +0000
commit2b519d7ce5cc1a9b78fe25efa769223dfea9bcb7 (patch)
treed3475b2b30df2c64058a7bb4e013bcd3cc6579a3 /www/firefox-esr
parent7a1e1287f3231b9f571faf007d296084290f4e0c (diff)
downloadports-2b519d7ce5cc1a9b78fe25efa769223dfea9bcb7.tar.gz
ports-2b519d7ce5cc1a9b78fe25efa769223dfea9bcb7.zip
Notes
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile30
-rw-r--r--www/firefox-esr/distinfo4
-rw-r--r--www/firefox-esr/files/mozconfig.in16
-rw-r--r--www/firefox-esr/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h32
-rw-r--r--www/firefox-esr/files/patch-nsprpub-pr-src-io-prprf.c16
-rw-r--r--www/firefox-esr/files/patch-xpcom-reflect-xptcall-public-xptcstubsdecl.inc12
-rw-r--r--www/firefox-esr/pkg-install.in29
-rw-r--r--www/firefox-esr/pkg-message14
8 files changed, 89 insertions, 64 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 0ffeafcd0e5d..a05f72056f59 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= firefox
-PORTVERSION= 0.8
-PORTREVISION= 5
+PORTVERSION= 0.9
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
-DISTNAME= ${PORTNAME}-source-${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-source
MAINTAINER= gnome@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
@@ -25,8 +24,7 @@ BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
freetype-config:${PORTSDIR}/print/freetype2
ALL_TARGET= default
-CONFIGURE_ENV= WITH_GTK2=yes \
- LOCALBASE=${LOCALBASE}
+CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
FAKEDIR= ${WRKDIR}/fake
FAKESUBDIR= ${FAKEDIR}/lib/${PORTNAME}
HAS_CONFIGURE= yes
@@ -42,6 +40,7 @@ USE_ICONV= yes
USE_PERL5_BUILD=yes
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/mozilla
+PKGINSTALL= ${WRKDIR}/pkg-install
JPI_LIST?=\
${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
@@ -57,6 +56,10 @@ OPTIONS= DEBUG "Build a debugging image" off \
.include <bsd.port.pre.mk>
+.if ${ARCH} == "i386"
+CONFIGURE_ENV+= WITH_REORDER=yes
+.endif # ${ARCH} == "i386"
+
.if defined(WITH_DEBUG)
WITH_LOGGING= yes
CONFIGURE_ENV+= WITH_DEBUG=yes
@@ -117,10 +120,10 @@ post-patch:
${WRKSRC}/security/coreconf/FreeBSD.mk \
${WRKSRC}/directory/c-sdk/config/FreeBSD.mk \
${WRKSRC}/js/src/Makefile.in
- @${PERL} -pi -e 's|libesd\.so\.0|${ESD_LIB}|g' \
+ @${PERL} -pi -e 's|libesd\.so\.\d+|${ESD_LIB}|g' \
${WRKSRC}/widget/src/gtk2/nsSound.cpp
-.for ii in modules/libpref/src/init browser/app/profile \
- calendar/sunbird/app/profile
+.for ii in modules/libpref/src/init extensions/sroaming/resources/content/prefs \
+ embedding/minimo
${MV} ${WRKSRC}/${ii}/all.js ${WRKSRC}/${ii}/all.js.bak
${SED} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
@@ -132,6 +135,12 @@ pre-configure:
${FALSE}; \
fi
+post-build:
+ # XXX This works around an install problem that is triggered when
+ # toolkit/profile/src is built after profile/src.
+ @(cd ${WRKSRC}/dist/lib && ${LN} -sf ../../profile/src/libprofile_s.a \
+ .)
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
@@ -142,9 +151,11 @@ pre-install:
Makefile ${MAKE_ARGS} install
.for ii in mac win
.for jj in / .jar
- @${RM} -rf ${FAKEDIR}/lib/mozilla-1.6/chrome/en-${ii}${jj}
+ @${RM} -rf ${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${PORTVERSION}/chrome/en-${ii}${jj}
.endfor
.endfor
+ @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}|g' \
+ < ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
.if !defined (WITH_HEADERS)
@${RM} -fr ${FAKEDIR}/share/idl ${FAKEDIR}/include
@@ -166,6 +177,7 @@ do-install:
cd ${FAKEDIR} && ${FIND} * | ${CPIO} -dmp --quiet ${PREFIX}
post-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.for i in ${EXTRA_SCRIPTS}
${INSTALL_SCRIPT} ${FILESDIR}/${i} ${PREFIX}/bin
.endfor
diff --git a/www/firefox-esr/distinfo b/www/firefox-esr/distinfo
index 7d6fc14da8cb..a143d7cf5d74 100644
--- a/www/firefox-esr/distinfo
+++ b/www/firefox-esr/distinfo
@@ -1,2 +1,2 @@
-MD5 (firefox-source-0.8.tar.bz2) = cdc85152f4219bf3e3f1a8dc46e04654
-SIZE (firefox-source-0.8.tar.bz2) = 31102943
+MD5 (firefox-0.9-source.tar.bz2) = 1dda543d1245db09cea9ad7b9a44146c
+SIZE (firefox-0.9-source.tar.bz2) = 32359326
diff --git a/www/firefox-esr/files/mozconfig.in b/www/firefox-esr/files/mozconfig.in
index a0d469df586e..df281d3a3ca8 100644
--- a/www/firefox-esr/files/mozconfig.in
+++ b/www/firefox-esr/files/mozconfig.in
@@ -9,6 +9,7 @@ ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-mailnews
ac_add_options --disable-composer
+ac_add_options --enable-default-toolkit=gtk2
######################################################################
# FBSD specific
export CPPFLAGS="@CPPFLAGS@"
@@ -31,7 +32,6 @@ ac_add_options --with-system-mng=@LOCALBASE@
######################################################################
# set compile/link features
ac_add_options --with-pthreads
-ac_add_options --enable-reorder
######################################################################
# disable unneeded/unavailable
ac_add_options --disable-auto-deps
@@ -45,6 +45,11 @@ ac_add_options --disable-installer
ac_add_options --enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices,inspector
######################################################################
# conditional from port Makefile
+if test -n "$WITH_REORDER"; then
+ ac_add_options --enable-reorder
+else
+ ac_add_options --disable-reorder
+fi # test -n "$WITH_REORDER"
if test -n "$WITH_DEBUG"; then
ac_add_options --enable-debug
ac_add_options --disable-strip
@@ -52,6 +57,10 @@ else
ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --enable-strip
+ export BUILD_OFFICIAL=1
+ export MOZILLA_OFFICIAL=1
+ mk_add_options BUILD_OFFICIAL=1
+ mk_add_options MOZILLA_OFFICIAL=1
fi # test -n "$WITH_DEBUG"
if test -n "$WITH_LOGGING"; then
ac_add_options --enable-logging
@@ -63,9 +72,4 @@ if test -z "$WITHOUT_XFT"; then
else
ac_add_options --disable-xft
fi # test -z "$WITHOUT_XFT"
-if test -n "$WITH_GTK2"; then
- ac_add_options --enable-default-toolkit=gtk2
-else
- ac_add_options --enable-default-toolkit=gtk
-fi # test -n "$WITH_GTK2"
######################################################################
diff --git a/www/firefox-esr/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h b/www/firefox-esr/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h
deleted file mode 100644
index e22c93be389e..000000000000
--- a/www/firefox-esr/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h
+++ /dev/null
@@ -1,32 +0,0 @@
-$FreeBSD$
-
---- directory/c-sdk/ldap/libraries/liblber/lber-int.h Tue Mar 26 13:53:23 2002
-+++ directory/c-sdk/ldap/libraries/liblber/lber-int.h Sat Dec 13 13:02:49 2003
-@@ -236,15 +236,15 @@
- (((_l)&0xff0000)>>8) + (((_l)&0xff000000)>>24))
- #define LBER_NTOHL(_l) LBER_HTONL(_l)
-
--#elif !defined(__alpha) || defined(VMS)
-+#elif !defined(__amd64__) && (!defined(__alpha) || defined(VMS))
-
- #define LBER_HTONL( l ) htonl( l )
- #define LBER_NTOHL( l ) ntohl( l )
-
- #else /* __alpha */
- /*
-- * htonl and ntohl on the DEC Alpha under OSF 1 seem to only swap the
-- * lower-order 32-bits of a (64-bit) long, so we define correct versions
-+ * htonl and ntohl on the 64 bit UNIX platforms only swap the lower-order
-+ * 32-bits of a (64-bit) long, so we define correct versions
- * here.
- */
- #define LBER_HTONL( l ) (((long)htonl( (l) & 0x00000000FFFFFFFF )) << 32 \
-@@ -252,7 +252,7 @@
-
- #define LBER_NTOHL( l ) (((long)ntohl( (l) & 0x00000000FFFFFFFF )) << 32 \
- | ntohl( ( (l) & 0xFFFFFFFF00000000 ) >> 32 ))
--#endif /* __alpha */
-+#endif /* __alpha || __amd64__ */
-
-
- /* function prototypes */
diff --git a/www/firefox-esr/files/patch-nsprpub-pr-src-io-prprf.c b/www/firefox-esr/files/patch-nsprpub-pr-src-io-prprf.c
index 29b941b60fac..38bd959aef25 100644
--- a/www/firefox-esr/files/patch-nsprpub-pr-src-io-prprf.c
+++ b/www/firefox-esr/files/patch-nsprpub-pr-src-io-prprf.c
@@ -1,14 +1,14 @@
-$FreeBSD$
-
---- nsprpub/pr/src/io/prprf.c Wed Feb 26 15:53:42 2003
-+++ nsprpub/pr/src/io/prprf.c Thu Oct 16 22:50:40 2003
-@@ -52,5 +52,8 @@
+--- nsprpub/pr/src/io/prprf.c.orig Mon Mar 8 22:18:19 2004
++++ nsprpub/pr/src/io/prprf.c Tue Jun 15 13:17:30 2004
+@@ -51,7 +51,10 @@
+ ** Note: on some platforms va_list is defined as an array,
** and requires array notation.
*/
--#if (defined(LINUX) && defined(__powerpc__)) || \
+-#if (defined(LINUX) && defined(__x86_64__))
+#if defined(__amd64__)
+#include <stdarg.h>
+#define VARARGS_ASSIGN(foo, bar) va_copy((foo), (bar))
-+#elif (defined(LINUX) && defined(__powerpc__)) || \
++#elif (defined(LINUX) && defined(__x86_64__))
+ #define VARARGS_ASSIGN(foo, bar) __va_copy((foo), (bar))
+ #elif (defined(LINUX) && defined(__powerpc__)) || \
(defined(LINUX) && defined(__s390__)) || \
- (defined(LINUX) && defined(__s390x__)) || \
diff --git a/www/firefox-esr/files/patch-xpcom-reflect-xptcall-public-xptcstubsdecl.inc b/www/firefox-esr/files/patch-xpcom-reflect-xptcall-public-xptcstubsdecl.inc
index dea21b7325a0..9a41bbfc4602 100644
--- a/www/firefox-esr/files/patch-xpcom-reflect-xptcall-public-xptcstubsdecl.inc
+++ b/www/firefox-esr/files/patch-xpcom-reflect-xptcall-public-xptcstubsdecl.inc
@@ -1,13 +1,11 @@
-$FreeBSD$
-
---- xpcom/reflect/xptcall/public/xptcstubsdecl.inc.orig Sun Feb 1 15:39:59 2004
-+++ xpcom/reflect/xptcall/public/xptcstubsdecl.inc Sun Feb 1 15:40:11 2004
+--- xpcom/reflect/xptcall/public/xptcstubsdecl.inc.orig Tue Mar 16 03:07:25 2004
++++ xpcom/reflect/xptcall/public/xptcstubsdecl.inc Tue Jun 15 12:52:36 2004
@@ -8,7 +8,7 @@
* 1 is AddRef
* 2 is Release
*/
-#if !defined(__ia64) || (!defined(__hpux) && !defined(__linux__))
+#if !defined(__ia64)
- XPTC_EXPORT NS_IMETHOD Stub3();
- XPTC_EXPORT NS_IMETHOD Stub4();
- XPTC_EXPORT NS_IMETHOD Stub5();
+ NS_IMETHOD Stub3();
+ NS_IMETHOD Stub4();
+ NS_IMETHOD Stub5();
diff --git a/www/firefox-esr/pkg-install.in b/www/firefox-esr/pkg-install.in
new file mode 100644
index 000000000000..e4158aae3df9
--- /dev/null
+++ b/www/firefox-esr/pkg-install.in
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Date created: Mon Nov 29, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+# Fix the chrome registry.
+
+umask 022
+PATH=/bin:/usr/bin
+
+[ "x$1" = "x" ] && exit 1
+[ "x$2" != "xPOST-INSTALL" ] && exit 0
+
+MOZDIR=%%MOZDIR%%
+REGXPCOM=${MOZDIR}/regxpcom
+REGCHROME=${MOZDIR}/regchrome
+
+echo "===> Building Chrome's registry..."
+rm -rf ${MOZDIR}/chrome/overlayinfo
+rm -f ${MOZDIR}/chrome/*.rdf
+mkdir -p ${MOZDIR}/chrome/overlayinfo
+rm -f ${MOZDIR}/component.reg
+
+LD_LIBRARY_PATH=${MOZDIR} MOZILLA_FIVE_HOME=${MOZDIR} ${REGXPCOM} || true
+LD_LIBRARY_PATH=${MOZDIR} MOZILLA_FIVE_HOME=${MOZDIR} ${REGXPCHROME} || true
+touch ${MOZDIR}/chrome/user-skins.rdf ${MOZDIR}/chrome/user-locales.rdf
+
+exit 0
diff --git a/www/firefox-esr/pkg-message b/www/firefox-esr/pkg-message
index ed9bc51041fc..81b95494a6c9 100644
--- a/www/firefox-esr/pkg-message
+++ b/www/firefox-esr/pkg-message
@@ -1,4 +1,18 @@
======================================================================
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!WARNING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!WARNING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!WARNING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+After installing Firefox, you must su - to root, and run ``firefox'' before
+running it as any other user. If you do not su - to root, you may lose some
+of your user settings. If you try to run Firefox as a normal user without
+first running it as root, the browser will not show up. This is a known issue
+with Firefox, and they hope to address it in a future release.
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!WARNING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!WARNING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!WARNING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^SEE WARNING ABOVE^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+
Any bug reports should be addressed to the maintainers at:
gnome@FreeBSD.org
You may also Cc: freebsd-ports@freebsd.org. Please do not send