aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2011-03-01 21:57:17 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2011-03-01 21:57:17 +0000
commit3d376cdc9ba8f407c146845ab533cb05026d9282 (patch)
tree49e70b44d9ef62b2aa799153375c407b2ebca082 /www/firefox-esr
parentb76390cb80665fb12bc6961dea242436371cb5ff (diff)
downloadports-3d376cdc9ba8f407c146845ab533cb05026d9282.tar.gz
ports-3d376cdc9ba8f407c146845ab533cb05026d9282.zip
Notes
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile11
-rw-r--r--www/firefox-esr/distinfo4
-rw-r--r--www/firefox-esr/files/patch-js-ctypes-libffi-configure12
-rw-r--r--www/firefox-esr/files/patch-security_nss_lib_freebl_mpi_mpcpucache.c44
-rw-r--r--www/firefox-esr/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in17
5 files changed, 83 insertions, 5 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index bd328eda4498..017069a4b098 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= firefox
-DISTVERSION= 3.6.13
+DISTVERSION= 3.6.14
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -63,6 +63,15 @@ EXTRA_PATCHES= ${FILESDIR}/releng6_pulseaudio
EXTRA_PATCHES= ${FILESDIR}/libsydney_oss
.endif
+.if ${ARCH} == powerpc64
+.if ${OSVERSION} < 900033
+BROKEN= Needs binutils 2.17.50 to build
+.else
+CONFIGURE_ENV+= UNAME_m="powerpc64"
+CFLAGS+= -mminimal-toc
+.endif
+.endif
+
WRKSRC:= ${WRKSRC}-1.9.2
GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
diff --git a/www/firefox-esr/distinfo b/www/firefox-esr/distinfo
index 182c5d5eaa85..98ee18fb4996 100644
--- a/www/firefox-esr/distinfo
+++ b/www/firefox-esr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-3.6.13.source.tar.bz2) = 4b90775c0f29cb7e170a80894311d8c7a2cd794c50e2124b70d1b83011c45f63
-SIZE (firefox-3.6.13.source.tar.bz2) = 51478675
+SHA256 (firefox-3.6.14.source.tar.bz2) = d2b28db2612d2603df45a1d7bccf0096da588f87cd287be6b7c96879c88ee855
+SIZE (firefox-3.6.14.source.tar.bz2) = 51489105
diff --git a/www/firefox-esr/files/patch-js-ctypes-libffi-configure b/www/firefox-esr/files/patch-js-ctypes-libffi-configure
new file mode 100644
index 000000000000..3f6b66e1d628
--- /dev/null
+++ b/www/firefox-esr/files/patch-js-ctypes-libffi-configure
@@ -0,0 +1,12 @@
+--- js/ctypes/libffi/configure.orig 2010-07-22 23:54:58.000000000 +0200
++++ js/ctypes/libffi/configure 2010-08-05 07:34:44.000000000 +0200
+@@ -21033,6 +21033,9 @@
+ powerpc-*-aix* | rs6000-*-aix*)
+ TARGET=POWERPC_AIX; TARGETDIR=powerpc
+ ;;
++ powerpc64-*-freebsd*)
++ TARGET=POWERPC; TARGETDIR=powerpc
++ ;;
+ powerpc-*-freebsd*)
+ TARGET=POWERPC_FREEBSD; TARGETDIR=powerpc
+ ;;
diff --git a/www/firefox-esr/files/patch-security_nss_lib_freebl_mpi_mpcpucache.c b/www/firefox-esr/files/patch-security_nss_lib_freebl_mpi_mpcpucache.c
new file mode 100644
index 000000000000..b579fc5b4995
--- /dev/null
+++ b/www/firefox-esr/files/patch-security_nss_lib_freebl_mpi_mpcpucache.c
@@ -0,0 +1,44 @@
+--- security/nss/lib/freebl/mpi/mpcpucache.c.orig 2011-02-26 18:44:42.000000000 +0100
++++ security/nss/lib/freebl/mpi/mpcpucache.c 2011-02-26 18:46:41.000000000 +0100
+@@ -733,6 +733,33 @@
+ #endif
+
+ #if defined(__ppc64__)
++#if defined(__FreeBSD__)
++#include <sys/stddef.h>
++#include <sys/sysctl.h>
++
++#include <machine/cpu.h>
++#include <machine/md_var.h>
++
++unsigned long
++s_mpi_getProcessorLineSize()
++{
++ static int cacheline_size = 0;
++ static int cachemib[] = { CTL_MACHDEP, CPU_CACHELINE };
++ int clen;
++
++ if (cacheline_size > 0)
++ return cacheline_size;
++
++ clen = sizeof(cacheline_size);
++ if (sysctl(cachemib, sizeof(cachemib) / sizeof(cachemib[0]),
++ &cacheline_size, &clen, NULL, 0) < 0 || !cacheline_size)
++ return 128; /* guess */
++
++ return cacheline_size;
++}
++#else /* __FreeBSD__ */
++
++
+ /*
+ * Sigh, The PPC has some really nice features to help us determine cache
+ * size, since it had lots of direct control functions to do so. The POWER
+@@ -786,6 +813,7 @@
+ return 0;
+ }
+
++#endif /* __FreeBSD__ */
+ #define MPI_GET_PROCESSOR_LINE_SIZE_DEFINED 1
+ #endif
+
diff --git a/www/firefox-esr/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in b/www/firefox-esr/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
index 244af2e49204..124e86202838 100644
--- a/www/firefox-esr/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
+++ b/www/firefox-esr/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
@@ -1,5 +1,5 @@
---- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig 2009-09-16 04:41:25.000000000 +0200
-+++ xpcom/reflect/xptcall/src/md/unix/Makefile.in 2009-10-03 21:30:21.000000000 +0200
+--- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig 2010-04-02 16:03:13.000000000 +0000
++++ xpcom/reflect/xptcall/src/md/unix/Makefile.in 2010-06-06 19:19:44.000000000 +0000
@@ -73,6 +73,9 @@
DEFINES += -DKEEP_STACK_16_BYTE_ALIGNED
CPPSRCS := xptcinvoke_unixish_x86.cpp xptcstubs_unixish_x86.cpp
@@ -56,6 +56,19 @@
CPPSRCS := xptcinvoke_ppc_linux.cpp xptcstubs_ppc_linux.cpp
ASFILES := xptcinvoke_asm_ppc_linux.s xptcstubs_asm_ppc_linux.s
AS := $(CC) -c -x assembler-with-cpp
+@@ -331,9 +340,9 @@
+ #
+ # Linux/PPC64
+ #
+-ifeq ($(OS_ARCH)$(OS_TEST),Linuxpowerpc64)
+-CPPSRCS := xptcinvoke_ppc64_linux.cpp xptcstubs_ppc64_linux.cpp
+-ASFILES := xptcinvoke_asm_ppc64_linux.s xptcstubs_asm_ppc64_linux.s
++ifneq (,$(filter Linuxpowerpc64 FreeBSDpowerpc64,$(OS_ARCH)$(OS_TEST)))
++CPPSRCS := xptcinvoke_ppc64_linux.cpp xptcstubs_ppc64_linux.cpp
++ASFILES := xptcinvoke_asm_ppc64_linux.s xptcstubs_asm_ppc64_linux.s
+ AS := $(CC) -c -x assembler-with-cpp
+ endif
+
@@ -400,6 +409,15 @@
ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
endif