aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-12-14 13:42:06 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-12-14 13:42:06 +0000
commit7efa77ad7c5cf3417d7fe8c89dbe949a8facca79 (patch)
tree3f75766ca5d76f6dd2367c583fb90b16519be03a /www/firefox-esr
parent306f0fd83b4dd6ed92cb257b5f916bc09f1583bf (diff)
downloadports-7efa77ad7c5cf3417d7fe8c89dbe949a8facca79.tar.gz
ports-7efa77ad7c5cf3417d7fe8c89dbe949a8facca79.zip
Notes
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile5
-rw-r--r--www/firefox-esr/distinfo4
-rw-r--r--www/firefox-esr/files/extra-bug78053124
-rw-r--r--www/firefox-esr/files/firefox.desktop.in6
-rw-r--r--www/firefox-esr/files/patch-browser-app-nsBrowserApp.cpp2
-rw-r--r--www/firefox-esr/files/patch-bug945046130
-rw-r--r--www/firefox-esr/files/patch-bug94656044
7 files changed, 182 insertions, 33 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index fb2281c5eca8..9547e60765df 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= firefox
-DISTVERSION= 24.1.0
-PORTREVISION= 1
+DISTVERSION= 24.2.0
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source
@@ -13,7 +12,7 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}esr.source
MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
-BUILD_DEPENDS= nspr>=4.10:${PORTSDIR}/devel/nspr \
+BUILD_DEPENDS= nspr>=4.10.2:${PORTSDIR}/devel/nspr \
nss>=3.15:${PORTSDIR}/security/nss \
sqlite3>=3.7.17:${PORTSDIR}/databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
diff --git a/www/firefox-esr/distinfo b/www/firefox-esr/distinfo
index fb50062e02de..1279ff0a28a8 100644
--- a/www/firefox-esr/distinfo
+++ b/www/firefox-esr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-24.1.0esr.source.tar.bz2) = 92dcc2bacaf00cb36004236440635613a27d1528e927d205b424a92c8f58b35e
-SIZE (firefox-24.1.0esr.source.tar.bz2) = 119816789
+SHA256 (firefox-24.2.0esr.source.tar.bz2) = 5a8aa526a0250e9faf2175ef610d63b2c91a5d01de7f9633b8781905dd2b9dcf
+SIZE (firefox-24.2.0esr.source.tar.bz2) = 119820009
diff --git a/www/firefox-esr/files/extra-bug780531 b/www/firefox-esr/files/extra-bug780531
deleted file mode 100644
index 26859a9bde10..000000000000
--- a/www/firefox-esr/files/extra-bug780531
+++ /dev/null
@@ -1,24 +0,0 @@
---- configure.in~
-+++ configure.in
-@@ -5364,15 +5364,18 @@ AC_SUBST(MOZ_SRTP)
-
- dnl Use integers over floats for audio on B2G and Android, because audio
- dnl backends for those platforms don't support floats.
--if test "$OS_TARGET" = "Android"; then
-+case "$target" in
-+*-android*|*-linuxandroid*|*-dragonfly*|*-freebsd*|*-netbsd*|*-openbsd*)
- MOZ_SAMPLE_TYPE_S16=1
- AC_DEFINE(MOZ_SAMPLE_TYPE_S16)
- AC_SUBST(MOZ_SAMPLE_TYPE_S16)
--else
-+;;
-+*)
- MOZ_SAMPLE_TYPE_FLOAT32=1
- AC_DEFINE(MOZ_SAMPLE_TYPE_FLOAT32)
- AC_SUBST(MOZ_SAMPLE_TYPE_FLOAT32)
--fi
-+;;
-+esac
-
- dnl ========================================================
- dnl = Disable Speech API code
diff --git a/www/firefox-esr/files/firefox.desktop.in b/www/firefox-esr/files/firefox.desktop.in
index 27b81ce2bdd7..63e28f69768f 100644
--- a/www/firefox-esr/files/firefox.desktop.in
+++ b/www/firefox-esr/files/firefox.desktop.in
@@ -182,10 +182,10 @@ Comment[vi]=Duyệt web
Comment[wa]=Naivyî avå les waibes
Comment[zh_CN]=浏览 Web
Comment[zh_TW]=瀏覽網頁
-Exec=@MOZILLA@ %u
+Exec=@MOZILLA@ %U
Icon=@FIREFOX_ICON@
-StartupNotify=false
+StartupNotify=true
Terminal=false
Type=Application
-Categories=Application;Network;
+Categories=Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
diff --git a/www/firefox-esr/files/patch-browser-app-nsBrowserApp.cpp b/www/firefox-esr/files/patch-browser-app-nsBrowserApp.cpp
index b8ff70542e0d..b3f59e4eeb6d 100644
--- a/www/firefox-esr/files/patch-browser-app-nsBrowserApp.cpp
+++ b/www/firefox-esr/files/patch-browser-app-nsBrowserApp.cpp
@@ -4,7 +4,7 @@
TriggerQuirks();
#endif
-+ setenv("MOZ_PLUGIN_PATH", "%%LOCALBASE%%/lib/browser_plugins/symlinks/gecko19:%%LOCALBASE%%/lib/npapi/symlinks/firefox", 0);
++ setenv("MOZ_PLUGIN_PATH", "%%LOCALBASE%%/lib/browser_plugins/symlinks/gecko", 0);
int gotCounters;
#if defined(XP_UNIX)
struct rusage initialRUsage;
diff --git a/www/firefox-esr/files/patch-bug945046 b/www/firefox-esr/files/patch-bug945046
new file mode 100644
index 000000000000..2da32f78cd4c
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug945046
@@ -0,0 +1,130 @@
+diff --git config/system-headers config/system-headers
+index 432cba6..18a9627 100644
+--- config/system-headers
++++ config/system-headers
+@@ -1157,3 +1157,4 @@ unicode/uenum.h
+ unicode/unum.h
+ unicode/ustring.h
+ #endif
++libutil.h
+diff --git js/src/config/system-headers js/src/config/system-headers
+index 432cba6..18a9627 100644
+--- js/src/config/system-headers
++++ js/src/config/system-headers
+@@ -1157,3 +1157,4 @@ unicode/uenum.h
+ unicode/unum.h
+ unicode/ustring.h
+ #endif
++libutil.h
+diff --git toolkit/library/Makefile.in toolkit/library/Makefile.in
+index 9975621..b4b037d 100644
+--- toolkit/library/Makefile.in
++++ toolkit/library/Makefile.in
+@@ -289,6 +289,10 @@ OS_LIBS += $(call EXPAND_LIBNAME,kvm)
+ EXTRA_DSO_LDOPTS += -Wl,--warn-unresolved-symbols
+ endif
+
++ifeq ($(OS_ARCH),FreeBSD)
++OS_LIBS += $(call EXPAND_LIBNAME,util)
++endif
++
+ ifeq ($(OS_ARCH),WINNT)
+ OS_LIBS += $(call EXPAND_LIBNAME,shell32 ole32 version winspool comdlg32 imm32 msimg32 shlwapi psapi ws2_32 dbghelp rasapi32 rasdlg iphlpapi uxtheme setupapi secur32 sensorsapi portabledeviceguids windowscodecs wininet wbemuuid)
+ ifdef ACCESSIBILITY
+diff --git xpcom/base/nsMemoryReporterManager.cpp xpcom/base/nsMemoryReporterManager.cpp
+index b8147c8..0ffb34e 100644
+--- xpcom/base/nsMemoryReporterManager.cpp
++++ xpcom/base/nsMemoryReporterManager.cpp
+@@ -153,6 +153,43 @@ static nsresult GetResidentFast(int64_t
+ return GetResident(n);
+ }
+
++#ifdef __FreeBSD__
++#include <libutil.h>
++
++static nsresult
++GetKinfoVmentrySelf(int64_t* prss)
++{
++ int cnt;
++ struct kinfo_vmentry *vmmap, *kve;
++ if ((vmmap = kinfo_getvmmap(getpid(), &cnt)) == NULL)
++ return NS_ERROR_FAILURE;
++
++ if (prss)
++ *prss = 0;
++
++ for (int i = 0; i < cnt; i++) {
++ kve = &vmmap[i];
++ if (prss)
++ *prss += kve->kve_private_resident;
++ }
++
++ free(vmmap);
++ return NS_OK;
++}
++
++#define HAVE_PRIVATE_REPORTER
++static nsresult
++GetPrivate(int64_t* aN)
++{
++ int64_t priv;
++ nsresult rv = GetKinfoVmentrySelf(&priv);
++ if (NS_SUCCEEDED(rv))
++ *aN = priv * getpagesize();
++
++ return NS_OK;
++}
++#endif // FreeBSD
++
+ #elif defined(SOLARIS)
+
+ #include <procfs.h>
+@@ -327,6 +364,24 @@ static nsresult GetResidentFast(int64_t
+ }
+
+ #define HAVE_PRIVATE_REPORTER
++static nsresult
++GetPrivate(int64_t* aN)
++{
++ PROCESS_MEMORY_COUNTERS_EX pmcex;
++ pmcex.cb = sizeof(PROCESS_MEMORY_COUNTERS_EX);
++
++ if (!GetProcessMemoryInfo(
++ GetCurrentProcess(),
++ (PPROCESS_MEMORY_COUNTERS) &pmcex, sizeof(pmcex))) {
++ return NS_ERROR_FAILURE;
++ }
++
++ *aN = pmcex.PrivateUsage;
++ return NS_OK;
++}
++#endif // XP_<PLATFORM>
++
++#ifdef HAVE_PRIVATE_REPORTER
+ class PrivateReporter MOZ_FINAL : public MemoryReporterBase
+ {
+ public:
+@@ -339,21 +394,10 @@ public:
+
+ NS_IMETHOD GetAmount(int64_t *aAmount)
+ {
+- PROCESS_MEMORY_COUNTERS_EX pmcex;
+- pmcex.cb = sizeof(PROCESS_MEMORY_COUNTERS_EX);
+-
+- if (!GetProcessMemoryInfo(
+- GetCurrentProcess(),
+- (PPROCESS_MEMORY_COUNTERS) &pmcex, sizeof(pmcex))) {
+- return NS_ERROR_FAILURE;
+- }
+-
+- *aAmount = pmcex.PrivateUsage;
+- return NS_OK;
++ return GetPrivate(aAmount);
+ }
+ };
+-
+-#endif // XP_<PLATFORM>
++#endif
+
+ #ifdef HAVE_VSIZE_AND_RESIDENT_REPORTERS
+ class VsizeReporter MOZ_FINAL : public MemoryReporterBase
diff --git a/www/firefox-esr/files/patch-bug946560 b/www/firefox-esr/files/patch-bug946560
new file mode 100644
index 000000000000..e2560bd0d0c3
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug946560
@@ -0,0 +1,44 @@
+diff --git xpcom/base/nsMemoryInfoDumper.cpp xpcom/base/nsMemoryInfoDumper.cpp
+index 0b2f78c..d857374 100644
+--- xpcom/base/nsMemoryInfoDumper.cpp
++++ xpcom/base/nsMemoryInfoDumper.cpp
+@@ -30,7 +30,7 @@
+ #include <unistd.h>
+ #endif
+
+-#ifdef XP_LINUX
++#if defined(XP_LINUX) || defined(__FreeBSD__)
+ #include <fcntl.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+@@ -109,7 +109,7 @@ private:
+
+ } // anonymous namespace
+
+-#ifdef XP_LINUX // {
++#if defined(XP_LINUX) || defined(__FreeBSD__) // {
+ namespace {
+
+ /*
+@@ -548,7 +548,7 @@ nsMemoryInfoDumper::~nsMemoryInfoDumper(
+ /* static */ void
+ nsMemoryInfoDumper::Initialize()
+ {
+-#ifdef XP_LINUX
++#if defined(XP_LINUX) || defined(__FreeBSD__)
+ SignalPipeWatcher::Create();
+ FifoWatcher::MaybeCreate();
+ #endif
+diff --git xpcom/base/nsMemoryReporterManager.cpp xpcom/base/nsMemoryReporterManager.cpp
+index 8c65665..8f6d0e9 100644
+--- xpcom/base/nsMemoryReporterManager.cpp
++++ xpcom/base/nsMemoryReporterManager.cpp
+@@ -824,7 +824,7 @@ nsMemoryReporterManager::Init()
+ RegisterReporter(new mozilla::dmd::DMDReporter);
+ #endif
+
+-#if defined(XP_LINUX)
++#if defined(XP_LINUX) || defined(__FreeBSD__)
+ nsMemoryInfoDumper::Initialize();
+ #endif
+