aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-10-09 19:44:02 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-10-09 19:44:02 +0000
commit27d7526f5508ddca4d55abf1cceebf59d7555ec6 (patch)
tree2aafb300ba5b67e63c9f5a7d8dcdeaaa4ea6922f /www/firefox-esr
parent85c21cbae3f9f251bc60cd332ff5ca1c6117292a (diff)
downloadports-27d7526f5508ddca4d55abf1cceebf59d7555ec6.tar.gz
ports-27d7526f5508ddca4d55abf1cceebf59d7555ec6.zip
Notes
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile4
-rw-r--r--www/firefox-esr/files/mozconfig.in4
2 files changed, 5 insertions, 3 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 4d6386d1e28c..857f950a868b 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -8,7 +8,7 @@
PORTNAME= firefox
PORTVERSION= 1.0.7
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -40,6 +40,7 @@ USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/mozilla
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+KRB5_HOME?= /usr
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
--exclude */macbuild/*\
@@ -145,6 +146,7 @@ post-extract::
-e 's|@LOCALBASE@|${LOCALBASE}|' \
-e 's|@FAKEDIR@|${FAKEDIR}|' \
-e 's|@PERL@|${PERL5}|' \
+ -e 's|@KRB5_HOME@|${KRB5_HOME}|' \
<${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
@${SED} -e 's|@PORTNAME_ICON@|${PORTNAME_ICON}|' \
<${FILESDIR}/${PORTNAME}.desktop.in >${WRKDIR}/${PORTNAME}.desktop
diff --git a/www/firefox-esr/files/mozconfig.in b/www/firefox-esr/files/mozconfig.in
index ad642f0bf408..57f2d808beb0 100644
--- a/www/firefox-esr/files/mozconfig.in
+++ b/www/firefox-esr/files/mozconfig.in
@@ -33,7 +33,7 @@ ac_add_options --with-system-jpeg=@LOCALBASE@
ac_add_options --with-system-zlib
ac_add_options --with-system-png=@LOCALBASE@
ac_add_options --with-system-nspr
-ac_add_options --with-gssapi=/usr
+ac_add_options --with-gssapi=@KRB5_HOME@
######################################################################
# set compile/link features
ac_add_options --with-pthreads
@@ -50,7 +50,7 @@ ac_add_options --disable-installer
ac_add_options --enable-single-profile
ac_add_options --disable-profilesharing
ac_add_options --enable-image-decoders=all
-ac_add_options --enable-extensions="cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,p3p,gnomevfs"
+ac_add_options --enable-extensions="default"
######################################################################
# conditional from port Makefile
#if test -n "$WITH_REORDER"; then