aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2010-08-29 15:17:43 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2010-08-29 15:17:43 +0000
commit901e6d609d43fc3f053f1f06851aa0ad3679c41c (patch)
tree8eb3a08711935b668cbdfeb52c430c760e7baca0 /www/firefox-esr
parent817bbe5ae9aa15c13065e740451bcc6cad9b4d74 (diff)
downloadports-901e6d609d43fc3f053f1f06851aa0ad3679c41c.tar.gz
ports-901e6d609d43fc3f053f1f06851aa0ad3679c41c.zip
Notes
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/files/patch-js_src_jsnum.cpp12
-rw-r--r--www/firefox-esr/files/patch-toolkit_library_Makefile.in11
-rw-r--r--www/firefox-esr/files/patch-xpcom_base_nsStackWalk.cpp11
3 files changed, 29 insertions, 5 deletions
diff --git a/www/firefox-esr/files/patch-js_src_jsnum.cpp b/www/firefox-esr/files/patch-js_src_jsnum.cpp
index cf29e7c9a869..c997f4c6b8ba 100644
--- a/www/firefox-esr/files/patch-js_src_jsnum.cpp
+++ b/www/firefox-esr/files/patch-js_src_jsnum.cpp
@@ -1,5 +1,5 @@
---- js/src/jsnum.cpp.orig 2009-10-14 18:03:30.000000000 +0200
-+++ js/src/jsnum.cpp 2009-10-15 21:49:44.000000000 +0200
+--- js/src/jsnum.cpp.orig 2010-01-05 22:35:17.000000000 -0500
++++ js/src/jsnum.cpp 2010-01-11 05:10:19.000000000 -0500
@@ -43,6 +43,9 @@
/*
* JS number type and wrapper class.
@@ -10,14 +10,16 @@
#ifdef XP_OS2
#define _PC_53 PC_53
#define _MCW_EM MCW_EM
-@@ -691,8 +694,16 @@
+@@ -691,8 +694,18 @@
#else
+#if defined(__FreeBSD__) && __FreeBSD_version >= 601000
++#if __BSD_VISIBLE == 0
++#error __BSD_VISIBLE is zero, so fedisableexcept is not defined
++#endif
+#include <fenv.h>
-+#define FIX_FPU() (fedisableexcept(FE_ALL_EXCEPT))
-+
++#define FIX_FPU() ((void)fedisableexcept(FE_ALL_EXCEPT))
+#else
+
#define FIX_FPU() ((void)0)
diff --git a/www/firefox-esr/files/patch-toolkit_library_Makefile.in b/www/firefox-esr/files/patch-toolkit_library_Makefile.in
new file mode 100644
index 000000000000..d905acd5bf67
--- /dev/null
+++ b/www/firefox-esr/files/patch-toolkit_library_Makefile.in
@@ -0,0 +1,11 @@
+--- toolkit/library/Makefile.in.orig 2010-01-11 12:13:08.000000000 -0500
++++ toolkit/library/Makefile.in 2010-01-11 12:15:05.000000000 -0500
+@@ -181,7 +181,7 @@
+ export:: $(RDF_UTIL_SRC_CPPSRCS) $(INTL_UNICHARUTIL_UTIL_CPPSRCS)
+ $(INSTALL) $^ .
+
+-EXTRA_DSO_LDOPTS += $(LIBS_DIR) $(EXTRA_DSO_LIBS)
++EXTRA_DSO_LDOPTS += -Wl,--warn-unresolved-symbols -Wl,--as-needed $(LIBS_DIR) $(EXTRA_DSO_LIBS)
+
+ ifdef MOZ_ENABLE_LIBXUL
+ include $(srcdir)/libxul-rules.mk
diff --git a/www/firefox-esr/files/patch-xpcom_base_nsStackWalk.cpp b/www/firefox-esr/files/patch-xpcom_base_nsStackWalk.cpp
new file mode 100644
index 000000000000..3485b1509ad1
--- /dev/null
+++ b/www/firefox-esr/files/patch-xpcom_base_nsStackWalk.cpp
@@ -0,0 +1,11 @@
+--- xpcom/base/nsStackWalk.cpp.orig 2010-01-11 02:11:49.000000000 -0500
++++ xpcom/base/nsStackWalk.cpp 2010-01-11 02:13:26.000000000 -0500
+@@ -1132,7 +1132,7 @@
+ #define __USE_GNU
+ #endif
+
+-#if defined(HAVE_LIBDL) || defined(XP_MACOSX)
++#if defined(HAVE_LIBDL) || defined(XP_MACOSX) || defined(__FreeBSD__)
+ #include <dlfcn.h>
+ #endif
+