aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-24 16:33:53 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-24 16:33:53 +0000
commita44095ee68cd67d68a70fbb5e2dac98cd63cb6da (patch)
tree6761bfc0b4b4713079709ea16d7453e0a5a51f8b /www/firefox-esr
parent24f5414a1a61aca883a3f3cdc7db66c4ff450494 (diff)
downloadports-a44095ee68cd67d68a70fbb5e2dac98cd63cb6da.tar.gz
ports-a44095ee68cd67d68a70fbb5e2dac98cd63cb6da.zip
Notes
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile17
-rw-r--r--www/firefox-esr/files/mozconfig.in5
-rw-r--r--www/firefox-esr/files/patch-build_unix_mozilla-xpcom.pc.in8
-rw-r--r--www/firefox-esr/pkg-message24
4 files changed, 51 insertions, 3 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 1d30ff57a4a3..d9033fcf7dc5 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
@@ -43,6 +43,9 @@ USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/mozilla
PKGINSTALL= ${WRKDIR}/pkg-install
+PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
+ mozilla-nspr mozilla-nss mozilla-plugin
+
JPI_LIST?=\
${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
@@ -53,7 +56,8 @@ OPTIONS= DEBUG "Build a debugging image" off \
HEADERS "Install headers and IDL files" off \
LOGGING "Enable additional log messages" off \
OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
- XFT "Enable support for anti-aliased fonts" on
+ XFT "Enable support for anti-aliased fonts" on \
+ SMB "Enable smb:// URI support using gnomevfs" off
.include <bsd.port.pre.mk>
@@ -79,6 +83,11 @@ CONFIGURE_ENV+= WITHOUT_XFT=yes
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
.endif # !defined(WITHOUT_XFT)
+.if defined(WITH_SMB)
+USE_GNOME+= gnomevfs2
+CONFIGURE_ENV+= WITH_SMB=yes
+.endif # defined(WITH_SMB)
+
CPPFLAGS+= -I${X11BASE}/include -I${LOCALBASE}/include
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= -L${X11BASE}/lib
@@ -128,6 +137,10 @@ post-patch:
${SED} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+.for ii in ${PKGCONFIG_FILES}
+ @${PERL} -pi -e 's|mozilla-|firefox-|g' \
+ ${WRKSRC}/build/unix/${ii}.pc.in
+.endfor
pre-configure:
@if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
diff --git a/www/firefox-esr/files/mozconfig.in b/www/firefox-esr/files/mozconfig.in
index 68a01ee39874..2f4aa77dd545 100644
--- a/www/firefox-esr/files/mozconfig.in
+++ b/www/firefox-esr/files/mozconfig.in
@@ -42,7 +42,7 @@ ac_add_options --disable-pedantic
ac_add_options --disable-profilesharing
ac_add_options --disable-installer
ac_add_options --enable-image-decoders=png,gif,jpeg,bmp
-ac_add_options --enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices,inspector,venkman
+ac_add_options --enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices,inspector,venkman,gnomevfs
######################################################################
# conditional from port Makefile
#if test -n "$WITH_REORDER"; then
@@ -68,4 +68,7 @@ if test -z "$WITHOUT_XFT"; then
else
ac_add_options --disable-xft
fi # test -z "$WITHOUT_XFT"
+if test -z "$WITH_SMB"; then
+ ac_add_options --disable-gnomevfs
+fi # test -z "$WITH_SMB"
######################################################################
diff --git a/www/firefox-esr/files/patch-build_unix_mozilla-xpcom.pc.in b/www/firefox-esr/files/patch-build_unix_mozilla-xpcom.pc.in
new file mode 100644
index 000000000000..4e982a5443e8
--- /dev/null
+++ b/www/firefox-esr/files/patch-build_unix_mozilla-xpcom.pc.in
@@ -0,0 +1,8 @@
+--- build/unix/mozilla-xpcom.pc.in.orig Thu Jun 24 12:23:09 2004
++++ build/unix/mozilla-xpcom.pc.in Thu Jun 24 12:23:18 2004
+@@ -8,4 +8,4 @@
+ Version: %MOZILLA_VERSION%
+ Requires: mozilla-nspr = %MOZILLA_VERSION%
+ Libs: -L${libdir} -lxpcom
+-Cflags: -I${includedir}/xpcom -I${includedir}/string
++Cflags: -I${includedir}/xpcom -I${includedir}/string -I${includedir}
diff --git a/www/firefox-esr/pkg-message b/www/firefox-esr/pkg-message
index ed9bc51041fc..77f3adad8770 100644
--- a/www/firefox-esr/pkg-message
+++ b/www/firefox-esr/pkg-message
@@ -1,4 +1,28 @@
======================================================================
+README FOR GNOMEVFS SUPPORT:
+Gnomevfs support is optional (disabled by default), and can be enabled by
+building with ``-DWITH_SMB''.
+
+It is new and currently has issues to be ironed out.
+
+You must delete your components registry for gnomevfs to register:
+
+rm ~/.mozilla/firefox/default.*/compreg.dat
+
+SMB issues:
+Network group, machine, and share browsing does not work correctly.
+
+SFTP:
+Only sftp access using public key authentication works. To easily
+setup public key authentication to "remote_host":
+
+ssh-keygen -t dsa
+cat ~/.ssh/id_dsa.pub | ssh remote_host "cat >> .ssh/authorized_keys"
+
+The SSH sever on remote_host must allow pub key authentication.
+
+======================================================================
+
Any bug reports should be addressed to the maintainers at:
gnome@FreeBSD.org
You may also Cc: freebsd-ports@freebsd.org. Please do not send