aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-02-28 18:20:53 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-02-28 18:20:53 +0000
commitfafd21c92020167fcbbb15fef8427c9f667fe42c (patch)
tree784626488ccb848a183cbf7b2be0dc596bab9329 /www/firefox-esr
parentf0c52cc7bcaff4081070c0d1ddd7e24b4c8da691 (diff)
Notes
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-bug161891434
2 files changed, 35 insertions, 1 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 2c42147da8c1..cfe206b558c5 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firefox
DISTVERSION= 68.5.0
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-bug1618914 b/www/firefox-esr/files/patch-bug1618914
new file mode 100644
index 000000000000..28d722fa6255
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1618914
@@ -0,0 +1,34 @@
+[Wayland] Fall back to ftruncate if posix_fallocate isn't supported by filesystem.
+
+diff --git widget/gtk/WindowSurfaceWayland.cpp widget/gtk/WindowSurfaceWayland.cpp
+index 9a73326399bd5..9e42a7f1c5d18 100644
+--- widget/gtk/WindowSurfaceWayland.cpp
++++ widget/gtk/WindowSurfaceWayland.cpp
+@@ -235,23 +235,24 @@
+ #ifdef HAVE_POSIX_FALLOCATE
+ do {
+ ret = posix_fallocate(fd, 0, aSize);
+ } while (ret == EINTR);
+- if (ret != 0) {
++ if (ret == 0) {
++ return fd;
++ } else if (ret != EINVAL && ret != EOPNOTSUPP) {
+ close(fd);
+ MOZ_CRASH_UNSAFE_PRINTF(
+ "posix_fallocate() fails on %s size %d error code %d\n", filename,
+ aSize, ret);
+ }
+-#else
++#endif
+ do {
+ ret = ftruncate(fd, aSize);
+ } while (ret < 0 && errno == EINTR);
+ if (ret < 0) {
+ close(fd);
+ MOZ_CRASH_UNSAFE_PRINTF("ftruncate() fails on %s size %d error code %d\n",
+ filename, aSize, ret);
+ }
+-#endif
+
+ return fd;
+ }