aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-sync
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2010-01-11 07:31:40 +0000
committerXin LI <delphij@FreeBSD.org>2010-01-11 07:31:40 +0000
commit17200acc4f4a0d3c6ca50eea670887ddecb0b507 (patch)
tree1ebc5cf249c12ed5a7fe2e8eb5e902f48b006497 /www/firefox-sync
parentfbd9766bfb7f1c5de84dbe0ae776a8c0ed144698 (diff)
Notes
Diffstat (limited to 'www/firefox-sync')
-rw-r--r--www/firefox-sync/Makefile5
-rw-r--r--www/firefox-sync/distinfo6
-rw-r--r--www/firefox-sync/files/patch-Makefile2
3 files changed, 7 insertions, 6 deletions
diff --git a/www/firefox-sync/Makefile b/www/firefox-sync/Makefile
index fdc6d1e89ab6..afdcfeb5d102 100644
--- a/www/firefox-sync/Makefile
+++ b/www/firefox-sync/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= weave
-PORTVERSION= 1.0b3
+DISTVERSION= 1.0rc
+PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://files.roorback.net/ \
LOCAL/glarkin
@@ -43,7 +44,7 @@ PLIST_SUB+= XPI_XPIDIR="${XPI_DIR:S,^${PREFIX}/,,}" \
post-install:
${MKDIR} ${XPI_DIR}
- (cd ${XPI_DIR}; tar -xf ${WRKSRC}/dist/xpi/weave-${PORTVERSION}-rel.xpi)
+ (cd ${XPI_DIR}; tar -xf ${WRKSRC}/dist/xpi/weave-${DISTVERSION}-rel.xpi)
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${XPI_DIR}/
${CHMOD} -R a+rX,go-w ${XPI_DIR}/
${MKDIR} ${PREFIX}/lib/firefox3/extensions
diff --git a/www/firefox-sync/distinfo b/www/firefox-sync/distinfo
index cc1dad8db07b..b74518f7134f 100644
--- a/www/firefox-sync/distinfo
+++ b/www/firefox-sync/distinfo
@@ -1,3 +1,3 @@
-MD5 (weave-1.0b3.tar.bz2) = cd4cd8956c6e23dd3207e250913a93de
-SHA256 (weave-1.0b3.tar.bz2) = 29c0a20871ab00f3028451198f1848e2165d6c669bc5ebe6bbc1d672f66450b9
-SIZE (weave-1.0b3.tar.bz2) = 398324
+MD5 (weave-1.0rc.tar.bz2) = 1228a2efb8fe5643ce1836ba2fe26013
+SHA256 (weave-1.0rc.tar.bz2) = 752b1444d8d09327e5aabb28637c064f1e10964622d9fc3988c228b6ad2da54d
+SIZE (weave-1.0rc.tar.bz2) = 430186
diff --git a/www/firefox-sync/files/patch-Makefile b/www/firefox-sync/files/patch-Makefile
index 367cffe37f39..6c2c30cec285 100644
--- a/www/firefox-sync/files/patch-Makefile
+++ b/www/firefox-sync/files/patch-Makefile
@@ -5,7 +5,7 @@
ifeq ($(buildid),)
date := $(shell date -u +%Y%m%d%H%M)
- revid := $(shell hg tip --template '{node|short}')
-+ revid := 0ff643d2615e
++ revid := d2a85a1d1d17
buildid := $(date)-$(revid)
buildid_short := $(date)
endif