aboutsummaryrefslogtreecommitdiff
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-12-04 22:05:43 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-12-04 22:05:43 +0000
commit4835940e84c5cbcbf8b2d7609265b5b2dd9079a6 (patch)
tree940a8fbad7656ce9fe892a5baade3624866aaeef /www/firefox/Makefile
parent48214282617dc951b3a0589ac10004f0114405ae (diff)
downloadports-4835940e84c5cbcbf8b2d7609265b5b2dd9079a6.tar.gz
ports-4835940e84c5cbcbf8b2d7609265b5b2dd9079a6.zip
- Add support for GECKO_PLIST_PRE_FILES and GECKO_PLIST_PRE_DIRS to
add files or directories to plist. - *Really* remove share/idl if empty in firefox
Notes
Notes: svn path=/head/; revision=150419
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 9a4d78c69b3e..2a797cb273f1 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -8,7 +8,7 @@
PORTNAME= firefox
DISTVERSION= 1.5
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -28,6 +28,9 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GCC= 3.4+
+GECKO_PLIST_PRE_FILES= lib/${MOZILLA}/chrome/icons/default/default.xpm
+GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/icons
+
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
MOZ_OPTIONS= --enable-application=browser \
@@ -69,6 +72,7 @@ post-patch:
pre-install:
${ECHO_CMD} 'share/applications/${MOZILLA}.desktop' >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${PLIST}
${ECHO_CMD} 'share/pixmaps/${FIREFOX_ICON}' >> ${PLIST}
.if !defined(WITHOUT_NEWTAB)
${ECHO_CMD} >> ${SYSTEM_PREFS}
@@ -76,13 +80,6 @@ pre-install:
${ECHO_CMD} "pref(\"browser.link.open_external\", 3);" \
>> ${SYSTEM_PREFS}
.endif # !defined(WITHOUT_NEWTAB)
- ${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${PLIST}
- ${ECHO_CMD} "lib/${MOZILLA}/chrome/icons/default/default.xpm" >> ${PLIST}
- ${ECHO_CMD} "@dirrm lib/${MOZILLA}/chrome/icons/default" >> ${PLIST}
- ${ECHO_CMD} "@dirrm lib/${MOZILLA}/chrome/icons" >> ${PLIST}
-# Dirty hack to make sure stuff gets removed right.
- ${SORT} -r ${PLIST} > ${PLIST}.tmp
- ${MV} -f ${PLIST}.tmp ${PLIST}
do-install:
if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \