aboutsummaryrefslogtreecommitdiff
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-11-30 18:22:07 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-11-30 18:31:41 +0000
commit67d9f1559aa71f3a4e90b99387a11871d00b7d8d (patch)
treee54bedbfc6a4290c2639f710f027fb643aad113a /www/firefox/Makefile
parent0a439f39b25ee0c2228b8e3c9d7b259e6b04d84c (diff)
downloadports-67d9f1559aa71f3a4e90b99387a11871d00b7d8d.tar.gz
ports-67d9f1559aa71f3a4e90b99387a11871d00b7d8d.zip
www/firefox: make dep on wasi-compiler-rt more flexible
as firefox needs matching wasi-compiler-rt, embedded llvm in rust and llvm for building and wasi-compiler-rt installs it's files in a path depending on it's full distversion, we need to know llvm/clang's full version. it's not possible to derive that programatically, as the required llvm version may not be installed at the time firefox' Makefile is being parsed. (cherry picked from commit dcc6b13daedf095da6572c27af69713ee551cb81)
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index b93ef4ba7e27..ab6318e47579 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -27,7 +27,7 @@ BUILD_DEPENDS= nspr>=4.32:devel/nspr \
zip:archivers/zip \
${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc++abi.a:devel/wasi-libcxx \
${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc \
- ${LOCALBASE}/llvm${LLVM_DEFAULT}/lib/clang/${LLVM_DEFAULT}.0.0/lib/wasi/libclang_rt.builtins-wasm32.a:devel/wasi-compiler-rt${LLVM_DEFAULT}
+ ${LOCALBASE}/llvm${LLVM_DEFAULT}/lib/clang/${LLVM_VERSION}/lib/wasi/libclang_rt.builtins-wasm32.a:devel/wasi-compiler-rt${LLVM_DEFAULT}
USE_GECKO= gecko
CONFLICTS_INSTALL= firefox-esr