aboutsummaryrefslogtreecommitdiff
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-24 16:33:53 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-24 16:33:53 +0000
commita44095ee68cd67d68a70fbb5e2dac98cd63cb6da (patch)
tree6761bfc0b4b4713079709ea16d7453e0a5a51f8b /www/firefox/Makefile
parent24f5414a1a61aca883a3f3cdc7db66c4ff450494 (diff)
downloadports-a44095ee68cd67d68a70fbb5e2dac98cd63cb6da.tar.gz
ports-a44095ee68cd67d68a70fbb5e2dac98cd63cb6da.zip
Notes
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 1d30ff57a4a3..d9033fcf7dc5 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
@@ -43,6 +43,9 @@ USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/mozilla
PKGINSTALL= ${WRKDIR}/pkg-install
+PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
+ mozilla-nspr mozilla-nss mozilla-plugin
+
JPI_LIST?=\
${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
@@ -53,7 +56,8 @@ OPTIONS= DEBUG "Build a debugging image" off \
HEADERS "Install headers and IDL files" off \
LOGGING "Enable additional log messages" off \
OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
- XFT "Enable support for anti-aliased fonts" on
+ XFT "Enable support for anti-aliased fonts" on \
+ SMB "Enable smb:// URI support using gnomevfs" off
.include <bsd.port.pre.mk>
@@ -79,6 +83,11 @@ CONFIGURE_ENV+= WITHOUT_XFT=yes
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
.endif # !defined(WITHOUT_XFT)
+.if defined(WITH_SMB)
+USE_GNOME+= gnomevfs2
+CONFIGURE_ENV+= WITH_SMB=yes
+.endif # defined(WITH_SMB)
+
CPPFLAGS+= -I${X11BASE}/include -I${LOCALBASE}/include
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= -L${X11BASE}/lib
@@ -128,6 +137,10 @@ post-patch:
${SED} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+.for ii in ${PKGCONFIG_FILES}
+ @${PERL} -pi -e 's|mozilla-|firefox-|g' \
+ ${WRKSRC}/build/unix/${ii}.pc.in
+.endfor
pre-configure:
@if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \