aboutsummaryrefslogtreecommitdiff
path: root/www/firefox10/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
diff options
context:
space:
mode:
authorPeter Wemm <peter@FreeBSD.org>2003-12-13 21:35:43 +0000
committerPeter Wemm <peter@FreeBSD.org>2003-12-13 21:35:43 +0000
commit7059589bd64b2a99cab6df938b191d4e9fce56bd (patch)
tree5f08e61f528456c64e85212ca62872ad7f7214a6 /www/firefox10/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
parent123c710bd51f7fa9a386ae7a6a7271d556a02564 (diff)
downloadports-7059589bd64b2a99cab6df938b191d4e9fce56bd.tar.gz
ports-7059589bd64b2a99cab6df938b191d4e9fce56bd.zip
Notes
Diffstat (limited to 'www/firefox10/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in')
-rw-r--r--www/firefox10/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in45
1 files changed, 45 insertions, 0 deletions
diff --git a/www/firefox10/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in b/www/firefox10/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
new file mode 100644
index 000000000000..a609c0d5d5e0
--- /dev/null
+++ b/www/firefox10/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
@@ -0,0 +1,45 @@
+--- xpcom/reflect/xptcall/src/md/unix/Makefile.in Thu Aug 14 21:00:23 2003
++++ xpcom/reflect/xptcall/src/md/unix/Makefile.in Sat Dec 13 13:02:49 2003
+@@ -49,6 +49,9 @@
+ ifeq (86,$(findstring 86,$(OS_TEST)))
+ CPPSRCS := xptcinvoke_unixish_x86.cpp xptcstubs_unixish_x86.cpp
+ endif
++ifeq (amd64,$(OS_TEST))
++CPPSRCS := xptcinvoke_amd64_freebsd.cpp xptcstubs_amd64_freebsd.cpp
++endif
+ endif
+ #
+ # New code for Linux, et. al., with gcc
+@@ -106,9 +109,15 @@
+ ASFILES := xptcinvoke_asm_osf1_alpha.s xptcstubs_asm_osf1_alpha.s
+ endif
+ #
++# FreeBSD/Alpha
++#
++ifeq ($(OS_ARCH)$(OS_TEST),FreeBSDalpha)
++CPPSRCS := xptcinvoke_freebsd_alpha.cpp xptcstubs_freebsd_alpha.cpp
++endif
++#
+ # Linux/Alpha
+ #
+-ifneq (,$(filter Linuxalpha FreeBSDalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
++ifneq (,$(filter Linuxalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
+ CPPSRCS := xptcinvoke_linux_alpha.cpp xptcstubs_linux_alpha.cpp
+ endif
+ #
+@@ -294,6 +303,15 @@
+ ifeq ($(OS_ARCH)$(OS_TEST),NetBSDsparc)
+ CPPSRCS := xptcinvoke_sparc_netbsd.cpp xptcstubs_sparc_netbsd.cpp
+ ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
++endif
++#
++# FreeBSD/SPARC64
++#
++ifeq ($(OS_ARCH),FreeBSD)
++ifneq (,$(findstring sparc,$(OS_TEST)))
++CPPSRCS := xptcinvoke_sparc64_freebsd.cpp xptcstubs_sparc64_freebsd.cpp
++ASFILES := xptcinvoke_asm_sparc64_freebsd.s xptcstubs_asm_sparcv9_solaris.s
++endif
+ endif
+ #
+ # Solaris/SPARC