aboutsummaryrefslogtreecommitdiff
path: root/www/firefox10
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-27 20:51:02 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-27 20:51:02 +0000
commit9e94e6497f64e1fa3109f3c3dde102efe77dd3e0 (patch)
treedf3a3611bab570aed7020cb9ccfbc1e69faad65b /www/firefox10
parent2f3d2c4f090a766e463f47e9659a1aef11d6ce5e (diff)
downloadports-9e94e6497f64e1fa3109f3c3dde102efe77dd3e0.tar.gz
ports-9e94e6497f64e1fa3109f3c3dde102efe77dd3e0.zip
Notes
Diffstat (limited to 'www/firefox10')
-rw-r--r--www/firefox10/Makefile1
-rw-r--r--www/firefox10/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
2 files changed, 18 insertions, 0 deletions
diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index faee9ffb4148..5eeeb7b36085 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
diff --git a/www/firefox10/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/www/firefox10/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/www/firefox10/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }