aboutsummaryrefslogtreecommitdiff
path: root/www/firefox15/files
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-11 07:16:17 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-11 07:16:17 +0000
commit6593022e89db95668f762d4db0020b296f786594 (patch)
tree5a8d9af95f916aa8c03b8ad1fcec948d0bf7d5e7 /www/firefox15/files
parent2d6ec12e4c9a5d36f260c6991f8341a98c6f71e7 (diff)
downloadports-6593022e89db95668f762d4db0020b296f786594.tar.gz
ports-6593022e89db95668f762d4db0020b296f786594.zip
Notes
Diffstat (limited to 'www/firefox15/files')
-rw-r--r--www/firefox15/files/firefox.rb (renamed from www/firefox15/files/firebird.rb)4
-rw-r--r--www/firefox15/files/mkdistfile6
-rw-r--r--www/firefox15/files/mozconfig.in3
-rw-r--r--www/firefox15/files/patch-Double.cpp2
-rw-r--r--www/firefox15/files/patch-build_unix_run-mozilla.sh27
-rw-r--r--www/firefox15/files/patch-config-mkdepend-imakemdep.h2
-rw-r--r--www/firefox15/files/patch-config-rules.mk2
-rw-r--r--www/firefox15/files/patch-config_preprocess.pl57
-rw-r--r--www/firefox15/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h2
-rw-r--r--www/firefox15/files/patch-extensions_typeaheadfind_src_nsTypeAheadFind.cpp48
-rw-r--r--www/firefox15/files/patch-extensions_typeaheadfind_src_nsTypeAheadFind.h14
-rw-r--r--www/firefox15/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp57
-rw-r--r--www/firefox15/files/patch-nspr-unix.c2
-rw-r--r--www/firefox15/files/patch-nsprpub-pr-include-md-_freebsd.cfg2
-rw-r--r--www/firefox15/files/patch-nsprpub-pr-include-md-_freebsd.h14
-rw-r--r--www/firefox15/files/patch-nsprpub-pr-src-io-prprf.c2
-rw-r--r--www/firefox15/files/patch-nsprpub-pr-src-misc-prtime.c11
-rw-r--r--www/firefox15/files/patch-security-coreconf-FreeBSD.mk2
-rw-r--r--www/firefox15/files/patch-typeaheadfind-nosound72
-rw-r--r--www/firefox15/files/patch-xpcom-reflect-xptcall-public-xptcstubsdecl.inc2
-rw-r--r--www/firefox15/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in2
-rw-r--r--www/firefox15/files/patch-xptcall-alpha2
-rw-r--r--www/firefox15/files/patch-xptcall-amd642
-rw-r--r--www/firefox15/files/patch-xptcall-ia642
-rw-r--r--www/firefox15/files/patch-xptcall-sparc642
25 files changed, 109 insertions, 232 deletions
diff --git a/www/firefox15/files/firebird.rb b/www/firefox15/files/firefox.rb
index bd3f19132620..1c970f9ee1b2 100644
--- a/www/firefox15/files/firebird.rb
+++ b/www/firefox15/files/firefox.rb
@@ -68,10 +68,10 @@ end
IO::popen("xwininfo -display #{$display} -root -tree") {
|io|
- if NAME != "firebird"
+ if NAME != "firefox"
$windows = io.grep(%r<"Mozilla"\s+"navigator:\s*browser">)
else
- $windows = io.grep(%r<MozillaFirebird-bin.*>)
+ $windows = io.grep(%r<MozillaFirefox-bin.*>)
end
}
diff --git a/www/firefox15/files/mkdistfile b/www/firefox15/files/mkdistfile
index 10cb140be958..3c3ae1744c4c 100644
--- a/www/firefox15/files/mkdistfile
+++ b/www/firefox15/files/mkdistfile
@@ -1,7 +1,7 @@
#!/bin/sh
# -*-shell-script-*-
#
-# mkdistfile -- maintainer's utility to make a firebird distfile
+# mkdistfile -- maintainer's utility to make a firefox distfile
#
# Copyright (c) 2002, Alan Eldridge
# All rights reserved.
@@ -165,7 +165,7 @@ EOF
test -d mozilla || die "No mozilla dir here."
find mozilla 2>/dev/null | egrep -f $exfile | xargs rm -fr
rm -f $exfile
-status "making firebird-$REV.tar.bz2 ..."
-tar -cjpf firebird-$REV.tar.bz2 mozilla
+status "making firefox-$REV.tar.bz2 ..."
+tar -cjpf firefox-$REV.tar.bz2 mozilla
status "done."
#EOF
diff --git a/www/firefox15/files/mozconfig.in b/www/firefox15/files/mozconfig.in
index be5fe7906f71..69405237bce0 100644
--- a/www/firefox15/files/mozconfig.in
+++ b/www/firefox15/files/mozconfig.in
@@ -43,13 +43,14 @@ ac_add_options --disable-ldap
ac_add_options --disable-pedantic
ac_add_options --disable-profilesharing
ac_add_options --disable-installer
-ac_add_options --enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices
+ac_add_options --enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices,inspector
######################################################################
# conditional from port Makefile
if test -n "$WITH_DEBUG"; then
ac_add_options --enable-debug
else
ac_add_options --disable-debug
+ ac_add_options --enable-optimize
fi # test -n "$WITH_DEBUG"
if test -n "$WITH_LOGGING"; then
ac_add_options --enable-logging
diff --git a/www/firefox15/files/patch-Double.cpp b/www/firefox15/files/patch-Double.cpp
index 5cd13e4ff4fe..26a1fa56337a 100644
--- a/www/firefox15/files/patch-Double.cpp
+++ b/www/firefox15/files/patch-Double.cpp
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- extensions/transformiix/source/base/Double.cpp.orig Thu Jan 30 09:26:46 2003
+++ extensions/transformiix/source/base/Double.cpp Sun Nov 16 01:46:42 2003
@@ -51,10 +51,10 @@
diff --git a/www/firefox15/files/patch-build_unix_run-mozilla.sh b/www/firefox15/files/patch-build_unix_run-mozilla.sh
index e7b80ed29c53..569ebc28940f 100644
--- a/www/firefox15/files/patch-build_unix_run-mozilla.sh
+++ b/www/firefox15/files/patch-build_unix_run-mozilla.sh
@@ -1,30 +1,13 @@
---- build/unix/run-mozilla.sh.orig Fri Apr 18 23:12:28 2003
-+++ build/unix/run-mozilla.sh Sat May 31 19:03:29 2003
+$FreeBSD$
+
+--- build/unix/run-mozilla.sh.orig Mon Feb 9 19:25:14 2004
++++ build/unix/run-mozilla.sh Mon Feb 9 21:18:11 2004
@@ -355,7 +355,7 @@
fi
##
## Set LD_LIBRARY_PATH
-LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
-+LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:%%PREFIX%%/lib/browser_plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
++LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:%PREFIX%%/lib/browser_plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
if [ -n "$LD_LIBRARYN32_PATH" ]
then
LD_LIBRARYN32_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARYN32_PATH+":$LD_LIBRARYN32_PATH"}
-@@ -402,7 +402,7 @@
- fi
- fi
- # Font path for Xft
--FONTCONFIG_PATH="/etc/fonts:${MOZILLA_FIVE_HOME}/res/Xft"
-+FONTCONFIG_PATH="%%PREFIX%%/etc/fonts:${MOZILLA_FIVE_HOME}/res/Xft"
- export FONTCONFIG_PATH
-
- if [ "$moz_debug" -eq 1 ]
-@@ -445,6 +445,9 @@
- #
- export MOZILLA_FIVE_HOME LD_LIBRARY_PATH
- export SHLIB_PATH LIBPATH LIBRARY_PATH ADDON_PATH DYLD_LIBRARY_PATH
-+
-+MOZ_PLUGIN_PATH=%%PREFIX%%/lib/browser_plugins
-+export MOZ_PLUGIN_PATH
-
- if [ $moz_debug -eq 1 ]
- then
diff --git a/www/firefox15/files/patch-config-mkdepend-imakemdep.h b/www/firefox15/files/patch-config-mkdepend-imakemdep.h
index b688e664475d..d8b6e0b049e1 100644
--- a/www/firefox15/files/patch-config-mkdepend-imakemdep.h
+++ b/www/firefox15/files/patch-config-mkdepend-imakemdep.h
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- config/mkdepend/imakemdep.h Fri Sep 4 21:22:25 1998
+++ config/mkdepend/imakemdep.h Thu Oct 16 22:43:25 2003
@@ -278,4 +278,7 @@
diff --git a/www/firefox15/files/patch-config-rules.mk b/www/firefox15/files/patch-config-rules.mk
index ecc3c8194dcc..db3009d37ee3 100644
--- a/www/firefox15/files/patch-config-rules.mk
+++ b/www/firefox15/files/patch-config-rules.mk
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- config/rules.mk.orig Tue Aug 26 13:28:47 2003
+++ config/rules.mk Sun Feb 1 15:11:41 2004
@@ -444,7 +444,11 @@
diff --git a/www/firefox15/files/patch-config_preprocess.pl b/www/firefox15/files/patch-config_preprocess.pl
deleted file mode 100644
index a5c17665d9e9..000000000000
--- a/www/firefox15/files/patch-config_preprocess.pl
+++ /dev/null
@@ -1,57 +0,0 @@
-$FreeBSD$
-
---- config/preprocessor.pl.orig Tue Sep 2 17:53:55 2003
-+++ config/preprocessor.pl Sat Oct 18 23:00:35 2003
-@@ -73,16 +73,39 @@
- ########################################################################
-
- package main;
--use File::Spec 0.8;
-+use File::Spec;
- use File::Spec::Unix; # on all platforms, because the #include syntax is unix-based
-+use File::Basename;
-+use Cwd;
-+
-+# This code is taken from File::Spec::Unix 0.8.
-+sub rel2abs {
-+ my ($path, $base) = @_;
-+
-+ if ( ! File::Spec->file_name_is_absolute( $path ) ) {
-+ if ( !defined( $base ) || $base eq '' ) {
-+ $base = cwd() ;
-+ }
-+ elsif ( ! File::Spec->file_name_is_absolute( $base ) ) {
-+ $base = rel2abs( $base );
-+ }
-+ else {
-+ $base = File::Spec->canonpath( $base );
-+ }
-+
-+ $path = File::Spec->catdir( $base, $path );
-+ }
-+
-+ return File::Spec->canonpath( $path );
-+}
-+# End code from File::Spec::Unix
-
- sub include {
- my($stack, $filename) = @_;
- my $directory = $stack->{'variables'}->{'DIRECTORY'};
- if ($filename ne '-') {
-- $filename = File::Spec->rel2abs($filename, $directory);
-- my($volume, $path) = File::Spec->splitpath($filename);
-- $directory = File::Spec->catpath($volume, $path, '');
-+ $filename = rel2abs($filename, $directory);
-+ $directory = File::Spec->catdir(File::Basename::dirname($filename));
- }
- local $stack->{'variables'}->{'DIRECTORY'} = $directory;
- local $stack->{'variables'}->{'FILE'} = $filename;
-@@ -376,7 +399,7 @@
- my $stack = shift;
- return if $stack->disabled;
- die "argument expected\n" unless @_;
-- main::include($stack, File::Spec->catpath(File::Spec::Unix->splitpath(@_)));
-+ main::include($stack, File::Spec->catfile(File::Basename::dirname(@_), File::Basename::basename(@_)));
- }
-
- sub filter {
diff --git a/www/firefox15/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h b/www/firefox15/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h
index edc10f32f824..e22c93be389e 100644
--- a/www/firefox15/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h
+++ b/www/firefox15/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- directory/c-sdk/ldap/libraries/liblber/lber-int.h Tue Mar 26 13:53:23 2002
+++ directory/c-sdk/ldap/libraries/liblber/lber-int.h Sat Dec 13 13:02:49 2003
@@ -236,15 +236,15 @@
diff --git a/www/firefox15/files/patch-extensions_typeaheadfind_src_nsTypeAheadFind.cpp b/www/firefox15/files/patch-extensions_typeaheadfind_src_nsTypeAheadFind.cpp
new file mode 100644
index 000000000000..0a2fa7daac00
--- /dev/null
+++ b/www/firefox15/files/patch-extensions_typeaheadfind_src_nsTypeAheadFind.cpp
@@ -0,0 +1,48 @@
+$FreeBSD$
+
+--- extensions/typeaheadfind/src/nsTypeAheadFind.cpp.orig Wed Nov 19 01:20:47 2003
++++ extensions/typeaheadfind/src/nsTypeAheadFind.cpp Tue Feb 10 02:52:26 2004
+@@ -323,11 +323,11 @@
+ prefBranch->GetBoolPref("accessibility.typeaheadfind.startlinksonly",
+ &mStartLinksOnlyPref);
+
+- PRBool isSoundEnabled = PR_TRUE;
++ mIsSoundEnabled = PR_TRUE;
+ prefBranch->GetBoolPref("accessibility.typeaheadfind.enablesound",
+- &isSoundEnabled);
++ &mIsSoundEnabled);
+ nsXPIDLCString soundStr;
+- if (isSoundEnabled) {
++ if (mIsSoundEnabled && mIsSoundEnabled) {
+ prefBranch->GetCharPref("accessibility.typeaheadfind.soundURL",
+ getter_Copies(soundStr));
+ }
+@@ -758,7 +758,7 @@
+ }
+ else {
+ // No find string to backspace in!
+- if (mIsBackspaceProtectOn) {
++ if (mIsBackspaceProtectOn && mIsSoundEnabled) {
+ // This flag should be on only if the last key was a backspace.
+ // It keeps us from accidentally hitting backspace too many times and
+ // going back in history when we really just wanted to clear
+@@ -1012,7 +1012,9 @@
+
+ // Error sound (don't fire when backspace is pressed, they're
+ // trying to correct the mistake!)
+- PlayNotFoundSound();
++ if (mIsSoundEnabled) {
++ PlayNotFoundSound();
++ }
+
+ // Remove bad character from buffer, so we can continue typing from
+ // last matched character
+@@ -1059,7 +1061,7 @@
+ void
+ nsTypeAheadFind::PlayNotFoundSound()
+ {
+- if (mNotFoundSoundURL.IsEmpty()) // no sound
++ if (mNotFoundSoundURL.IsEmpty() || !mIsSoundEnabled) // no sound
+ return;
+ if (!mSoundInterface) {
+ mSoundInterface = do_CreateInstance("@mozilla.org/sound;1");
diff --git a/www/firefox15/files/patch-extensions_typeaheadfind_src_nsTypeAheadFind.h b/www/firefox15/files/patch-extensions_typeaheadfind_src_nsTypeAheadFind.h
new file mode 100644
index 000000000000..809531f726bc
--- /dev/null
+++ b/www/firefox15/files/patch-extensions_typeaheadfind_src_nsTypeAheadFind.h
@@ -0,0 +1,14 @@
+$FreeBSD$
+
+--- extensions/typeaheadfind/src/nsTypeAheadFind.h.orig Fri May 23 22:00:33 2003
++++ extensions/typeaheadfind/src/nsTypeAheadFind.h Mon Feb 9 22:21:43 2004
+@@ -194,6 +194,9 @@
+
+ nsCString mNotFoundSoundURL;
+
++ // Move the sound enabled boolean out for all methods to access.
++ PRBool mIsSoundEnabled;
++
+ // PRBool's are used instead of PRPackedBool's where the address of the
+ // boolean variable is getting passed into a method. For example:
+ // GetBoolPref("accessibility.typeaheadfind.linksonly", &mLinksOnlyPref);
diff --git a/www/firefox15/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp b/www/firefox15/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
deleted file mode 100644
index 0b0e08247101..000000000000
--- a/www/firefox15/files/patch-gfx_src_gtk_nsFontMetricsXft.cpp
+++ /dev/null
@@ -1,57 +0,0 @@
---- gfx/src/gtk/nsFontMetricsXft.cpp.save Thu Aug 7 12:14:49 2003
-+++ gfx/src/gtk/nsFontMetricsXft.cpp Thu Aug 7 12:33:45 2003
-@@ -106,6 +106,7 @@
- FcPattern *mPattern;
- FcPattern *mFontName;
- FcCharSet *mCharset;
-+ int mNotXft;
- };
-
- class nsFontXftInfo;
-@@ -1051,7 +1052,7 @@
- // font in our loaded list that supports the character
- for (PRInt32 i = 0, end = mLoadedFonts.Count(); i < end; ++i) {
- nsFontXft *font = (nsFontXft *)mLoadedFonts.ElementAt(i);
-- if (font->HasChar(PRUint32(aChar)))
-+ if (font->HasChar(PRUint32(aChar)) && font->GetXftFont())
- return font;
- }
-
-@@ -1492,7 +1493,7 @@
- // this character.
- for (PRInt32 j = 0, end = mLoadedFonts.Count(); j < end; ++j) {
- font = (nsFontXft *)mLoadedFonts.ElementAt(j);
-- if (font->HasChar(c)) {
-+ if (font->HasChar(c) && font->GetXftFont()) {
- currFont = font;
- goto FoundFont; // for speed -- avoid "if" statement
- }
-@@ -1922,6 +1923,7 @@
- FcPatternReference(mFontName);
-
- mXftFont = nsnull;
-+ mNotXft = 0;
-
- // set up our charset
- mCharset = nsnull;
-@@ -1948,7 +1950,7 @@
- XftFont *
- nsFontXft::GetXftFont(void)
- {
-- if (!mXftFont) {
-+ if (!mXftFont && !mNotXft) {
- FcPattern *pat = FcFontRenderPrepare(0, mPattern, mFontName);
- if (!pat)
- return nsnull;
-@@ -1967,8 +1969,10 @@
- FcPatternDel(pat, FC_SPACING);
-
- mXftFont = XftFontOpenPattern(GDK_DISPLAY(), pat);
-- if (!mXftFont)
-+ if (!mXftFont) {
- FcPatternDestroy(pat);
-+ mNotXft = 1;
-+ }
- }
-
- return mXftFont;
diff --git a/www/firefox15/files/patch-nspr-unix.c b/www/firefox15/files/patch-nspr-unix.c
index 6bb4ed08fb40..4a221aa9d6b3 100644
--- a/www/firefox15/files/patch-nspr-unix.c
+++ b/www/firefox15/files/patch-nspr-unix.c
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- nsprpub/pr/src/md/unix/unix.c.orig Sat May 31 18:06:04 2003
+++ nsprpub/pr/src/md/unix/unix.c Sat May 31 18:04:43 2003
@@ -65,7 +65,8 @@
diff --git a/www/firefox15/files/patch-nsprpub-pr-include-md-_freebsd.cfg b/www/firefox15/files/patch-nsprpub-pr-include-md-_freebsd.cfg
index 3ac9a34fbc70..30a28b01459b 100644
--- a/www/firefox15/files/patch-nsprpub-pr-include-md-_freebsd.cfg
+++ b/www/firefox15/files/patch-nsprpub-pr-include-md-_freebsd.cfg
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- nsprpub/pr/include/md/_freebsd.cfg.orig Wed Jan 2 18:38:25 2002
+++ nsprpub/pr/include/md/_freebsd.cfg Sun Feb 1 15:09:53 2004
@@ -91,7 +91,7 @@
diff --git a/www/firefox15/files/patch-nsprpub-pr-include-md-_freebsd.h b/www/firefox15/files/patch-nsprpub-pr-include-md-_freebsd.h
index 18f809bf396b..02923f6d3e22 100644
--- a/www/firefox15/files/patch-nsprpub-pr-include-md-_freebsd.h
+++ b/www/firefox15/files/patch-nsprpub-pr-include-md-_freebsd.h
@@ -1,11 +1,11 @@
---- nsprpub/pr/include/md/_freebsd.h.orig Thu Jan 16 15:09:12 2003
-+++ nsprpub/pr/include/md/_freebsd.h Sun Feb 1 15:21:56 2004
-@@ -48,6 +48,12 @@
- #define _PR_SI_ARCHITECTURE "x86"
- #elif defined(__alpha)
+$FreeBSD$
+
+--- nsprpub/pr/include/md/_freebsd.h.orig Sat Nov 15 23:36:13 2003
++++ nsprpub/pr/include/md/_freebsd.h Mon Feb 9 22:24:39 2004
+@@ -50,6 +50,10 @@
#define _PR_SI_ARCHITECTURE "alpha"
-+#elif defined(__sparc__)
-+#define _PR_SI_ARCHITECTURE "sparc"
+ #elif defined(__sparc__)
+ #define _PR_SI_ARCHITECTURE "sparc"
+#elif defined(__ia64__)
+#define _PR_SI_ARCHITECTURE "ia64"
+#elif defined(__amd64__)
diff --git a/www/firefox15/files/patch-nsprpub-pr-src-io-prprf.c b/www/firefox15/files/patch-nsprpub-pr-src-io-prprf.c
index 8c48ad1e08fb..29b941b60fac 100644
--- a/www/firefox15/files/patch-nsprpub-pr-src-io-prprf.c
+++ b/www/firefox15/files/patch-nsprpub-pr-src-io-prprf.c
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- nsprpub/pr/src/io/prprf.c Wed Feb 26 15:53:42 2003
+++ nsprpub/pr/src/io/prprf.c Thu Oct 16 22:50:40 2003
@@ -52,5 +52,8 @@
diff --git a/www/firefox15/files/patch-nsprpub-pr-src-misc-prtime.c b/www/firefox15/files/patch-nsprpub-pr-src-misc-prtime.c
deleted file mode 100644
index 9682808e4d9e..000000000000
--- a/www/firefox15/files/patch-nsprpub-pr-src-misc-prtime.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- nsprpub/pr/src/misc/prtime.c.orig Thu Feb 27 01:01:02 2003
-+++ nsprpub/pr/src/misc/prtime.c Thu May 22 16:46:49 2003
-@@ -1666,7 +1666,7 @@
- */
-
- #if defined(SUNOS4) || (__GLIBC__ >= 2) || defined(XP_BEOS) \
-- || defined(NETBSD)
-+ || defined(NETBSD) || defined(__FreeBSD__)
- a.tm_zone = NULL;
- a.tm_gmtoff = tm->tm_params.tp_gmt_offset + tm->tm_params.tp_dst_offset;
- #endif
diff --git a/www/firefox15/files/patch-security-coreconf-FreeBSD.mk b/www/firefox15/files/patch-security-coreconf-FreeBSD.mk
index 4f6bccff7cec..73292a7362d5 100644
--- a/www/firefox15/files/patch-security-coreconf-FreeBSD.mk
+++ b/www/firefox15/files/patch-security-coreconf-FreeBSD.mk
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- security/coreconf/FreeBSD.mk Thu Oct 16 23:03:47 2003
+++ security/coreconf/FreeBSD.mk Thu Oct 16 22:53:11 2003
@@ -44,5 +44,9 @@
diff --git a/www/firefox15/files/patch-typeaheadfind-nosound b/www/firefox15/files/patch-typeaheadfind-nosound
deleted file mode 100644
index 9cc1d3506fb0..000000000000
--- a/www/firefox15/files/patch-typeaheadfind-nosound
+++ /dev/null
@@ -1,72 +0,0 @@
---- extensions/typeaheadfind/src/nsTypeAheadFind.cpp.orig Sun Feb 8 01:13:31 2004
-+++ extensions/typeaheadfind/src/nsTypeAheadFind.cpp Sun Feb 8 01:19:17 2004
-@@ -323,11 +323,11 @@
- prefBranch->GetBoolPref("accessibility.typeaheadfind.startlinksonly",
- &mStartLinksOnlyPref);
-
-- PRBool isSoundEnabled = PR_TRUE;
-+ mIsSoundEnabled = PR_TRUE;
- prefBranch->GetBoolPref("accessibility.typeaheadfind.enablesound",
-- &isSoundEnabled);
-+ &mIsSoundEnabled);
- nsXPIDLCString soundStr;
-- if (isSoundEnabled) {
-+ if (mIsSoundEnabled) {
- prefBranch->GetCharPref("accessibility.typeaheadfind.soundURL",
- getter_Copies(soundStr));
- }
-@@ -612,7 +612,7 @@
- return NS_OK;
- }
-
-- if (!mIsSoundInitialized) {
-+ if (!mIsSoundInitialized && mIsSoundEnabled) {
- // This makes sure system sound library is loaded so that
- // there's no lag before the first sound is played
- // by waiting for the first keystroke, we still get the startup time benefits.
-@@ -760,11 +760,13 @@
- // It keeps us from accidentally hitting backspace too many times and
- // going back in history when we really just wanted to clear
- // the find string.
-+ if (mIsSoundEnabled) {
- nsCOMPtr<nsISound> soundInterface =
- do_CreateInstance("@mozilla.org/sound;1");
- if (soundInterface) {
- soundInterface->Beep(); // beep to warn
- }
-+ }
- mIsBackspaceProtectOn = PR_FALSE;
- }
- else {
-@@ -1009,7 +1011,9 @@
-
- // Error sound (don't fire when backspace is pressed, they're
- // trying to correct the mistake!)
-- PlayNotFoundSound();
-+ if (mIsSoundEnabled) {
-+ PlayNotFoundSound();
-+ }
-
- // Remove bad character from buffer, so we can continue typing from
- // last matched character
-@@ -1056,7 +1060,7 @@
- void
- nsTypeAheadFind::PlayNotFoundSound()
- {
-- if (mNotFoundSoundURL.IsEmpty()) // no sound
-+ if (mNotFoundSoundURL.IsEmpty() || !mIsSoundEnabled) // no sound
- return;
- if (!mSoundInterface) {
- mSoundInterface = do_CreateInstance("@mozilla.org/sound;1");
---- extensions/typeaheadfind/src/nsTypeAheadFind.h.orig Sun Feb 8 01:11:53 2004
-+++ extensions/typeaheadfind/src/nsTypeAheadFind.h Sun Feb 8 01:19:29 2004
-@@ -194,6 +194,9 @@
-
- nsCString mNotFoundSoundURL;
-
-+ // Move the sound enabled boolean out for all methods to access.
-+ PRBool mIsSoundEnabled;
-+
- // PRBool's are used instead of PRPackedBool's where the address of the
- // boolean variable is getting passed into a method. For example:
- // GetBoolPref("accessibility.typeaheadfind.linksonly", &mLinksOnlyPref);
diff --git a/www/firefox15/files/patch-xpcom-reflect-xptcall-public-xptcstubsdecl.inc b/www/firefox15/files/patch-xpcom-reflect-xptcall-public-xptcstubsdecl.inc
index 94ae99042c41..dea21b7325a0 100644
--- a/www/firefox15/files/patch-xpcom-reflect-xptcall-public-xptcstubsdecl.inc
+++ b/www/firefox15/files/patch-xpcom-reflect-xptcall-public-xptcstubsdecl.inc
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- xpcom/reflect/xptcall/public/xptcstubsdecl.inc.orig Sun Feb 1 15:39:59 2004
+++ xpcom/reflect/xptcall/public/xptcstubsdecl.inc Sun Feb 1 15:40:11 2004
@@ -8,7 +8,7 @@
diff --git a/www/firefox15/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in b/www/firefox15/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
index fcde57b85b3a..c0af6bf2df9d 100644
--- a/www/firefox15/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
+++ b/www/firefox15/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig Thu Aug 14 21:00:23 2003
+++ xpcom/reflect/xptcall/src/md/unix/Makefile.in Sun Feb 1 15:06:40 2004
@@ -49,6 +49,9 @@
diff --git a/www/firefox15/files/patch-xptcall-alpha b/www/firefox15/files/patch-xptcall-alpha
index 29631a98e61e..6052f3ecf6dc 100644
--- a/www/firefox15/files/patch-xptcall-alpha
+++ b/www/firefox15/files/patch-xptcall-alpha
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- xpcom/reflect/xptcall/src/md/unix/xptcinvoke_freebsd_alpha.cpp.orig Tue May 27 01:37:25 2003
+++ xpcom/reflect/xptcall/src/md/unix/xptcinvoke_freebsd_alpha.cpp Tue May 27 01:37:00 2003
@@ -0,0 +1,184 @@
diff --git a/www/firefox15/files/patch-xptcall-amd64 b/www/firefox15/files/patch-xptcall-amd64
index 3227cad02182..541d40207aa7 100644
--- a/www/firefox15/files/patch-xptcall-amd64
+++ b/www/firefox15/files/patch-xptcall-amd64
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- /dev/null Wed Dec 31 16:00:00 1969
+++ xpcom/reflect/xptcall/src/md/unix/xptcinvoke_amd64_freebsd.cpp Thu Oct 16 22:59:43 2003
@@ -0,0 +1,174 @@
diff --git a/www/firefox15/files/patch-xptcall-ia64 b/www/firefox15/files/patch-xptcall-ia64
index 9cd07f7ddbb2..65e17ebb6c12 100644
--- a/www/firefox15/files/patch-xptcall-ia64
+++ b/www/firefox15/files/patch-xptcall-ia64
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- xpcom/reflect/xptcall/src/md/unix/xptcinvoke_asm_ipf64.s.orig Sun Jul 20 00:05:32 2003
+++ xpcom/reflect/xptcall/src/md/unix/xptcinvoke_asm_ipf64.s Sun Jul 20 00:06:37 2003
@@ -8,6 +8,7 @@
diff --git a/www/firefox15/files/patch-xptcall-sparc64 b/www/firefox15/files/patch-xptcall-sparc64
index 9599a8a71336..13745acf9f4f 100644
--- a/www/firefox15/files/patch-xptcall-sparc64
+++ b/www/firefox15/files/patch-xptcall-sparc64
@@ -1,3 +1,5 @@
+$FreeBSD$
+
--- /dev/null Mon May 26 13:22:00 2003
+++ xpcom/reflect/xptcall/src/md/unix/xptcstubs_sparc64_freebsd.cpp Mon May 26 04:12:55 2003
@@ -0,0 +1,123 @@