aboutsummaryrefslogtreecommitdiff
path: root/www/firefox35/files/patch-security-coreconf-FreeBSD.mk
diff options
context:
space:
mode:
authorPeter Wemm <peter@FreeBSD.org>2003-12-13 21:35:43 +0000
committerPeter Wemm <peter@FreeBSD.org>2003-12-13 21:35:43 +0000
commit7059589bd64b2a99cab6df938b191d4e9fce56bd (patch)
tree5f08e61f528456c64e85212ca62872ad7f7214a6 /www/firefox35/files/patch-security-coreconf-FreeBSD.mk
parent123c710bd51f7fa9a386ae7a6a7271d556a02564 (diff)
Port to amd64 (note: needs ld-elf.so.1 bugfix to actually work)
I've taken a chance and split the sparc64 and alpha mega-diffs up because sparc64 patched the result of alpha's patches, and amd64 needed to do the same again - but it was sorted lexically before alpha/sparc64. I've grouped the xptcall patches together since they are standalone and split up and merged the other infrastructure jumbo-patches. I also attempted to sync up the nspr vs firebird diffs for sparc64 and alpha because they disagreed. HOWEVER... While this port 'depends' on the nspr port, it doesn't actually *use* it. It should probably be removed from the LIB_DEPENDS list. Note that the amd64 xptcall code came from SuSE via the mozilla bugzilla database.
Notes
Notes: svn path=/head/; revision=95748
Diffstat (limited to 'www/firefox35/files/patch-security-coreconf-FreeBSD.mk')
-rw-r--r--www/firefox35/files/patch-security-coreconf-FreeBSD.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/www/firefox35/files/patch-security-coreconf-FreeBSD.mk b/www/firefox35/files/patch-security-coreconf-FreeBSD.mk
new file mode 100644
index 000000000000..4f6bccff7cec
--- /dev/null
+++ b/www/firefox35/files/patch-security-coreconf-FreeBSD.mk
@@ -0,0 +1,12 @@
+--- security/coreconf/FreeBSD.mk Thu Oct 16 23:03:47 2003
++++ security/coreconf/FreeBSD.mk Thu Oct 16 22:53:11 2003
+@@ -44,5 +44,9 @@
+ CPU_ARCH = alpha
+ else
++ifeq ($(OS_TEST),amd64)
++CPU_ARCH = amd64
++else
+ CPU_ARCH = x86
++endif
+ endif
+