aboutsummaryrefslogtreecommitdiff
path: root/www/firefox35/files
diff options
context:
space:
mode:
authorMarcel Moolenaar <marcel@FreeBSD.org>2009-11-11 00:43:15 +0000
committerMarcel Moolenaar <marcel@FreeBSD.org>2009-11-11 00:43:15 +0000
commit6190222f2a06bb672665e390df6c1bfe1f2c7230 (patch)
tree9a03a4cff709bd6ecf931c137dcdf217bcc344fc /www/firefox35/files
parent0175e1c433c15210265d93efe0f93a6c99e16908 (diff)
Notes
Diffstat (limited to 'www/firefox35/files')
-rw-r--r--www/firefox35/files/patch-content-xslt-public-txDouble.h2
-rw-r--r--www/firefox35/files/patch-security-coreconf-FreeBSD.mk16
-rw-r--r--www/firefox35/files/patch-xpcom-reflect-xptcall-src-xptcprivate.h20
3 files changed, 31 insertions, 7 deletions
diff --git a/www/firefox35/files/patch-content-xslt-public-txDouble.h b/www/firefox35/files/patch-content-xslt-public-txDouble.h
index 959fef17233a..cd4acfc534bf 100644
--- a/www/firefox35/files/patch-content-xslt-public-txDouble.h
+++ b/www/firefox35/files/patch-content-xslt-public-txDouble.h
@@ -5,7 +5,7 @@
#ifdef __FreeBSD__
#include <ieeefp.h>
-#ifdef __alpha__
-+#if defined (__alpha__) || defined (__powerpc__) || defined (__sparc__)
++#if !defined(__amd64__) && !defined(__i386__)
static fp_except_t allmask = FP_X_INV|FP_X_OFL|FP_X_UFL|FP_X_DZ|FP_X_IMP;
#else
static fp_except_t allmask = FP_X_INV|FP_X_OFL|FP_X_UFL|FP_X_DZ|FP_X_IMP|FP_X_DNML;
diff --git a/www/firefox35/files/patch-security-coreconf-FreeBSD.mk b/www/firefox35/files/patch-security-coreconf-FreeBSD.mk
index f82f5f02b9ff..992a34b3d1f5 100644
--- a/www/firefox35/files/patch-security-coreconf-FreeBSD.mk
+++ b/www/firefox35/files/patch-security-coreconf-FreeBSD.mk
@@ -1,12 +1,15 @@
---- security/coreconf/FreeBSD.mk.orig 2009-07-30 17:30:28.000000000 +0200
-+++ security/coreconf/FreeBSD.mk 2009-08-17 22:29:03.510890513 +0200
-@@ -45,8 +45,20 @@
+--- security/coreconf/FreeBSD.mk.orig 2008-07-12 07:28:59.000000000 -0700
++++ security/coreconf/FreeBSD.mk 2009-11-09 22:42:09.000000000 -0800
+@@ -45,8 +45,24 @@
ifeq ($(OS_TEST),alpha)
CPU_ARCH = alpha
else
+ifeq ($(OS_TEST),amd64)
+CPU_ARCH = amd64
+else
++ifeq ($(OS_TEST),ia64)
++CPU_ARCH = ia64
++else
+ifeq ($(OS_TEST),powerpc)
+CPU_ARCH = powerpc
+else
@@ -18,10 +21,11 @@
+endif
+endif
+endif
++endif
OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -Wno-switch -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
-@@ -73,7 +85,7 @@
+@@ -73,7 +89,7 @@
DLL_SUFFIX = so.1.0
endif
@@ -30,9 +34,9 @@
ifdef MAPFILE
MKSHLIB += -Wl,--version-script,$(MAPFILE)
endif
-@@ -82,4 +94,4 @@
+@@ -82,4 +98,4 @@
G++INCLUDES = -I/usr/include/g++
-INCLUDES += -I/usr/X11R6/include
-+#INCLUDES += -I/usr/X11R6/include
++#INCLUDES += -I/usr/local/include
diff --git a/www/firefox35/files/patch-xpcom-reflect-xptcall-src-xptcprivate.h b/www/firefox35/files/patch-xpcom-reflect-xptcall-src-xptcprivate.h
new file mode 100644
index 000000000000..0440ce0a263f
--- /dev/null
+++ b/www/firefox35/files/patch-xpcom-reflect-xptcall-src-xptcprivate.h
@@ -0,0 +1,20 @@
+--- xpcom/reflect/xptcall/src/xptcprivate.h.orig 2009-11-09 21:43:49.000000000 -0800
++++ xpcom/reflect/xptcall/src/xptcprivate.h 2009-11-09 21:44:05.000000000 -0800
+@@ -45,7 +45,7 @@
+
+ class xptiInterfaceEntry;
+
+-#if !defined(__ia64) || (!defined(__hpux) && !defined(__linux__))
++#if !defined(__ia64)
+ #define STUB_ENTRY(n) NS_IMETHOD Stub##n() = 0;
+ #else
+ #define STUB_ENTRY(n) NS_IMETHOD Stub##n(PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64) = 0;
+@@ -62,7 +62,7 @@
+ #undef STUB_ENTRY
+ #undef SENTINEL_ENTRY
+
+-#if !defined(__ia64) || (!defined(__hpux) && !defined(__linux__))
++#if !defined(__ia64)
+ #define STUB_ENTRY(n) NS_IMETHOD Stub##n();
+ #else
+ #define STUB_ENTRY(n) NS_IMETHOD Stub##n(PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64,PRUint64);