aboutsummaryrefslogtreecommitdiff
path: root/www/firefox35
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-19 05:18:14 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-19 05:18:14 +0000
commit24a35882acb4d27812aa08d07c47e02f65762906 (patch)
tree98221232e8aa9c974d1fde11a4d76600dd291a38 /www/firefox35
parent9daf9b3b459ede74fbd531dd7bdea5c2de47092a (diff)
downloadports-24a35882acb4d27812aa08d07c47e02f65762906.tar.gz
ports-24a35882acb4d27812aa08d07c47e02f65762906.zip
Notes
Diffstat (limited to 'www/firefox35')
-rw-r--r--www/firefox35/files/patch-browser_app_Makefile.in10
-rw-r--r--www/firefox35/files/patch-toolkit_xre_nsAppRunner.cpp10
2 files changed, 20 insertions, 0 deletions
diff --git a/www/firefox35/files/patch-browser_app_Makefile.in b/www/firefox35/files/patch-browser_app_Makefile.in
new file mode 100644
index 000000000000..0fee861b9f72
--- /dev/null
+++ b/www/firefox35/files/patch-browser_app_Makefile.in
@@ -0,0 +1,10 @@
+--- browser/app/Makefile.in.orig Sat Jun 19 00:39:09 2004
++++ browser/app/Makefile.in Sat Jun 19 00:39:55 2004
+@@ -75,6 +75,7 @@
+ $(STATIC_COMPONENTS_LINKER_PATH) \
+ $(EXTRA_DSO_LIBS) \
+ $(DIST)/lib/$(LIB_PREFIX)xulapp_s.$(LIB_SUFFIX) \
++ -lgthread-2.0 \
+ $(MOZ_JS_LIBS) \
+ $(XPCOM_LIBS) \
+ $(NSPR_LIBS) \
diff --git a/www/firefox35/files/patch-toolkit_xre_nsAppRunner.cpp b/www/firefox35/files/patch-toolkit_xre_nsAppRunner.cpp
new file mode 100644
index 000000000000..68f43996813d
--- /dev/null
+++ b/www/firefox35/files/patch-toolkit_xre_nsAppRunner.cpp
@@ -0,0 +1,10 @@
+--- toolkit/xre/nsAppRunner.cpp.orig Sat Jun 19 00:37:07 2004
++++ toolkit/xre/nsAppRunner.cpp Sat Jun 19 00:37:39 2004
+@@ -1710,6 +1710,7 @@
+ // in nsAppShell::Create, but we need to get in before gtk
+ // has been initialized to make sure everything is running
+ // consistently.
++ g_thread_init(NULL);
+ if (CheckArg("install"))
+ gdk_rgb_set_install(TRUE);
+