aboutsummaryrefslogtreecommitdiff
path: root/www/firefox35
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2010-08-29 15:17:43 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2010-08-29 15:17:43 +0000
commit901e6d609d43fc3f053f1f06851aa0ad3679c41c (patch)
tree8eb3a08711935b668cbdfeb52c430c760e7baca0 /www/firefox35
parent817bbe5ae9aa15c13065e740451bcc6cad9b4d74 (diff)
downloadports-901e6d609d43fc3f053f1f06851aa0ad3679c41c.tar.gz
ports-901e6d609d43fc3f053f1f06851aa0ad3679c41c.zip
Notes
Diffstat (limited to 'www/firefox35')
-rw-r--r--www/firefox35/files/patch-toolkit_library_Makefile.in11
-rw-r--r--www/firefox35/files/patch-xpcom_base_nsStackWalk.cpp11
2 files changed, 22 insertions, 0 deletions
diff --git a/www/firefox35/files/patch-toolkit_library_Makefile.in b/www/firefox35/files/patch-toolkit_library_Makefile.in
new file mode 100644
index 000000000000..5a6726c3bef7
--- /dev/null
+++ b/www/firefox35/files/patch-toolkit_library_Makefile.in
@@ -0,0 +1,11 @@
+--- toolkit/library/Makefile.in.orig 2010-01-11 23:57:11.000000000 -0500
++++ toolkit/library/Makefile.in 2010-01-11 23:58:08.000000000 -0500
+@@ -181,7 +181,7 @@
+ export:: $(RDF_UTIL_SRC_CPPSRCS) $(INTL_UNICHARUTIL_UTIL_CPPSRCS)
+ $(INSTALL) $^ .
+
+-EXTRA_DSO_LDOPTS += $(LIBS_DIR) $(EXTRA_DSO_LIBS)
++EXTRA_DSO_LDOPTS += -Wl,--warn-unresolved-symbols -Wl,--as-needed $(LIBS_DIR) $(EXTRA_DSO_LIBS)
+
+ ifdef MOZ_ENABLE_LIBXUL
+ include $(srcdir)/libxul-rules.mk
diff --git a/www/firefox35/files/patch-xpcom_base_nsStackWalk.cpp b/www/firefox35/files/patch-xpcom_base_nsStackWalk.cpp
new file mode 100644
index 000000000000..c51d22aad3c3
--- /dev/null
+++ b/www/firefox35/files/patch-xpcom_base_nsStackWalk.cpp
@@ -0,0 +1,11 @@
+--- xpcom/base/nsStackWalk.cpp.orig 2010-01-11 23:06:47.000000000 -0500
++++ xpcom/base/nsStackWalk.cpp 2010-01-11 23:07:29.000000000 -0500
+@@ -1124,7 +1124,7 @@
+ #define __USE_GNU
+ #endif
+
+-#if defined(HAVE_LIBDL) || defined(XP_MACOSX)
++#if defined(HAVE_LIBDL) || defined(XP_MACOSX) || defined(__FreeBSD__)
+ #include <dlfcn.h>
+ #endif
+