aboutsummaryrefslogtreecommitdiff
path: root/www/firefox35
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-12 00:04:40 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-12 00:04:40 +0000
commit2d0cba2617626af7a15f6e5b2ad9919721fddbe5 (patch)
treef46bf941776c90eedf9a26d6edb9e943bc1b1198 /www/firefox35
parent3ec31f90a392b3db04d1680ff51ffd4ba6c59730 (diff)
downloadports-2d0cba2617626af7a15f6e5b2ad9919721fddbe5.tar.gz
ports-2d0cba2617626af7a15f6e5b2ad9919721fddbe5.zip
Notes
Diffstat (limited to 'www/firefox35')
-rw-r--r--www/firefox35/Makefile29
-rw-r--r--www/firefox35/distinfo4
-rw-r--r--www/firefox35/files/Extensions.rdf37
-rw-r--r--www/firefox35/files/firefox.rb2
-rw-r--r--www/firefox35/files/mozconfig.in5
-rw-r--r--www/firefox35/files/patch-25086222
-rw-r--r--www/firefox35/files/patch-25506760
-rw-r--r--www/firefox35/files/patch-25631618
-rw-r--r--www/firefox35/pkg-deinstall.in1
-rw-r--r--www/firefox35/pkg-install.in6
10 files changed, 23 insertions, 161 deletions
diff --git a/www/firefox35/Makefile b/www/firefox35/Makefile
index 1168c9a59e8f..d93b0795a297 100644
--- a/www/firefox35/Makefile
+++ b/www/firefox35/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= firefox
-PORTVERSION= 0.9.3
+PORTVERSION= 1.0.1.p
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
-MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-source
+MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${REALVERSION}
+DISTNAME= ${PORTNAME}-1.0PR-source
MAINTAINER= gnome@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
@@ -19,15 +19,14 @@ COMMENT= Web browser based on the browser portion of Mozilla
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
- freetype.9:${PORTSDIR}/print/freetype2 \
- nspr4.1:${PORTSDIR}/devel/nspr
+ freetype.9:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
freetype-config:${PORTSDIR}/print/freetype2
ALL_TARGET= default
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
FAKEDIR= ${WRKDIR}/fake
-FAKESUBDIR= ${FAKEDIR}/lib/${PORTNAME}
+REALVERSION= 0.10.1
HAS_CONFIGURE= yes
ESD_LIB= libesd.so.2
LOCAL_PREFIX= ${PREFIX}/lib/${PORTNAME}
@@ -54,11 +53,12 @@ JPI_LIST?=\
${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
OPTIONS= DEBUG "Build a debugging image" off \
- HEADERS "Install headers and IDL files" off \
+ HEADERS "Install headers and IDL files" on \
LOGGING "Enable additional log messages" off \
OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
XFT "Enable support for anti-aliased fonts" on \
- SMB "Enable smb:// URI support using gnomevfs" off
+ SMB "Enable smb:// URI support using gnomevfs" off \
+ NEW_ICON "Install the new Firefox branding icon" off
.include <bsd.port.pre.mk>
@@ -160,19 +160,16 @@ pre-install:
# package, replacing the traditional pkg-plist file.
@${RM} -rf ${FAKEDIR} ${PLIST}
@${MKDIR} ${FAKEDIR}/lib/browser_plugins
- @${MKDIR} ${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${PORTVERSION}/extensions.port
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
Makefile ${MAKE_ARGS} install
.for ii in mac win
.for jj in / .jar
- @${RM} -rf ${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${PORTVERSION}/chrome/en-${ii}${jj}
+ @${RM} -rf ${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${REALVERSION}/chrome/en-${ii}${jj}
.endfor
.endfor
- @${INSTALL_DATA} ${FILESDIR}/Extensions.rdf \
- ${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${PORTVERSION}/extensions.port
- @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}|g' \
+ @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${REALVERSION}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
- @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}|g' \
+ @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${REALVERSION}|g' \
< ${MASTERDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
.if !defined (WITH_HEADERS)
@@ -221,5 +218,9 @@ post-install:
fi; \
done; \
fi
+.if defined(WITH_NEW_ICON)
+ ${INSTALL_DATA} ${WRKSRC}/other-licenses/branding/firefox/default.xpm \
+ ${LOCAL_PREFIX}/lib/${PORTNAME}-${REALVERSION}/chrome/icons/default/default.xpm
+.endif # defined(WITH_NEW_ICON)
.include <bsd.port.post.mk>
diff --git a/www/firefox35/distinfo b/www/firefox35/distinfo
index 53764c79efd8..599a26ee75b5 100644
--- a/www/firefox35/distinfo
+++ b/www/firefox35/distinfo
@@ -1,2 +1,2 @@
-MD5 (firefox-0.9.3-source.tar.bz2) = 641ebf96d2211b3c5527e88389b9687e
-SIZE (firefox-0.9.3-source.tar.bz2) = 33945173
+MD5 (firefox-1.0PR-source.tar.bz2) = ff9eae3b90b8573bf44293ea44bf3c50
+SIZE (firefox-1.0PR-source.tar.bz2) = 32380173
diff --git a/www/firefox35/files/Extensions.rdf b/www/firefox35/files/Extensions.rdf
deleted file mode 100644
index 93e1e38a5e02..000000000000
--- a/www/firefox35/files/Extensions.rdf
+++ /dev/null
@@ -1,37 +0,0 @@
-<?xml version="1.0"?>
-<RDF:RDF xmlns:em="http://www.mozilla.org/2004/em-rdf#"
- xmlns:NC="http://home.netscape.com/NC-rdf#"
- xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
- <RDF:Description RDF:about="urn:mozilla:extension:{641d8d09-7dda-4850-8228-ac0ab65e2ac9}"
- em:version="1.0"
- em:name="DOM Inspector"
- em:description="A powerful tool for viewing and manipulating documents."
- em:creator="Joe Hewitt"
- em:locked="true">
- <em:targetApplication RDF:resource="rdf:#$BfYhZ3"/>
- </RDF:Description>
- <RDF:Description RDF:about="rdf:#$BfYhZ3"
- em:id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
- em:minVersion="0.9"
- em:maxVersion="0.9" />
- <RDF:Description RDF:about="rdf:#$pfYhZ3"
- em:id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
- em:minVersion="0.9"
- em:maxVersion="0.9" />
- <RDF:Description RDF:about="urn:mozilla:theme:{972ce4c6-7e08-4474-a285-3208198ce6fd}"
- em:version="2.0"
- em:name="Firefox (default)"
- em:description="The default theme"
- em:creator="Gerich and Horlander"
- em:internalName="classic/1.0"
- em:locked="true"
- em:contributor="Mozilla Contributors">
- <em:targetApplication RDF:resource="rdf:#$pfYhZ3"/>
- </RDF:Description>
- <RDF:Seq RDF:about="urn:mozilla:theme:root">
- <RDF:li RDF:resource="urn:mozilla:theme:{972ce4c6-7e08-4474-a285-3208198ce6fd}"/>
- </RDF:Seq>
- <RDF:Seq RDF:about="urn:mozilla:extension:root">
- <RDF:li RDF:resource="urn:mozilla:extension:{641d8d09-7dda-4850-8228-ac0ab65e2ac9}"/>
- </RDF:Seq>
-</RDF:RDF>
diff --git a/www/firefox35/files/firefox.rb b/www/firefox35/files/firefox.rb
index 082607af8783..7b6e6bc42d46 100644
--- a/www/firefox35/files/firefox.rb
+++ b/www/firefox35/files/firefox.rb
@@ -33,7 +33,7 @@
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
- $Id: firebird.rb,v 1.2 2003/05/31 17:24:19 marcus Exp $
+ $Id: firefox.rb,v 1.1 2004/09/30 06:27:21 marcus Exp $
2002-12-16 Alan Eldridge <alane@geeksrus.net>
diff --git a/www/firefox35/files/mozconfig.in b/www/firefox35/files/mozconfig.in
index 2f4aa77dd545..d77584ed4edc 100644
--- a/www/firefox35/files/mozconfig.in
+++ b/www/firefox35/files/mozconfig.in
@@ -28,6 +28,7 @@ ac_add_options --with-system-jpeg=@LOCALBASE@
ac_add_options --with-system-zlib
ac_add_options --with-system-png=@LOCALBASE@
ac_add_options --with-system-mng=@LOCALBASE@
+ac_add_options --without-system-nspr
######################################################################
# set compile/link features
ac_add_options --with-pthreads
@@ -41,8 +42,10 @@ ac_add_options --disable-ldap
ac_add_options --disable-pedantic
ac_add_options --disable-profilesharing
ac_add_options --disable-installer
+ac_add_options --enable-single-profile
+ac_add_options --disable-profilesharing
ac_add_options --enable-image-decoders=png,gif,jpeg,bmp
-ac_add_options --enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices,inspector,venkman,gnomevfs
+ac_add_options --enable-extensions="cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,p3p,gnomevfs"
######################################################################
# conditional from port Makefile
#if test -n "$WITH_REORDER"; then
diff --git a/www/firefox35/files/patch-250862 b/www/firefox35/files/patch-250862
deleted file mode 100644
index 05423dc84195..000000000000
--- a/www/firefox35/files/patch-250862
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: mozilla/xpfe/communicator/resources/content/contentAreaDD.js
-===================================================================
-RCS file: /cvsroot/mozilla/xpfe/communicator/resources/content/contentAreaDD.js,v
-retrieving revision 1.32
-retrieving revision 1.32.88.1
-diff -u -r1.32 -r1.32.88.1
---- xpfe/communicator/resources/content/contentAreaDD.js 10 Jul 2002 01:23:50 -0000 1.32
-+++ xpfe/communicator/resources/content/contentAreaDD.js 27 Aug 2004 01:13:39 -0000 1.32.88.1
-@@ -53,8 +53,11 @@
- {
- var url = transferUtils.retrieveURLFromData(aXferData.data, aXferData.flavour.contentType);
-
-- // valid urls don't contain spaces ' '; if we have a space it isn't a valid url so bail out
-- if (!url || !url.length || url.indexOf(" ", 0) != -1)
-+ // valid urls don't contain spaces ' '; if we have a space it
-+ // isn't a valid url, or if it's a javascript: or data: url,
-+ // bail out
-+ if (!url || !url.length || url.indexOf(" ", 0) != -1 ||
-+ /^\s*(javascript|data):/.test(url))
- return;
-
- switch (document.firstChild.getAttribute('windowtype')) {
diff --git a/www/firefox35/files/patch-255067 b/www/firefox35/files/patch-255067
deleted file mode 100644
index cddf17ca8328..000000000000
--- a/www/firefox35/files/patch-255067
+++ /dev/null
@@ -1,60 +0,0 @@
-Index: mozilla/gfx/src/shared/gfxImageFrame.cpp
-===================================================================
-RCS file: /cvsroot/mozilla/gfx/src/shared/gfxImageFrame.cpp,v
-retrieving revision 1.26
-retrieving revision 1.26.12.1
-diff -u -r1.26 -r1.26.12.1
---- gfx/src/shared/gfxImageFrame.cpp 16 Jan 2004 23:28:48 -0000 1.26
-+++ gfx/src/shared/gfxImageFrame.cpp 27 Aug 2004 11:02:58 -0000 1.26.12.1
-@@ -72,6 +72,13 @@
- return NS_ERROR_FAILURE;
- }
-
-+ /* reject over-wide or over-tall images */
-+ const PRInt32 k64KLimit = 0x0000FFFF;
-+ if ( aWidth > k64KLimit || aHeight > k64KLimit ){
-+ NS_ERROR("image too big");
-+ return NS_ERROR_FAILURE;
-+ }
-+
- nsresult rv;
-
- mOffset.MoveTo(aX, aY);
-Index: mozilla/gfx/src/windows/nsImageWin.cpp
-===================================================================
-RCS file: /cvsroot/mozilla/gfx/src/windows/nsImageWin.cpp,v
-retrieving revision 3.130.2.1
-retrieving revision 3.130.2.1.6.1
-diff -u -r3.130.2.1 -r3.130.2.1.6.1
---- gfx/src/windows/nsImageWin.cpp 11 May 2004 21:53:49 -0000 3.130.2.1
-+++ gfx/src/windows/nsImageWin.cpp 27 Aug 2004 11:02:58 -0000 3.130.2.1.6.1
-@@ -131,6 +131,10 @@
- return NS_ERROR_UNEXPECTED;
- }
-
-+ // limit images to 64k pixels on a side (~55 feet on a 100dpi monitor)
-+ const PRInt32 k64KLimit = 0x0000FFFF;
-+ if (aWidth > k64KLimit || aHeight > k64KLimit)
-+ return NS_ERROR_FAILURE;
-
- if (mNumPaletteColors >= 0){
- // If we have a palette
-Index: mozilla/modules/libpr0n/decoders/bmp/nsBMPDecoder.cpp
-===================================================================
-RCS file: /cvsroot/mozilla/modules/libpr0n/decoders/bmp/nsBMPDecoder.cpp,v
-retrieving revision 1.24.2.1
-retrieving revision 1.24.2.1.6.1
-diff -u -r1.24.2.1 -r1.24.2.1.6.1
---- modules/libpr0n/decoders/bmp/nsBMPDecoder.cpp 13 May 2004 22:27:35 -0000 1.24.2.1
-+++ modules/libpr0n/decoders/bmp/nsBMPDecoder.cpp 27 Aug 2004 11:02:58 -0000 1.24.2.1.6.1
-@@ -274,7 +274,9 @@
- CalcBitShift();
- }
- // BMPs with negative width are invalid
-- if (mBIH.width < 0)
-+ // Reject extremely wide images to keep the math sane
-+ const PRInt32 k64KWidth = 0x0000FFFF;
-+ if (mBIH.width < 0 || mBIH.width > k64KWidth)
- return NS_ERROR_FAILURE;
-
- PRUint32 real_height = (mBIH.height > 0) ? mBIH.height : -mBIH.height;
diff --git a/www/firefox35/files/patch-256316 b/www/firefox35/files/patch-256316
deleted file mode 100644
index 147d15e5303d..000000000000
--- a/www/firefox35/files/patch-256316
+++ /dev/null
@@ -1,18 +0,0 @@
-Index: mozilla/netwerk/dns/src/nsIDNService.cpp
-===================================================================
-RCS file: /cvsroot/mozilla/netwerk/dns/src/nsIDNService.cpp,v
-retrieving revision 1.18
-retrieving revision 1.18.10.1
-diff -u -r1.18 -r1.18.10.1
---- netwerk/dns/src/nsIDNService.cpp 3 Apr 2004 07:32:18 -0000 1.18
-+++ netwerk/dns/src/nsIDNService.cpp 27 Aug 2004 11:23:21 -0000 1.18.10.1
-@@ -242,6 +242,9 @@
-
- NS_IMETHODIMP nsIDNService::Normalize(const nsACString & input, nsACString & output)
- {
-+ // protect against bogus input
-+ NS_ENSURE_TRUE(IsUTF8(input), NS_ERROR_UNEXPECTED);
-+
- nsAutoString outUTF16;
- nsresult rv = stringPrep(NS_ConvertUTF8toUTF16(input), outUTF16);
- if (NS_SUCCEEDED(rv))
diff --git a/www/firefox35/pkg-deinstall.in b/www/firefox35/pkg-deinstall.in
index 3fe1644fc054..d806dcc711dc 100644
--- a/www/firefox35/pkg-deinstall.in
+++ b/www/firefox35/pkg-deinstall.in
@@ -17,6 +17,7 @@ MOZDIR=%%MOZDIR%%
rm -rf ${MOZDIR}/chrome/overlayinfo
rm -f ${MOZDIR}/chrome/*.rdf
rm -f ${MOZDIR}/component.reg
+rm -f ${MOZDIR}/components.ini
rm -f ${MOZDIR}/components/*.dat
rm -rf ${MOZDIR}/extensions
diff --git a/www/firefox35/pkg-install.in b/www/firefox35/pkg-install.in
index 5de485a7716a..048ff1d62da3 100644
--- a/www/firefox35/pkg-install.in
+++ b/www/firefox35/pkg-install.in
@@ -26,11 +26,5 @@ rm -rf ${MOZDIR}/extensions
cd ${MOZDIR} || exit 1
./run-mozilla.sh ${REGXPCOM} || true
./run-mozilla.sh ${REGCHROME} || true
-mkdir -p ${MOZDIR}/extensions
-cp -rp ${MOZDIR}/defaults/profile/extensions/* ${MOZDIR}/extensions
-mv -f ${MOZDIR}/extensions/installed-extensions.txt \
- ${MOZDIR}/extensions/installed-extensions-processed.txt
-cp -p ${MOZDIR}/extensions.port/Extensions.rdf \
- ${MOZDIR}/extensions
exit 0