aboutsummaryrefslogtreecommitdiff
path: root/www/firefox36
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-15 06:03:30 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-15 06:03:30 +0000
commit6a6b9d788102948cfbaf51975a1ef1679eefb8bd (patch)
tree0c314d6eeed53ad4edc61e47d8b71b99a8563733 /www/firefox36
parenta2605b3968a7a88e02d840a260fc33a9e6d06bf9 (diff)
downloadports-6a6b9d788102948cfbaf51975a1ef1679eefb8bd.tar.gz
ports-6a6b9d788102948cfbaf51975a1ef1679eefb8bd.zip
Notes
Diffstat (limited to 'www/firefox36')
-rw-r--r--www/firefox36/Makefile4
-rw-r--r--www/firefox36/files/mozconfig.in2
-rw-r--r--www/firefox36/files/patch-config::mkdepend::Makefile.in10
3 files changed, 15 insertions, 1 deletions
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index e5c044e9e151..aeecbba11251 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -144,6 +144,8 @@ post-patch:
${WRKSRC}/js/src/Makefile.in
@${REINPLACE_CMD} -e 's|libesd\.so\.\d+|${ESD_LIB}|g' \
${WRKSRC}/widget/src/gtk2/nsSound.cpp
+ @${REINPLACE_CMD} -E -e 's|libcups\.so\.[0-9]+|libcups.no|g' \
+ ${WRKSRC}/gfx/src/gtk/nsDeviceContextSpecG.cpp
.for ii in modules/libpref/src/init extensions/sroaming/resources/content/prefs \
embedding/minimo
@${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/ ; \
diff --git a/www/firefox36/files/mozconfig.in b/www/firefox36/files/mozconfig.in
index 26bd8e79d771..a2c8dccba3ac 100644
--- a/www/firefox36/files/mozconfig.in
+++ b/www/firefox36/files/mozconfig.in
@@ -22,6 +22,8 @@ export PERL="@PERL@"
mk_add_options PERL=$PERL
# Configure options for installation
ac_add_options --prefix=@FAKEDIR@
+ac_add_options --x-includes=@X11BASE@/include
+ac_add_options --x-libraries=@X11BASE@/lib
######################################################################
# Use ports for these libraries
ac_add_options --with-system-jpeg=@LOCALBASE@
diff --git a/www/firefox36/files/patch-config::mkdepend::Makefile.in b/www/firefox36/files/patch-config::mkdepend::Makefile.in
new file mode 100644
index 000000000000..bace012a282e
--- /dev/null
+++ b/www/firefox36/files/patch-config::mkdepend::Makefile.in
@@ -0,0 +1,10 @@
+--- config/mkdepend/Makefile.in.orig Sun Dec 12 07:36:57 2004
++++ config/mkdepend/Makefile.in Sun Dec 12 07:37:55 2004
+@@ -57,6 +57,7 @@
+ include $(topsrcdir)/config/rules.mk
+
+ HOST_CFLAGS += -DINCLUDEDIR=\"/usr/include\" -DOBJSUFFIX=\".$(OBJ_SUFFIX)\"
++HOST_CFLAGS += $(XCFLAGS)
+
+ ifdef GNU_CC
+ _GCCDIR = $(shell $(CC) -print-file-name=include)