aboutsummaryrefslogtreecommitdiff
path: root/www/firefox36
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-01-18 22:37:11 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-01-18 22:37:11 +0000
commitfaa1047dd911a3de51604e2abc47ea61fab2345a (patch)
tree6c3a5ab8efb06f80a334dfa4ebfefe5497a12792 /www/firefox36
parentcf7f380693c143bba74cb65cb11bc5099b76e4ec (diff)
downloadports-faa1047dd911a3de51604e2abc47ea61fab2345a.tar.gz
ports-faa1047dd911a3de51604e2abc47ea61fab2345a.zip
Notes
Diffstat (limited to 'www/firefox36')
-rw-r--r--www/firefox36/Makefile2
-rw-r--r--www/firefox36/files/patch-widget_src_gtk2_nsDragService.cpp18
2 files changed, 20 insertions, 0 deletions
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index c0455b866809..66e0ef4763c2 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -4,9 +4,11 @@
#
# $FreeBSD$
# $MCom: ports-stable/www/firefox/Makefile,v 1.21 2006/10/25 01:20:12 ahze Exp $
+#
PORTNAME= firefox
DISTVERSION= 2.0.0.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
diff --git a/www/firefox36/files/patch-widget_src_gtk2_nsDragService.cpp b/www/firefox36/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/firefox36/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void