aboutsummaryrefslogtreecommitdiff
path: root/www/firefox
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2012-04-25 04:51:59 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2012-04-25 04:51:59 +0000
commit5d1bdd789c20819a25ccb974a8619073098ddb7e (patch)
tree2c310cc49005dcb307974eddaad9cf5351680b0b /www/firefox
parenta4a3a3c37ac07b0bd68369c163353bc038471c9a (diff)
Notes
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/distinfo4
-rw-r--r--www/firefox/files/patch-gfx-thebes-gfxPlatform.cpp34
-rw-r--r--www/firefox/files/patch-js-src-Makefile.in26
4 files changed, 50 insertions, 16 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index b5c67d8898ac..d99f01483f23 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= firefox
-DISTVERSION= 11.0
+DISTVERSION= 12.0
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 5a804a03a1fe..b2218ba6a033 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-11.0.source.tar.bz2) = 2fda6bcfe455c2449a8a69bc16bf13f6ea6006badb0657dae63107e52f051701
-SIZE (firefox-11.0.source.tar.bz2) = 78548401
+SHA256 (firefox-12.0.source.tar.bz2) = 9a232a10e5803b0e4a85bd986e3e88b87ccde7bdc3363ea7022d5761944dbb1d
+SIZE (firefox-12.0.source.tar.bz2) = 78956707
diff --git a/www/firefox/files/patch-gfx-thebes-gfxPlatform.cpp b/www/firefox/files/patch-gfx-thebes-gfxPlatform.cpp
new file mode 100644
index 000000000000..13ff30263c1b
--- /dev/null
+++ b/www/firefox/files/patch-gfx-thebes-gfxPlatform.cpp
@@ -0,0 +1,34 @@
+--- gfx/thebes/gfxPlatform.cpp~ 2012-02-07 11:59:39.717184907 +0000
++++ gfx/thebes/gfxPlatform.cpp 2012-02-07 13:06:01.084668445 +0000
+@@ -446,6 +446,7 @@
+ static_cast<SourceSurface*>(srcBuffer)->Release();
+ }
+
++#ifdef MOZ_TREE_CAIRO
+ void SourceSnapshotDetached(cairo_surface_t *nullSurf)
+ {
+ gfxImageSurface* origSurf =
+@@ -453,6 +454,7 @@
+
+ origSurf->SetData(&kSourceSurface, NULL, NULL);
+ }
++#endif
+
+ RefPtr<SourceSurface>
+ gfxPlatform::GetSourceSurfaceForSurface(DrawTarget *aTarget, gfxASurface *aSurface)
+@@ -522,6 +524,7 @@
+ imgSurface->Stride(),
+ format);
+
++ #ifdef MOZ_TREE_CAIRO
+ cairo_surface_t *nullSurf =
+ cairo_null_surface_create(CAIRO_CONTENT_COLOR_ALPHA);
+ cairo_surface_set_user_data(nullSurf,
+@@ -530,6 +533,7 @@
+ NULL);
+ cairo_surface_attach_snapshot(imgSurface->CairoSurface(), nullSurf, SourceSnapshotDetached);
+ cairo_surface_destroy(nullSurf);
++ #endif
+ }
+
+ srcBuffer->AddRef();
diff --git a/www/firefox/files/patch-js-src-Makefile.in b/www/firefox/files/patch-js-src-Makefile.in
index b9f4996d371f..75d431a9ed0e 100644
--- a/www/firefox/files/patch-js-src-Makefile.in
+++ b/www/firefox/files/patch-js-src-Makefile.in
@@ -1,15 +1,15 @@
---- js/src/Makefile.in.orig 2011-07-06 05:09:22.000000000 +0200
-+++ js/src/Makefile.in 2011-07-06 22:23:46.363233778 +0200
-@@ -416,7 +416,7 @@
- # END enclude sources for V8 dtoa
- #############################################
+--- js/src/Makefile.in.orig 2012-03-15 20:40:13.000000000 +0100
++++ js/src/Makefile.in 2012-03-16 10:03:18.000000000 +0100
+@@ -352,7 +352,7 @@
+ # For architectures without YARR JIT, PCRE is faster than the YARR
+ # interpreter (bug 684559).
--ifeq (,$(filter arm% sparc %86 x86_64,$(TARGET_CPU)))
-+ifeq (,$(filter arm% sparc %86 amd64 x86_64,$(TARGET_CPU)))
+-ifeq (,$(filter arm% sparc %86 x86_64 mips%,$(TARGET_CPU)))
++ifeq (,$(filter arm% sparc %86 amd64 x86_64 mips%,$(TARGET_CPU)))
- VPATH += $(srcdir)/assembler \
- $(srcdir)/assembler/wtf \
-@@ -469,6 +469,9 @@
+ VPATH += $(srcdir)/yarr/pcre \
+ $(NULL)
+@@ -418,6 +418,9 @@
else
#CPPSRCS += only_on_x86.cpp
endif
@@ -19,12 +19,12 @@
endif
ifeq (arm, $(TARGET_CPU))
#CPPSRCS += only_on_arm.cpp
-@@ -793,7 +796,7 @@
+@@ -737,7 +740,7 @@
endif # WINNT
ifeq ($(OS_ARCH),FreeBSD)
-EXTRA_LIBS += -pthread
+EXTRA_LIBS += -pthread -lc
endif
- ifeq ($(OS_ARCH),IRIX)
- ifdef USE_N32
+ ifeq ($(OS_ARCH),Linux)
+ EXTRA_LIBS += -ldl