aboutsummaryrefslogtreecommitdiff
path: root/www/firefox
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2011-08-24 23:34:00 +0000
committerFlorian Smeets <flo@FreeBSD.org>2011-08-24 23:34:00 +0000
commit8defd42d3a0426e3ba10e5dbb70b8de88df3b7c4 (patch)
treec55f640307bc5122d840985cc34c54b309e2a5fc /www/firefox
parent7bd4fe43074216c2001b332695fb43d815e0ec5f (diff)
downloadports-8defd42d3a0426e3ba10e5dbb70b8de88df3b7c4.tar.gz
ports-8defd42d3a0426e3ba10e5dbb70b8de88df3b7c4.zip
Notes
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-bugzilla-65993235
-rw-r--r--www/firefox/files/patch-js_src_jsnum.cpp2
-rw-r--r--www/firefox/files/patch-nsprpub-pr-include-md_freebsd.h2
4 files changed, 39 insertions, 2 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 8aa1ff587dad..ccd5f4b229d2 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -22,6 +22,8 @@ BUILD_DEPENDS= nspr>=4.8.8:${PORTSDIR}/devel/nspr \
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
event-1.4:${PORTSDIR}/devel/libevent
+CONFLICTS_BUILD= spidermonkey-*
+
USE_AUTOTOOLS= autoconf213
USE_GECKO= gecko
MOZ_PKGCONFIG_FILES= # empty
diff --git a/www/firefox/files/patch-bugzilla-659932 b/www/firefox/files/patch-bugzilla-659932
new file mode 100644
index 000000000000..d0698cb253c5
--- /dev/null
+++ b/www/firefox/files/patch-bugzilla-659932
@@ -0,0 +1,35 @@
+--- toolkit/xre/glxtest.cpp.orig 2011-08-11 17:41:31.000000000 -0400
++++ toolkit/xre/glxtest.cpp 2011-08-23 15:09:48.000000000 -0400
+@@ -114,6 +114,9 @@
+ typedef GLXFBConfig* (* PFNGLXQUERYEXTENSION) (Display *, int *, int *);
+ PFNGLXQUERYEXTENSION glXQueryExtension = cast<PFNGLXQUERYEXTENSION>(dlsym(libgl, "glXQueryExtension"));
+
++ typedef GLXFBConfig* (* PFNGLXQUERYVERSION) (Display *, int *, int *);
++ PFNGLXQUERYVERSION glXQueryVersion = cast<PFNGLXQUERYVERSION>(dlsym(libgl, "glXQueryVersion"));
++
+ typedef GLXFBConfig* (* PFNGLXCHOOSEFBCONFIG) (Display *, int, const int *, int *);
+ PFNGLXCHOOSEFBCONFIG glXChooseFBConfig = cast<PFNGLXCHOOSEFBCONFIG>(dlsym(libgl, "glXChooseFBConfig"));
+
+@@ -139,6 +142,7 @@
+ PFNGLGETSTRING glGetString = cast<PFNGLGETSTRING>(dlsym(libgl, "glGetString"));
+
+ if (!glXQueryExtension ||
++ !glXQueryVersion ||
+ !glXChooseFBConfig ||
+ !glXGetVisualFromFBConfig ||
+ !glXCreatePixmap ||
+@@ -158,6 +162,14 @@
+ ///// Check that the GLX extension is present /////
+ if (!glXQueryExtension(dpy, NULL, NULL))
+ fatal_error("GLX extension missing");
++
++ ///// Check that the GLX version is >= 1.3, needed for glXCreatePixmap, bug 659932 /////
++ int majorVersion, minorVersion;
++ if (!glXQueryVersion(dpy, &majorVersion, &minorVersion))
++ fatal_error("Unable to query GLX version");
++
++ if (majorVersion < 1 || (majorVersion == 1 && minorVersion < 3))
++ fatal_error("GLX version older than the required 1.3");
+
+ XSetErrorHandler(x_error_handler);
+
diff --git a/www/firefox/files/patch-js_src_jsnum.cpp b/www/firefox/files/patch-js_src_jsnum.cpp
index c997f4c6b8ba..ea2515a74d94 100644
--- a/www/firefox/files/patch-js_src_jsnum.cpp
+++ b/www/firefox/files/patch-js_src_jsnum.cpp
@@ -14,7 +14,7 @@
#else
-+#if defined(__FreeBSD__) && __FreeBSD_version >= 601000
++#if defined(__FreeBSD__)
+#if __BSD_VISIBLE == 0
+#error __BSD_VISIBLE is zero, so fedisableexcept is not defined
+#endif
diff --git a/www/firefox/files/patch-nsprpub-pr-include-md_freebsd.h b/www/firefox/files/patch-nsprpub-pr-include-md_freebsd.h
index 1f1f04bdf81c..f6d36d5c5e64 100644
--- a/www/firefox/files/patch-nsprpub-pr-include-md_freebsd.h
+++ b/www/firefox/files/patch-nsprpub-pr-include-md_freebsd.h
@@ -15,7 +15,7 @@
#define _PR_IPV6_V6ONLY_PROBE
#endif
-+#if (__FreeBSD_version >= 700016) || (__FreeBSD_version < 700000 && __FreeBSD_version >= 601103)
++#if (__FreeBSD_version >= 700016)
+#if defined(_PR_PTHREADS)
+#define _PR_HAVE_GETPROTO_R
+#define _PR_HAVE_5_ARG_GETPROTO_R