aboutsummaryrefslogtreecommitdiff
path: root/www/firefox
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2011-06-21 21:12:31 +0000
committerFlorian Smeets <flo@FreeBSD.org>2011-06-21 21:12:31 +0000
commitb114c704acc1ae20b9f25e0066b2b3117516b7c2 (patch)
tree6fc8b4915c54356a6fc00b58f388cf785d989d6a /www/firefox
parent6e774929fa5d36d3dd975d1c16f4fb8a889f6cc2 (diff)
downloadports-b114c704acc1ae20b9f25e0066b2b3117516b7c2.tar.gz
ports-b114c704acc1ae20b9f25e0066b2b3117516b7c2.zip
Notes
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile13
-rw-r--r--www/firefox/distinfo4
-rw-r--r--www/firefox/files/patch-ipc-chromium-src-base-atomicops_internals_mutex.cc10
-rw-r--r--www/firefox/files/patch-ipc-chromium-src-base-file_util.h13
-rw-r--r--www/firefox/files/patch-ipc-chromium-src-base-file_util_linux.cc11
-rw-r--r--www/firefox/files/patch-ipc-chromium-src-base-file_util_posix.cc11
-rw-r--r--www/firefox/files/patch-ipc-chromium-src-base-platform_file_posix.cc10
-rw-r--r--www/firefox/files/patch-ipc-chromium-src-base-platform_thread_posix.cc25
-rw-r--r--www/firefox/files/patch-ipc-chromium-src-base-third_party-nspr-prcpucfg.h11
-rw-r--r--www/firefox/files/patch-ipc-chromium-src-build-build_config.h11
-rw-r--r--www/firefox/files/patch-layout_generic_Makefile.in8
-rw-r--r--www/firefox/files/patch-toolkit_library_Makefile.in2
-rw-r--r--www/firefox/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in20
-rw-r--r--www/firefox/pkg-message2
14 files changed, 129 insertions, 22 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 5d9e5ba47a2a..7fe886ccabac 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= firefox
-DISTVERSION= 4.0.1
+DISTVERSION= 5.0
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -17,6 +17,8 @@ MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nspr>=4.8.7:${PORTSDIR}/devel/nspr
+LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
+ event-1.4:${PORTSDIR}/devel/libevent
USE_AUTOTOOLS= autoconf213
USE_GECKO= gecko
@@ -47,7 +49,7 @@ MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/' \
--enable-application=browser \
--enable-official-branding --disable-updater \
--enable-canvas --enable-libxul --disable-necko-wifi \
- --disable-ipc
+ --with-system-libevent=${LOCALBASE}
OPTIONS= DBUS "Enable D-BUS support" on \
PGO "Enable Profile-Guided Optimization" off \
@@ -55,7 +57,7 @@ OPTIONS= DBUS "Enable D-BUS support" on \
.include <bsd.port.pre.mk>
-WRKSRC:= ${WRKSRC}-2.0
+WRKSRC:= ${WRKDIR}/mozilla-release
GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
@@ -107,6 +109,9 @@ post-extract::
<${FILESDIR}/firefox.desktop.in >${WRKDIR}/${MOZILLA}.desktop
post-patch:
+ @${GREP} -Flr \"/proc ${WRKSRC}/ipc/chromium/src/base | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|/proc/self/fd|/dev/fd|' \
+ -e 's|/proc["/]|/compat/linux&|'
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
${WRKSRC}/storage/build/Makefile.in \
${WRKSRC}/toolkit/library/Makefile.in \
@@ -119,7 +124,7 @@ post-patch:
s|-lpthread|${PTHREAD_LIBS}|g ; \
s|echo aout|echo elf|g ; \
s|/usr/X11R6|${LOCALBASE}|g' \
- ${WRKSRC}/js/src/configure
+ ${WRKSRC}/js/src/configure.in
pre-configure:
(cd ${WRKSRC} && ${AUTOCONF})
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index d7b1002bba80..7354f655ff75 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-4.0.1.source.tar.bz2) = cf3a39877facc229a67760915341fe95095cca647faab3a7adcb70046105199c
-SIZE (firefox-4.0.1.source.tar.bz2) = 65980273
+SHA256 (firefox-5.0.source.tar.bz2) = 6bf97d80c8296f6ac576a07a87460e68066066de8bf23afe5f271cb7e1eedf44
+SIZE (firefox-5.0.source.tar.bz2) = 68782151
diff --git a/www/firefox/files/patch-ipc-chromium-src-base-atomicops_internals_mutex.cc b/www/firefox/files/patch-ipc-chromium-src-base-atomicops_internals_mutex.cc
new file mode 100644
index 000000000000..1c8dde492901
--- /dev/null
+++ b/www/firefox/files/patch-ipc-chromium-src-base-atomicops_internals_mutex.cc
@@ -0,0 +1,10 @@
+--- ipc/chromium/src/base/atomicops_internals_mutex.cc~
++++ ipc/chromium/src/base/atomicops_internals_mutex.cc
+@@ -39,6 +39,7 @@
+ * ***** END LICENSE BLOCK ***** */
+
+ #include "base/atomicops.h"
++#include "base/lock.h"
+
+ namespace base {
+ namespace subtle {
diff --git a/www/firefox/files/patch-ipc-chromium-src-base-file_util.h b/www/firefox/files/patch-ipc-chromium-src-base-file_util.h
new file mode 100644
index 000000000000..474da02969de
--- /dev/null
+++ b/www/firefox/files/patch-ipc-chromium-src-base-file_util.h
@@ -0,0 +1,13 @@
+--- ipc/chromium/src/base/file_util.h~
++++ ipc/chromium/src/base/file_util.h
+@@ -15,8 +15,9 @@
+ #elif defined(ANDROID)
+ #include <sys/stat.h>
+ #elif defined(OS_POSIX)
++#include <sys/types.h>
++#include <sys/stat.h>
+ #include <fts.h>
+-#include <sys/stat.h>
+ #endif
+
+ #include <stdio.h>
diff --git a/www/firefox/files/patch-ipc-chromium-src-base-file_util_linux.cc b/www/firefox/files/patch-ipc-chromium-src-base-file_util_linux.cc
new file mode 100644
index 000000000000..c6e4df63d444
--- /dev/null
+++ b/www/firefox/files/patch-ipc-chromium-src-base-file_util_linux.cc
@@ -0,0 +1,11 @@
+--- ipc/chromium/src/base/file_util_linux.cc~
++++ ipc/chromium/src/base/file_util_linux.cc
+@@ -28,7 +28,7 @@ bool GetShmemTempDir(FilePath* path) {
+ #ifdef ANDROID
+ return GetTempDir(path);
+ #else
+- *path = FilePath("/dev/shm");
++ *path = FilePath("/tmp");
+ return true;
+ #endif
+ }
diff --git a/www/firefox/files/patch-ipc-chromium-src-base-file_util_posix.cc b/www/firefox/files/patch-ipc-chromium-src-base-file_util_posix.cc
new file mode 100644
index 000000000000..b43b33f44510
--- /dev/null
+++ b/www/firefox/files/patch-ipc-chromium-src-base-file_util_posix.cc
@@ -0,0 +1,11 @@
+--- ipc/chromium/src/base/file_util_posix.cc~
++++ ipc/chromium/src/base/file_util_posix.cc
+@@ -30,6 +30,8 @@
+ #include "base/string_util.h"
+ #include "base/time.h"
+
++#define stat64 stat
++
+ namespace file_util {
+
+ #if defined(GOOGLE_CHROME_BUILD)
diff --git a/www/firefox/files/patch-ipc-chromium-src-base-platform_file_posix.cc b/www/firefox/files/patch-ipc-chromium-src-base-platform_file_posix.cc
new file mode 100644
index 000000000000..01111459c4bb
--- /dev/null
+++ b/www/firefox/files/patch-ipc-chromium-src-base-platform_file_posix.cc
@@ -0,0 +1,10 @@
+--- ipc/chromium/src/base/platform_file_posix.cc~
++++ ipc/chromium/src/base/platform_file_posix.cc
+@@ -9,6 +9,7 @@
+ #ifdef ANDROID
+ #include <linux/stat.h>
+ #endif
++#include <sys/stat.h>
+
+ #include "base/logging.h"
+ #include "base/string_util.h"
diff --git a/www/firefox/files/patch-ipc-chromium-src-base-platform_thread_posix.cc b/www/firefox/files/patch-ipc-chromium-src-base-platform_thread_posix.cc
new file mode 100644
index 000000000000..0b527d38d4f6
--- /dev/null
+++ b/www/firefox/files/patch-ipc-chromium-src-base-platform_thread_posix.cc
@@ -0,0 +1,25 @@
+--- ipc/chromium/src/base/platform_thread_posix.cc~
++++ ipc/chromium/src/base/platform_thread_posix.cc
+@@ -11,6 +11,7 @@
+ #include <mach/mach.h>
+ #elif defined(OS_LINUX)
+ #include <sys/syscall.h>
++#include <pthread_np.h>
+ #include <unistd.h>
+ #endif
+
+@@ -34,7 +35,13 @@ PlatformThreadId PlatformThread::Current
+ #if defined(OS_MACOSX)
+ return mach_thread_self();
+ #elif defined(OS_LINUX)
+- return syscall(__NR_gettid);
++#if __FreeBSD_version > 900030
++ return pthread_getthreadid_np();
++#else
++ long tid;
++ syscall(SYS_thr_self, &tid);
++ return tid;
++#endif
+ #endif
+ }
+
diff --git a/www/firefox/files/patch-ipc-chromium-src-base-third_party-nspr-prcpucfg.h b/www/firefox/files/patch-ipc-chromium-src-base-third_party-nspr-prcpucfg.h
new file mode 100644
index 000000000000..75bf9d8a0269
--- /dev/null
+++ b/www/firefox/files/patch-ipc-chromium-src-base-third_party-nspr-prcpucfg.h
@@ -0,0 +1,11 @@
+--- ipc/chromium/src/base/third_party/nspr/prcpucfg.h~
++++ ipc/chromium/src/base/third_party/nspr/prcpucfg.h
+@@ -34,7 +34,7 @@
+ #include "base/third_party/nspr/prcpucfg_win.h"
+ #elif defined(__APPLE__)
+ #include "base/third_party/nspr/prcpucfg_mac.h"
+-#elif defined(__linux__) || defined(ANDROID)
++#elif defined(__FreeBSD__) || defined(ANDROID)
+ #include "base/third_party/nspr/prcpucfg_linux.h"
+ #else
+ #error Provide a prcpucfg.h appropriate for your platform
diff --git a/www/firefox/files/patch-ipc-chromium-src-build-build_config.h b/www/firefox/files/patch-ipc-chromium-src-build-build_config.h
new file mode 100644
index 000000000000..076370d85a80
--- /dev/null
+++ b/www/firefox/files/patch-ipc-chromium-src-build-build_config.h
@@ -0,0 +1,11 @@
+--- ipc/chromium/src/build/build_config.h~
++++ ipc/chromium/src/build/build_config.h
+@@ -17,7 +17,7 @@
+ // A set of macros to use for platform detection.
+ #if defined(__APPLE__)
+ #define OS_MACOSX 1
+-#elif defined(__linux__) || defined(ANDROID)
++#elif defined(__FreeBSD__) || defined(ANDROID)
+ #define OS_LINUX 1
+ #elif defined(_WIN32)
+ #define OS_WIN 1
diff --git a/www/firefox/files/patch-layout_generic_Makefile.in b/www/firefox/files/patch-layout_generic_Makefile.in
index e39242751a1f..a8ca386d2911 100644
--- a/www/firefox/files/patch-layout_generic_Makefile.in
+++ b/www/firefox/files/patch-layout_generic_Makefile.in
@@ -1,9 +1,9 @@
---- layout/generic/Makefile.in.orig 2009-08-07 00:49:41.000000000 +0200
-+++ layout/generic/Makefile.in 2009-08-09 20:54:53.000000000 +0200
-@@ -187,9 +187,10 @@
- -I$(srcdir)/../../content/base/src \
+--- layout/generic/Makefile.in.orig 2011-04-26 23:21:46.000000000 +0200
++++ layout/generic/Makefile.in 2011-04-26 23:44:09.096445086 +0200
+@@ -147,9 +147,10 @@
-I$(srcdir)/../../content/html/content/src \
-I$(srcdir)/../../dom/base \
+ -I$(srcdir)/../../modules/plugin/base/src \
- $(MOZ_CAIRO_CFLAGS) \
$(NULL)
diff --git a/www/firefox/files/patch-toolkit_library_Makefile.in b/www/firefox/files/patch-toolkit_library_Makefile.in
index 35e1cd0e7f58..64b0c47e4b64 100644
--- a/www/firefox/files/patch-toolkit_library_Makefile.in
+++ b/www/firefox/files/patch-toolkit_library_Makefile.in
@@ -5,7 +5,7 @@
$(INSTALL) $^ .
-EXTRA_DSO_LDOPTS += $(LIBS_DIR) $(EXTRA_DSO_LIBS)
-+EXTRA_DSO_LDOPTS += $(LIBS_DIR) $(EXTRA_DSO_LIBS) %%PTHREAD_LIBS%%
++EXTRA_DSO_LDOPTS += $(LIBS_DIR) $(EXTRA_DSO_LIBS) -lexecinfo %%PTHREAD_LIBS%%
ifdef MOZ_ENABLE_LIBXUL
include $(srcdir)/libxul-rules.mk
diff --git a/www/firefox/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in b/www/firefox/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
index f514e6784489..169fa43553d7 100644
--- a/www/firefox/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
+++ b/www/firefox/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
@@ -1,6 +1,6 @@
---- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig 2010-02-08 15:42:25.000000000 +0100
-+++ xpcom/reflect/xptcall/src/md/unix/Makefile.in 2010-02-09 18:31:15.000000000 +0100
-@@ -72,6 +72,9 @@
+--- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig 2011-04-26 23:22:05.000000000 +0200
++++ xpcom/reflect/xptcall/src/md/unix/Makefile.in 2011-04-26 23:48:09.637442986 +0200
+@@ -94,6 +94,9 @@
DEFINES += -DKEEP_STACK_16_BYTE_ALIGNED
CPPSRCS := xptcinvoke_unixish_x86.cpp xptcstubs_unixish_x86.cpp
endif
@@ -10,7 +10,7 @@
endif
endif
-@@ -95,7 +98,7 @@
+@@ -117,7 +120,7 @@
endif
endif
# IA64 Linux
@@ -19,7 +19,7 @@
ifneq (,$(findstring ia64,$(OS_TEST)))
CPPSRCS := xptcinvoke_ipf64.cpp xptcstubs_ipf64.cpp
ASFILES := xptcstubs_asm_ipf64.s xptcinvoke_asm_ipf64.s
-@@ -108,6 +111,12 @@
+@@ -130,6 +133,12 @@
CPPSRCS := xptcinvoke_amd64_openbsd.cpp xptcstubs_amd64_openbsd.cpp
endif
#
@@ -29,10 +29,10 @@
+CPPSRCS := xptcinvoke_amd64_openbsd.cpp xptcstubs_amd64_openbsd.cpp
+endif
+#
- # BeOS/Intel (uses the same unixish_x86 code)
+ # Neutrino/Intel (uses the same unixish_x86 code)
#
- ifeq ($(OS_ARCH)$(OS_TEST),BeOSBePC)
-@@ -158,9 +167,15 @@
+ ifeq ($(OS_TARGET),NTO)
+@@ -184,9 +193,15 @@
ASFILES := xptcinvoke_asm_osf1_alpha.s xptcstubs_asm_osf1_alpha.s
endif
#
@@ -49,7 +49,7 @@
CPPSRCS := xptcinvoke_linux_alpha.cpp xptcstubs_linux_alpha.cpp
endif
#
-@@ -315,7 +330,7 @@
+@@ -341,7 +356,7 @@
#
# Linux/PPC
#
@@ -58,7 +58,7 @@
CPPSRCS := xptcinvoke_ppc_linux.cpp xptcstubs_ppc_linux.cpp
ASFILES := xptcinvoke_asm_ppc_linux.s xptcstubs_asm_ppc_linux.s
AS := $(CC) -c -x assembler-with-cpp
-@@ -393,6 +408,15 @@
+@@ -419,6 +434,15 @@
ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
endif
#
diff --git a/www/firefox/pkg-message b/www/firefox/pkg-message
index 0bb19f605909..c685efa51197 100644
--- a/www/firefox/pkg-message
+++ b/www/firefox/pkg-message
@@ -14,7 +14,7 @@ The SSH server on remote_host must allow pub key authentication.
======================================================================
-Firefox 4.0 and HTML5
+Firefox and HTML5
Certain functions used to display HTML5 elements need the sem module.