aboutsummaryrefslogtreecommitdiff
path: root/www/firefox
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2012-04-18 14:50:10 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2012-04-18 14:50:10 +0000
commit29231a1ea1650acae228eb0822d27ba2f55337d0 (patch)
treea321a6d4b84fc60fd001b30f368c3517bf57544c /www/firefox
parent10a0d05f0dc05a2707d7e23047eb88a2b0de132a (diff)
downloadports-29231a1ea1650acae228eb0822d27ba2f55337d0.tar.gz
ports-29231a1ea1650acae228eb0822d27ba2f55337d0.zip
Notes
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile9
-rw-r--r--www/firefox/distinfo4
-rw-r--r--www/firefox/files/patch-browser-app-Makefile.in15
-rw-r--r--www/firefox/files/patch-browser-app-nsBrowserApp.cpp91
-rw-r--r--www/firefox/files/patch-js-src-configure.in37
5 files changed, 81 insertions, 75 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 1d12ee76fbeb..b5c67d8898ac 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= firefox
-DISTVERSION= 10.0.3
+DISTVERSION= 11.0
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
-MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}esr/source
-DISTNAME= ${PORTNAME}-${DISTVERSION}esr.source
+MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
+DISTNAME= ${PORTNAME}-${DISTVERSION}.source
MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
@@ -26,6 +26,7 @@ CONFLICTS_BUILD= spidermonkey-*
USE_AUTOTOOLS= autoconf213
USE_GECKO= gecko
+CONFLICTS= firefox-10.*
MOZ_PKGCONFIG_FILES= # empty
USE_MOZILLA= -png -nss -dbm -jpeg -xft
MOZILLA_NAME= Firefox
@@ -57,7 +58,7 @@ OPTIONS= DBUS "Enable D-BUS support" on \
.include <bsd.port.pre.mk>
-WRKSRC:= ${WRKDIR}/mozilla-esr10
+WRKSRC:= ${WRKDIR}/mozilla-release
.if ${HAVE_GNOME:Mlibgnomeui}!=""
USE_GNOME+= libgnomeui
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index f18017fbfa47..5a804a03a1fe 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-10.0.3esr.source.tar.bz2) = 3a3af286617c56e0f2843a530144aeb87fffe4ea76c254d2604f62ac589c4a01
-SIZE (firefox-10.0.3esr.source.tar.bz2) = 75471818
+SHA256 (firefox-11.0.source.tar.bz2) = 2fda6bcfe455c2449a8a69bc16bf13f6ea6006badb0657dae63107e52f051701
+SIZE (firefox-11.0.source.tar.bz2) = 78548401
diff --git a/www/firefox/files/patch-browser-app-Makefile.in b/www/firefox/files/patch-browser-app-Makefile.in
index 12c3f0bf8392..742939363af1 100644
--- a/www/firefox/files/patch-browser-app-Makefile.in
+++ b/www/firefox/files/patch-browser-app-Makefile.in
@@ -1,6 +1,6 @@
---- browser/app/Makefile.in 2011-09-28 22:24:36.000000000 +0200
-+++ ../../ff6/mozilla-release/browser/app/Makefile.in 2011-09-02 22:15:19.000000000 +0200
-@@ -92,22 +91,35 @@
+--- browser/app/Makefile.in.orig 2012-02-22 17:06:17.000000000 +0100
++++ browser/app/Makefile.in 2012-03-07 20:46:17.000000000 +0100
+@@ -66,23 +66,36 @@
else
# Build a binary bootstrapping with XRE_main
@@ -15,6 +15,7 @@
LOCAL_INCLUDES += -I$(topsrcdir)/toolkit/xre
LOCAL_INCLUDES += -I$(topsrcdir)/xpcom/base
-LOCAL_INCLUDES += -I$(topsrcdir)/xpcom/build
+ LOCAL_INCLUDES += -I$(DEPTH)/build
-DEFINES += -DXPCOM_GLUE
-STL_FLAGS=
@@ -37,10 +38,10 @@
+LIBS += -ljprof
+endif
+
- ifndef MOZ_WINCONSOLE
- ifdef MOZ_DEBUG
- MOZ_WINCONSOLE = 1
-@@ -182,9 +194,18 @@
+ ifdef MOZ_LINKER
+ LIBS += $(ZLIB_LIBS)
+ endif
+@@ -157,9 +170,18 @@
ifneq (,$(filter-out OS2 WINNT,$(OS_ARCH)))
diff --git a/www/firefox/files/patch-browser-app-nsBrowserApp.cpp b/www/firefox/files/patch-browser-app-nsBrowserApp.cpp
index 8737fd9a2fa5..ba6fbe56405c 100644
--- a/www/firefox/files/patch-browser-app-nsBrowserApp.cpp
+++ b/www/firefox/files/patch-browser-app-nsBrowserApp.cpp
@@ -1,18 +1,23 @@
---- browser/app/nsBrowserApp.cpp 2011-09-28 22:24:36.000000000 +0200
-+++ ../../ff6/mozilla-release/browser/app/nsBrowserApp.cpp 2011-09-02 22:15:19.000000000 +0200
-@@ -36,19 +36,14 @@
+--- browser/app/nsBrowserApp.cpp 2012-03-13 02:36:38.000000000 +0100
++++ ../../../firefox-esr/work/mozilla-esr10/browser/app/nsBrowserApp.cpp 2012-03-15 10:17:09.000000000 +0100
+@@ -36,23 +36,14 @@
*
* ***** END LICENSE BLOCK ***** */
+-#include "application.ini.h"
-#include "nsXPCOMGlue.h"
- #include "nsXULAppAPI.h"
-#if defined(XP_WIN)
++#include "nsXULAppAPI.h"
+#ifdef XP_WIN
#include <windows.h>
#include <stdlib.h>
-#elif defined(XP_UNIX)
-#include <sys/time.h>
-#include <sys/resource.h>
+-#endif
+-
+-#ifdef XP_MACOSX
+-#include "MacQuirks.h"
#endif
#include <stdio.h>
@@ -21,7 +26,7 @@
#include "plstr.h"
#include "prprf.h"
-@@ -59,16 +54,11 @@
+@@ -63,16 +54,11 @@
#include "nsStringGlue.h"
#ifdef XP_WIN
@@ -40,7 +45,7 @@
static void Output(const char *fmt, ... )
{
-@@ -95,12 +85,12 @@
+@@ -99,12 +85,12 @@
{
if (*++arg == '-')
++arg;
@@ -54,8 +59,8 @@
+ return !PL_strcasecmp(++arg, s);
#endif
- return PR_FALSE;
-@@ -116,48 +106,22 @@
+ return false;
+@@ -120,35 +106,22 @@
~ScopedLogging() { NS_LogTerm(); }
};
@@ -86,22 +91,13 @@
+ ScopedLogging log;
+
nsCOMPtr<nsILocalFile> appini;
--#ifdef XP_WIN
-- // exePath comes from mozilla::BinaryPath::Get, which returns a UTF-8
-- // encoded path, so it is safe to convert it
-- nsresult rv = NS_NewLocalFile(NS_ConvertUTF8toUTF16(exePath), false,
-- getter_AddRefs(appini));
--#else
-- nsresult rv = NS_NewNativeLocalFile(nsDependentCString(exePath), false,
-- getter_AddRefs(appini));
--#endif
+- nsresult rv;
+ nsresult rv = XRE_GetBinaryPath(argv[0], getter_AddRefs(appini));
- if (NS_FAILED(rv)) {
++ if (NS_FAILED(rv)) {
+ Output("Couldn't calculate the application directory.");
- return 255;
- }
--
- appini->SetNativeLeafName(NS_LITERAL_CSTRING("application.ini"));
++ return 255;
++ }
++ appini->SetNativeLeafName(NS_LITERAL_CSTRING("application.ini"));
// Allow firefox.exe to launch XULRunner apps via -app <application.ini>
// Note that -app must be the *first* argument.
@@ -111,7 +107,7 @@
if (appDataFile && *appDataFile) {
rv = XRE_GetFileFromPath(appDataFile, getter_AddRefs(appini));
if (NS_FAILED(rv)) {
-@@ -177,12 +141,8 @@
+@@ -168,133 +141,23 @@
return 255;
}
@@ -126,10 +122,34 @@
argv[2] = argv[0];
argv += 2;
argc -= 2;
-@@ -197,90 +157,7 @@
+ }
- int result = XRE_main(argc, argv, appData);
- XRE_FreeAppData(appData);
+- int result;
+- if (appini) {
+- nsXREAppData *appData;
+- rv = XRE_CreateAppData(appini, &appData);
+- if (NS_FAILED(rv)) {
+- Output("Couldn't read application.ini");
+- return 255;
+- }
+- result = XRE_main(argc, argv, appData);
+- XRE_FreeAppData(appData);
+- } else {
+-#ifdef XP_WIN
+- // exePath comes from mozilla::BinaryPath::Get, which returns a UTF-8
+- // encoded path, so it is safe to convert it
+- rv = NS_NewLocalFile(NS_ConvertUTF8toUTF16(exePath), PR_FALSE,
+- getter_AddRefs(appini));
+-#else
+- rv = NS_NewNativeLocalFile(nsDependentCString(exePath), PR_FALSE,
+- getter_AddRefs(appini));
+-#endif
+- if (NS_FAILED(rv)) {
+- return 255;
+- }
+- result = XRE_main(argc, argv, &sAppData);
+- }
+-
- return result;
-}
-
@@ -137,6 +157,10 @@
-{
- char exePath[MAXPATHLEN];
-
+-#ifdef XP_MACOSX
+- TriggerQuirks();
+-#endif
+-
- nsresult rv = mozilla::BinaryPath::Get(argv[0], exePath);
- if (NS_FAILED(rv)) {
- Output("Couldn't calculate the application directory.\n");
@@ -173,13 +197,18 @@
- Output("Couldn't load XPCOM.\n");
- return 255;
- }
+- // Reset exePath so that it is the directory name and not the xpcom dll name
+- *lastSlash = 0;
-
- rv = XPCOMGlueLoadXULFunctions(kXULFuncs);
-- if (NS_FAILED(rv)) {
++ nsXREAppData *appData;
++ rv = XRE_CreateAppData(appini, &appData);
+ if (NS_FAILED(rv)) {
- Output("Couldn't load XRE functions.\n");
-- return 255;
-- }
--
++ Output("Couldn't read application.ini");
+ return 255;
+ }
+
-#ifdef XRE_HAS_DLL_BLOCKLIST
- XRE_SetupDllBlocklist();
-#endif
@@ -215,6 +244,8 @@
- }
-
- XPCOMGlueShutdown();
++ int result = XRE_main(argc, argv, appData);
++ XRE_FreeAppData(appData);
+ if (appEnv)
+ PR_smprintf_free(appEnv);
return result;
diff --git a/www/firefox/files/patch-js-src-configure.in b/www/firefox/files/patch-js-src-configure.in
index 27c02de1c14c..3487b16d9b2d 100644
--- a/www/firefox/files/patch-js-src-configure.in
+++ b/www/firefox/files/patch-js-src-configure.in
@@ -1,6 +1,6 @@
---- js/src/configure.in.orig 2012-01-29 11:24:33.000000000 +0100
-+++ js/src/configure.in 2012-01-30 23:30:02.051087215 +0100
-@@ -1410,7 +1410,7 @@
+--- js/src/configure.in.orig 2012-02-22 17:06:28.000000000 +0100
++++ js/src/configure.in 2012-03-07 21:03:11.000000000 +0100
+@@ -1470,7 +1470,7 @@
CPU_ARCH=sparc
;;
@@ -9,7 +9,7 @@
CPU_ARCH="$OS_TEST"
;;
-@@ -1432,7 +1432,7 @@
+@@ -1492,7 +1492,7 @@
dnl ===============================================================
INTEL_ARCHITECTURE=
case "$OS_TEST" in
@@ -18,7 +18,7 @@
INTEL_ARCHITECTURE=1
esac
-@@ -2713,6 +2713,16 @@
+@@ -2814,6 +2814,16 @@
AC_DEFINE(JS_CPU_X86)
AC_DEFINE(JS_NUNBOX32)
;;
@@ -33,32 +33,5 @@
+ AC_DEFINE(JS_PUNBOX64)
+ ;;
x86_64*-*)
- NANOJIT_ARCH=X64
- ENABLE_METHODJIT=1
-@@ -2732,6 +2742,7 @@
- AC_DEFINE(JS_NUNBOX32)
- ;;
- sparc*-*)
-+ if test ! "$HAVE_64BIT_OS" ; then
- NANOJIT_ARCH=Sparc
ENABLE_METHODJIT=1
ENABLE_MONOIC=1
-@@ -2739,6 +2750,7 @@
- ENABLE_METHODJIT_TYPED_ARRAY=1
- AC_DEFINE(JS_CPU_SPARC)
- AC_DEFINE(JS_NUNBOX32)
-+ fi
- ;;
- esac
-
-@@ -2795,6 +2807,10 @@
- i?86-*)
- AC_DEFINE(AVMPLUS_IA32)
- ;;
-+amd64*-*)
-+ AC_DEFINE(AVMPLUS_AMD64)
-+ AC_DEFINE(AVMPLUS_64BIT)
-+ ;;
- x86_64*-*)
- AC_DEFINE(AVMPLUS_AMD64)
- AC_DEFINE(AVMPLUS_64BIT)