aboutsummaryrefslogtreecommitdiff
path: root/www/firefox
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2011-09-30 15:07:49 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2011-09-30 15:07:49 +0000
commit914cc1d7fea82acfd7e41d9d5d6afafb08133cfb (patch)
tree922f10a6762a7c6d9e682aac65f193e4a521534a /www/firefox
parent1a08e74bd19746f73a3e5d11947e2d8115b07055 (diff)
downloadports-914cc1d7fea82acfd7e41d9d5d6afafb08133cfb.tar.gz
ports-914cc1d7fea82acfd7e41d9d5d6afafb08133cfb.zip
Notes
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile6
-rw-r--r--www/firefox/distinfo4
-rw-r--r--www/firefox/files/patch-xpcom-io-nsAppFileLocationProvider.cpp11
3 files changed, 16 insertions, 5 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 0c88f8687ab6..32f3f1b13fb5 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= firefox
-DISTVERSION= 7.0
-PORTREVISION= 1
+DISTVERSION= 7.0.1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -117,7 +116,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/security/manager/ssl/src/Makefile.in \
${WRKSRC}/js/src/config/mkdepend/Makefile.in \
- ${WRKSRC}/js/src/config/config.mk
+ ${WRKSRC}/js/src/config/config.mk \
+ ${WRKSRC}/xpcom/io/nsAppFileLocationProvider.cpp
@${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g ; \
s|-lpthread|${PTHREAD_LIBS}|g ; \
s|echo aout|echo elf|g ; \
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 92cad936e0f1..7026e9397537 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-7.0.source.tar.bz2) = 82d46cff57d9cae41f8d3b764808d8348a8d8c65b189f2591aa721d6346deaba
-SIZE (firefox-7.0.source.tar.bz2) = 69282568
+SHA256 (firefox-7.0.1.source.tar.bz2) = 81ecf63fca67186094d49dd5a6fe7f5dbd143a39f872ad126de38f246334fc04
+SIZE (firefox-7.0.1.source.tar.bz2) = 69278554
diff --git a/www/firefox/files/patch-xpcom-io-nsAppFileLocationProvider.cpp b/www/firefox/files/patch-xpcom-io-nsAppFileLocationProvider.cpp
new file mode 100644
index 000000000000..c16124abefa0
--- /dev/null
+++ b/www/firefox/files/patch-xpcom-io-nsAppFileLocationProvider.cpp
@@ -0,0 +1,11 @@
+--- xpcom/io/nsAppFileLocationProvider.cpp.orig 2011-09-30 15:52:07.000000000 +0200
++++ xpcom/io/nsAppFileLocationProvider.cpp 2011-09-30 15:52:40.000000000 +0200
+@@ -238,7 +238,7 @@
+ #if defined(HAVE_USR_LIB64_DIR) && defined(__LP64__)
+ "/usr/lib64/mozilla/plugins";
+ #else
+- "/usr/lib/mozilla/plugins";
++ "%%LOCALBASE%%/lib/npapi/symlinks/firefox";
+ #endif
+ rv = NS_NewNativeLocalFile(nsDependentCString(sysLPlgDir),
+ PR_FALSE, getter_AddRefs(localFile));