aboutsummaryrefslogtreecommitdiff
path: root/www/firefox
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-10-26 19:17:19 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-10-26 19:20:10 +0000
commit9b3dd988d3a475a3ad7b68166f5b19f417301549 (patch)
tree44551a82176fea6c971a9f15e7b16220f43a3f48 /www/firefox
parentbfda574d1a63d6fe5d5e7218d28c953675ffc508 (diff)
downloadports-9b3dd988d3a475a3ad7b68166f5b19f417301549.tar.gz
ports-9b3dd988d3a475a3ad7b68166f5b19f417301549.zip
www/firefox: update to 94.0 (rc2)
Release Notes (soon): https://www.mozilla.org/en-US/firefox/94.0/releasenotes/ (cherry picked from commit 6502ab1b26740b68bf710eb4aa8f927841e44a0a)
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile11
-rw-r--r--www/firefox/distinfo6
-rw-r--r--www/firefox/files/patch-bug1602730_comment524
3 files changed, 8 insertions, 33 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 1318f0451975..268b6b40f1e0 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,22 +1,21 @@
# Created by: Alan Eldridge <alane@FreeBSD.org>
PORTNAME= firefox
-DISTVERSION= 93.0
-PORTREVISION= 1
+DISTVERSION= 94.0
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
- MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
+ MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build2/source
DISTFILES= ${DISTNAME}.source${EXTRACT_SUFX}
MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nspr>=4.32:devel/nspr \
- nss>=3.70:security/nss \
- icu>=67.1,1:devel/icu \
+ nss>=3.71:security/nss \
+ icu>=69.1,1:devel/icu \
libevent>=2.1.8:devel/libevent \
- harfbuzz>=2.8.1:print/harfbuzz \
+ harfbuzz>=2.9.1:print/harfbuzz \
graphite2>=1.3.14:graphics/graphite2 \
png>=1.6.37:graphics/png \
libvpx>=1.8.2:multimedia/libvpx \
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 4d6458d79e11..bb261fd8eda0 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1632868474
-SHA256 (firefox-93.0.source.tar.xz) = a78f080f5849bc284b84299f3540934a12e961a7ea368b592ae6576ea1f97102
-SIZE (firefox-93.0.source.tar.xz) = 382181136
+TIMESTAMP = 1635270996
+SHA256 (firefox-94.0.source.tar.xz) = b5e1a5f6068f16992bb516d01875f3f04acd90f53ad5b7a11a6a5a66ff999f09
+SIZE (firefox-94.0.source.tar.xz) = 380022264
diff --git a/www/firefox/files/patch-bug1602730_comment5 b/www/firefox/files/patch-bug1602730_comment5
deleted file mode 100644
index 212221b6d5cf..000000000000
--- a/www/firefox/files/patch-bug1602730_comment5
+++ /dev/null
@@ -1,24 +0,0 @@
---- gfx/layers/composite/CompositableHost.cpp.orig 2020-09-12 21:47:42 UTC
-+++ gfx/layers/composite/CompositableHost.cpp
-@@ -10,6 +10,7 @@
- #include "Effects.h" // for EffectMask, Effect, etc
- #include "gfxUtils.h"
- #include "Layers.h"
-+#include "mozilla/EndianUtils.h"
- #include "mozilla/gfx/gfxVars.h"
- #include "mozilla/layers/LayersSurfaces.h" // for SurfaceDescriptor
- #include "mozilla/layers/TextureHost.h" // for TextureHost, etc
-@@ -89,9 +90,13 @@
- }
- MOZ_ASSERT(source);
-
-+ // Setting an alpha-mask here breaks the URL-bar on big endian (s390x)
-+ // if the typed URL is too long for the textbox (automatic scrolling needed)
-+#if MOZ_LITTLE_ENDIAN()
- RefPtr<EffectMask> effect =
- new EffectMask(source, source->GetSize(), aTransform);
- aEffects.mSecondaryEffects[EffectTypes::MASK] = effect;
-+#endif
- return true;
- }
-